aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-biology/open-ephys-gui/Manifest1
-rw-r--r--sci-biology/open-ephys-gui/files/open-ephys-gui-0.5.2.2.patch12
-rw-r--r--sci-biology/open-ephys-gui/files/open-ephys-gui-9999.patch12
-rw-r--r--sci-biology/open-ephys-gui/files/open-ephys-gui-99999999.patch12
-rw-r--r--sci-biology/open-ephys-gui/metadata.xml14
-rw-r--r--sci-biology/open-ephys-gui/open-ephys-gui-0.5.2.2.ebuild82
-rw-r--r--sci-biology/open-ephys-gui/open-ephys-gui-9999.ebuild82
-rw-r--r--sci-biology/open-ephys-gui/open-ephys-gui-99999999.ebuild82
8 files changed, 297 insertions, 0 deletions
diff --git a/sci-biology/open-ephys-gui/Manifest b/sci-biology/open-ephys-gui/Manifest
new file mode 100644
index 000000000..f4b770e24
--- /dev/null
+++ b/sci-biology/open-ephys-gui/Manifest
@@ -0,0 +1 @@
+DIST open-ephys-gui-0.5.2.2.tar.gz 64533170 BLAKE2B dc70c3eca6a8fbc7c4f6e84580fa6d5b31b837fedbdff20f532e3c01c764cbc3c51637e4fd678d048c78b6f79b4b4a5cd4d437125beeaf712f6f322e82579c85 SHA512 b6369bb0abd8ca18ff225cffab04a24915865647ee1ab5b6d83d5d6fbda3bc64d1b7db04c23deb8d29b8ff378e703b88cfa9d409f4cde62a3af34a7984427219
diff --git a/sci-biology/open-ephys-gui/files/open-ephys-gui-0.5.2.2.patch b/sci-biology/open-ephys-gui/files/open-ephys-gui-0.5.2.2.patch
new file mode 100644
index 000000000..77e401639
--- /dev/null
+++ b/sci-biology/open-ephys-gui/files/open-ephys-gui-0.5.2.2.patch
@@ -0,0 +1,12 @@
+# Add 'Gentoo' build type
+
+--- ../CMakeLists.txt 2019-12-02 22:29:24.021065669 -0300
++++ ../CMakeLists.txt 2019-12-02 22:29:11.251065418 -0300
+@@ -123,6 +123,7 @@
+ if(${CMAKE_BUILD_TYPE} STREQUAL "Debug")
+
+ elseif (${CMAKE_BUILD_TYPE} STREQUAL "Release")
++ elseif (${CMAKE_BUILD_TYPE} STREQUAL "Gentoo")
+ else()
+ message(FATAL_ERROR "Invalid build type")
+ endif()
diff --git a/sci-biology/open-ephys-gui/files/open-ephys-gui-9999.patch b/sci-biology/open-ephys-gui/files/open-ephys-gui-9999.patch
new file mode 100644
index 000000000..77e401639
--- /dev/null
+++ b/sci-biology/open-ephys-gui/files/open-ephys-gui-9999.patch
@@ -0,0 +1,12 @@
+# Add 'Gentoo' build type
+
+--- ../CMakeLists.txt 2019-12-02 22:29:24.021065669 -0300
++++ ../CMakeLists.txt 2019-12-02 22:29:11.251065418 -0300
+@@ -123,6 +123,7 @@
+ if(${CMAKE_BUILD_TYPE} STREQUAL "Debug")
+
+ elseif (${CMAKE_BUILD_TYPE} STREQUAL "Release")
++ elseif (${CMAKE_BUILD_TYPE} STREQUAL "Gentoo")
+ else()
+ message(FATAL_ERROR "Invalid build type")
+ endif()
diff --git a/sci-biology/open-ephys-gui/files/open-ephys-gui-99999999.patch b/sci-biology/open-ephys-gui/files/open-ephys-gui-99999999.patch
new file mode 100644
index 000000000..77e401639
--- /dev/null
+++ b/sci-biology/open-ephys-gui/files/open-ephys-gui-99999999.patch
@@ -0,0 +1,12 @@
+# Add 'Gentoo' build type
+
+--- ../CMakeLists.txt 2019-12-02 22:29:24.021065669 -0300
++++ ../CMakeLists.txt 2019-12-02 22:29:11.251065418 -0300
+@@ -123,6 +123,7 @@
+ if(${CMAKE_BUILD_TYPE} STREQUAL "Debug")
+
+ elseif (${CMAKE_BUILD_TYPE} STREQUAL "Release")
++ elseif (${CMAKE_BUILD_TYPE} STREQUAL "Gentoo")
+ else()
+ message(FATAL_ERROR "Invalid build type")
+ endif()
diff --git a/sci-biology/open-ephys-gui/metadata.xml b/sci-biology/open-ephys-gui/metadata.xml
new file mode 100644
index 000000000..4b23eb18b
--- /dev/null
+++ b/sci-biology/open-ephys-gui/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>malfatti@disroot.org</email>
+ <name>T Malfatti</name>
+ </maintainer>
+ <longdescription lang="en">
+ Software for processing, recording, and visualizing multichannel electrophysiological data.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">open-ephys/plugin-GUI</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-biology/open-ephys-gui/open-ephys-gui-0.5.2.2.ebuild b/sci-biology/open-ephys-gui/open-ephys-gui-0.5.2.2.ebuild
new file mode 100644
index 000000000..b0266e0ac
--- /dev/null
+++ b/sci-biology/open-ephys-gui/open-ephys-gui-0.5.2.2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake
+
+DESCRIPTION="Processing, recording, and visualizing multichannel ephys data"
+HOMEPAGE="http://www.open-ephys.org/gui/"
+LICENSE="GPL-3"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/open-ephys/plugin-GUI"
+ EGIT_BRANCH="master"
+ Suffix=$EGIT_BRANCH
+ SubDir=${P}
+elif [[ ${PV} == "99999999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/open-ephys/plugin-GUI"
+ EGIT_BRANCH="development"
+ Suffix=$EGIT_BRANCH
+ SubDir=${P}
+else
+ SRC_URI="https://github.com/open-ephys/plugin-GUI/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ Suffix=${PV}
+ SubDir="plugin-GUI-${PV}"
+ S="${WORKDIR}/$SubDir"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+SLOT="${PV}"
+IUSE="jack"
+
+BDEPEND="
+ <sys-devel/gcc-9
+"
+DEPEND="
+ media-libs/alsa-lib
+ media-libs/freeglut
+ media-libs/freetype
+ x11-libs/libXrandr
+ x11-libs/libXcursor
+ x11-libs/libXinerama
+ jack? ( media-sound/jack-audio-connection-kit )
+"
+RDEPEND="${DEPEND}"
+
+BUILD_DIR="$S/Build"
+PATCHES=( "${FILESDIR}"/${P}.patch )
+
+QA_PREBUILT="opt/open-ephys-0.5.2.2/shared/*.so"
+QA_PRESTRIPPED="
+ opt/open-ephys-0.5.2.2/plugins/*.so
+ opt/open-ephys-0.5.2.2/open-ephys
+"
+
+src_prepare() {
+ cmake_src_prepare
+
+ if use jack; then
+ sed -i 's/JUCE_APP_VERSION=/JUCE_JACK=1\n JUCE_APP_VERSION=/' "${WORKDIR}/${SubDir}/CMakeLists.txt" || die "Sed failed!"
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=( -DCMAKE_SKIP_RPATH=ON )
+ cmake_src_configure
+}
+
+src_install() {
+ dodir opt/open-ephys-"$Suffix"/ lib/udev/rules.d/
+ cp -R "${BUILD_DIR}"/Gentoo/* "${ED}"/opt/open-ephys-"$Suffix"/
+ cp -R "${WORKDIR}"/"${SubDir}"/Resources/Scripts/40-open-ephys.rules "${ED}"/lib/udev/rules.d/
+ dosym ../../opt/open-ephys-"$Suffix"/open-ephys usr/bin/open-ephys-"$Suffix"
+}
+
+pkg_postinst() {
+ ewarn " "
+ ewarn "You must restart the udev service in order to allow your computer to"
+ ewarn "communicate with the Open Ephys acquisition board."
+ ewarn " "
+}
diff --git a/sci-biology/open-ephys-gui/open-ephys-gui-9999.ebuild b/sci-biology/open-ephys-gui/open-ephys-gui-9999.ebuild
new file mode 100644
index 000000000..b0266e0ac
--- /dev/null
+++ b/sci-biology/open-ephys-gui/open-ephys-gui-9999.ebuild
@@ -0,0 +1,82 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake
+
+DESCRIPTION="Processing, recording, and visualizing multichannel ephys data"
+HOMEPAGE="http://www.open-ephys.org/gui/"
+LICENSE="GPL-3"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/open-ephys/plugin-GUI"
+ EGIT_BRANCH="master"
+ Suffix=$EGIT_BRANCH
+ SubDir=${P}
+elif [[ ${PV} == "99999999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/open-ephys/plugin-GUI"
+ EGIT_BRANCH="development"
+ Suffix=$EGIT_BRANCH
+ SubDir=${P}
+else
+ SRC_URI="https://github.com/open-ephys/plugin-GUI/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ Suffix=${PV}
+ SubDir="plugin-GUI-${PV}"
+ S="${WORKDIR}/$SubDir"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+SLOT="${PV}"
+IUSE="jack"
+
+BDEPEND="
+ <sys-devel/gcc-9
+"
+DEPEND="
+ media-libs/alsa-lib
+ media-libs/freeglut
+ media-libs/freetype
+ x11-libs/libXrandr
+ x11-libs/libXcursor
+ x11-libs/libXinerama
+ jack? ( media-sound/jack-audio-connection-kit )
+"
+RDEPEND="${DEPEND}"
+
+BUILD_DIR="$S/Build"
+PATCHES=( "${FILESDIR}"/${P}.patch )
+
+QA_PREBUILT="opt/open-ephys-0.5.2.2/shared/*.so"
+QA_PRESTRIPPED="
+ opt/open-ephys-0.5.2.2/plugins/*.so
+ opt/open-ephys-0.5.2.2/open-ephys
+"
+
+src_prepare() {
+ cmake_src_prepare
+
+ if use jack; then
+ sed -i 's/JUCE_APP_VERSION=/JUCE_JACK=1\n JUCE_APP_VERSION=/' "${WORKDIR}/${SubDir}/CMakeLists.txt" || die "Sed failed!"
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=( -DCMAKE_SKIP_RPATH=ON )
+ cmake_src_configure
+}
+
+src_install() {
+ dodir opt/open-ephys-"$Suffix"/ lib/udev/rules.d/
+ cp -R "${BUILD_DIR}"/Gentoo/* "${ED}"/opt/open-ephys-"$Suffix"/
+ cp -R "${WORKDIR}"/"${SubDir}"/Resources/Scripts/40-open-ephys.rules "${ED}"/lib/udev/rules.d/
+ dosym ../../opt/open-ephys-"$Suffix"/open-ephys usr/bin/open-ephys-"$Suffix"
+}
+
+pkg_postinst() {
+ ewarn " "
+ ewarn "You must restart the udev service in order to allow your computer to"
+ ewarn "communicate with the Open Ephys acquisition board."
+ ewarn " "
+}
diff --git a/sci-biology/open-ephys-gui/open-ephys-gui-99999999.ebuild b/sci-biology/open-ephys-gui/open-ephys-gui-99999999.ebuild
new file mode 100644
index 000000000..b0266e0ac
--- /dev/null
+++ b/sci-biology/open-ephys-gui/open-ephys-gui-99999999.ebuild
@@ -0,0 +1,82 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake
+
+DESCRIPTION="Processing, recording, and visualizing multichannel ephys data"
+HOMEPAGE="http://www.open-ephys.org/gui/"
+LICENSE="GPL-3"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/open-ephys/plugin-GUI"
+ EGIT_BRANCH="master"
+ Suffix=$EGIT_BRANCH
+ SubDir=${P}
+elif [[ ${PV} == "99999999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/open-ephys/plugin-GUI"
+ EGIT_BRANCH="development"
+ Suffix=$EGIT_BRANCH
+ SubDir=${P}
+else
+ SRC_URI="https://github.com/open-ephys/plugin-GUI/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ Suffix=${PV}
+ SubDir="plugin-GUI-${PV}"
+ S="${WORKDIR}/$SubDir"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+SLOT="${PV}"
+IUSE="jack"
+
+BDEPEND="
+ <sys-devel/gcc-9
+"
+DEPEND="
+ media-libs/alsa-lib
+ media-libs/freeglut
+ media-libs/freetype
+ x11-libs/libXrandr
+ x11-libs/libXcursor
+ x11-libs/libXinerama
+ jack? ( media-sound/jack-audio-connection-kit )
+"
+RDEPEND="${DEPEND}"
+
+BUILD_DIR="$S/Build"
+PATCHES=( "${FILESDIR}"/${P}.patch )
+
+QA_PREBUILT="opt/open-ephys-0.5.2.2/shared/*.so"
+QA_PRESTRIPPED="
+ opt/open-ephys-0.5.2.2/plugins/*.so
+ opt/open-ephys-0.5.2.2/open-ephys
+"
+
+src_prepare() {
+ cmake_src_prepare
+
+ if use jack; then
+ sed -i 's/JUCE_APP_VERSION=/JUCE_JACK=1\n JUCE_APP_VERSION=/' "${WORKDIR}/${SubDir}/CMakeLists.txt" || die "Sed failed!"
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=( -DCMAKE_SKIP_RPATH=ON )
+ cmake_src_configure
+}
+
+src_install() {
+ dodir opt/open-ephys-"$Suffix"/ lib/udev/rules.d/
+ cp -R "${BUILD_DIR}"/Gentoo/* "${ED}"/opt/open-ephys-"$Suffix"/
+ cp -R "${WORKDIR}"/"${SubDir}"/Resources/Scripts/40-open-ephys.rules "${ED}"/lib/udev/rules.d/
+ dosym ../../opt/open-ephys-"$Suffix"/open-ephys usr/bin/open-ephys-"$Suffix"
+}
+
+pkg_postinst() {
+ ewarn " "
+ ewarn "You must restart the udev service in order to allow your computer to"
+ ewarn "communicate with the Open Ephys acquisition board."
+ ewarn " "
+}