aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/bazel/Manifest1
-rw-r--r--dev-util/bazel/bazel-0.13.0.ebuild104
-rw-r--r--dev-util/bazel/metadata.xml20
3 files changed, 125 insertions, 0 deletions
diff --git a/dev-util/bazel/Manifest b/dev-util/bazel/Manifest
new file mode 100644
index 000000000..686aebe99
--- /dev/null
+++ b/dev-util/bazel/Manifest
@@ -0,0 +1 @@
+DIST bazel-0.13.0-dist.zip 90105262 BLAKE2B cb065025524123babef187bac2e1f54f43645d08cb1282a5fe8f8c8b090e595570646072e2380836e2c43403f7953f97321becc24b743d7b9ab43ad208cf2c2d SHA512 3c128e551cff1b685250a68892ca3e1ad6be8b152ee2b8eb527c94adbb8fd50c70e703a363bb938916275030ddb14d756c14e4dc238e7a7b40289c700c5d53c7
diff --git a/dev-util/bazel/bazel-0.13.0.ebuild b/dev-util/bazel/bazel-0.13.0.ebuild
new file mode 100644
index 000000000..797c062b0
--- /dev/null
+++ b/dev-util/bazel/bazel-0.13.0.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1 java-pkg-2
+
+DESCRIPTION="Fast and correct automated build system"
+HOMEPAGE="http://bazel.io/"
+SRC_URI="https://github.com/bazelbuild/bazel/releases/download/${PV}/${P}-dist.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples tools zsh-completion"
+# strip corrupts the bazel binary
+RESTRICT="strip"
+RDEPEND="virtual/jdk:1.8"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ app-arch/zip"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ echo ${PATH} | grep -q ccache && \
+ ewarn "${PN} usually fails to compile with ccache, you have been warned"
+ java-pkg-2_pkg_setup
+}
+
+bazel-get-flags() {
+ local fs=""
+ for i in ${CFLAGS}; do
+ [[ -n "${fs}" ]] && fs+=" "
+ fs+="--copt=${i}"
+ done
+ for i in ${CXXFLAGS}; do
+ [[ -n "${fs}" ]] && fs+=" "
+ fs+="--cxxopt=${i}"
+ done
+ for i in ${CPPFLAGS}; do
+ [[ -n "${fs}" ]] && fs+=" "
+ fs+="--copt=${i}"
+ fs+="--cxxopt=${i}"
+ done
+ for i in ${LDFLAGS}; do
+ [[ -n "${fs}" ]] && fs+=" "
+ fs+="--linkopt=${i}"
+ done
+ echo "${fs}"
+}
+
+src_compile() {
+ # F: fopen_wr
+ # S: deny
+ # P: /proc/self/setgroups
+ # A: /proc/self/setgroups
+ # R: /proc/24939/setgroups
+ # C: /usr/lib/systemd/systemd
+ addpredict /proc
+ VERBOSE=yes ./compile.sh || die
+ # Use standalone strategy to deactivate the bazel sandbox, since it
+ # conflicts with FEATURES=sandbox.
+ echo "build --verbose_failures --spawn_strategy=standalone --genrule_strategy=standalone" \
+ > "${T}/bazelrc" || die
+ einfo "output/bazel --bazelrc=\"${T}/bazelrc\" build \\"
+ einfo " $(bazel-get-flags) \\"
+ einfo " scripts:bazel-complete.bash"
+ output/bazel --bazelrc="${T}/bazelrc" build $(bazel-get-flags) \
+ scripts:bazel-complete.bash || die
+ mv bazel-bin/scripts/bazel-complete.bash output/ || die
+}
+
+src_test() {
+ output/bazel test \
+ --verbose_failures \
+ --spawn_strategy=standalone \
+ --genrule_strategy=standalone \
+ --verbose_test_summary \
+ examples/cpp:hello-success_test || die
+}
+
+src_install() {
+ output/bazel shutdown
+ dobin output/bazel
+ newbashcomp output/bazel-complete.bash ${PN}
+ bashcomp_alias ${PN} ibazel
+ if use zsh-completion ; then
+ insinto /usr/share/zsh/site-functions
+ doins scripts/zsh_completion/_bazel
+ fi
+ if use examples; then
+ docinto examples
+ dodoc -r examples/*
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ # could really build tools but I don't know which ones
+ # are actually used
+ if use tools; then
+ docinto tools
+ dodoc -r tools/*
+ docompress -x /usr/share/doc/${PF}/tools
+ fi
+}
diff --git a/dev-util/bazel/metadata.xml b/dev-util/bazel/metadata.xml
new file mode 100644
index 000000000..e7d5f3b34
--- /dev/null
+++ b/dev-util/bazel/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">bazelbuild/bazel</remote-id>
+ </upstream>
+ <longdescription>
+ Bazel is Google's own build tool. Bazel has built-in support for
+ building both client and server software, including client
+ applications for both Android and iOS platforms. It also provides
+ an extensible framework that you can use to develop your own build
+ rules.
+ </longdescription>
+ <use>
+ <flag name="tools">Install extra bazel tools to build from sources</flag>
+ </use>
+</pkgmetadata>