aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-mathematics/mdp/ChangeLog4
-rw-r--r--sci-mathematics/mdp/Manifest2
-rw-r--r--sci-mathematics/mdp/mdp-3.3.ebuild (renamed from sci-mathematics/mdp/mdp-3.2.ebuild)25
-rw-r--r--sci-mathematics/mdp/mdp-9999.ebuild25
4 files changed, 33 insertions, 23 deletions
diff --git a/sci-mathematics/mdp/ChangeLog b/sci-mathematics/mdp/ChangeLog
index d86c6bab3..005f815ec 100644
--- a/sci-mathematics/mdp/ChangeLog
+++ b/sci-mathematics/mdp/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 04 Dec 2013; Justin Lecher <jlec@gentoo.org> -mdp-3.2.ebuild,
+ +mdp-3.3.ebuild, mdp-9999.ebuild:
+ Version BUmp; Bump to distutils-r1 eclass
+
03 Mar 2013; Justin Lecher <jlec@gentoo.org> mdp-9999.ebuild, metadata.xml:
Clean wrong space and blank lines
diff --git a/sci-mathematics/mdp/Manifest b/sci-mathematics/mdp/Manifest
index 66da7654f..97e795fcf 100644
--- a/sci-mathematics/mdp/Manifest
+++ b/sci-mathematics/mdp/Manifest
@@ -1 +1 @@
-DIST MDP-3.2.tar.gz 469010 SHA256 5310d54766cb91a02988f42bea4b493197155ac1960fbfa41a8c9661b08c1665 SHA512 223629b543ac8baedb891212e1beded231a7b21de167b3f23f4a355ceb7443afd40b1737e5fb96cc2df969c0011b5cbe2ebc7004cbb2ad89cfb75a1ec8b86a80 WHIRLPOOL 2e4fef0ea51af94e627f13ba791f6f22e13c13a1a7e2f2cd18ae311910dd10f30f0071d0a8601404d2604339d5af3873dbfc4585452d17bced91251ffd39aba8
+DIST MDP-3.3.tar.gz 471439 SHA256 3461a54c96a050029ec548c48fa5c60c2bb5b28cc088092438aa95c94d8b3478 SHA512 fdbecd38e86aae970c6091c3ff7cd8e576556bf449051e5d998852e294041587907acc0701d3415059da7aaac73c04803138a04c9990bcc2a168a8f6f83d91cf WHIRLPOOL 0ea37eaff661a814ee3befe84cdfcac35a2462acd16f34dd7a46a2c9aaa9b8f5fee46c6b1e33e2a4313c454ab7519e3dcc9e54234d91c3c6e3fafcc094bfe5a1
diff --git a/sci-mathematics/mdp/mdp-3.2.ebuild b/sci-mathematics/mdp/mdp-3.3.ebuild
index 704be41e5..2a6300391 100644
--- a/sci-mathematics/mdp/mdp-3.2.ebuild
+++ b/sci-mathematics/mdp/mdp-3.3.ebuild
@@ -1,14 +1,13 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="3"
+EAPI=5
-PYTHON_DEPEND="2:2.5:2.7 3:3.1:3.2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4"
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+PYTHON_COMPAT=( python3_3 )
-inherit distutils
+inherit distutils-r1
MY_P="${P/mdp/MDP}"
MY_P="${MY_P/_rc/RC}"
@@ -23,13 +22,15 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND=""
-RDEPEND="|| ( >=dev-python/numpy-1.1 >=sci-libs/scipy-0.5.2 )"
+RDEPEND="|| (
+ >=dev-python/numpy-1.1[${PYTHON_USEDEP}]
+ >=sci-libs/scipy-0.5.2[${PYTHON_USEDEP}]
+ )"
S="${WORKDIR}/${MY_P}"
-src_test() {
- testing() {
- PYTHONPATH="build-${PYTHON_ABI}/src" "$(PYTHON)" -c "import mdp;mdp.test()"
- }
- python_execute_function testing
+python_test() {
+ distutils_install_for_testing
+ cd "${BUILD_DIR}" || die
+ "${PYTHON}" -c "import mdp;mdp.test()" || die
}
diff --git a/sci-mathematics/mdp/mdp-9999.ebuild b/sci-mathematics/mdp/mdp-9999.ebuild
index 73620f098..b34474609 100644
--- a/sci-mathematics/mdp/mdp-9999.ebuild
+++ b/sci-mathematics/mdp/mdp-9999.ebuild
@@ -2,28 +2,33 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="3"
+EAPI=5
-inherit distutils git-2
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit distutils-r1 git-r3
MY_P="${P/mdp/MDP}"
MY_P="${MY_P/_rc/RC}"
DESCRIPTION="Modular data processing framework for python"
HOMEPAGE="http://mdp-toolkit.sourceforge.net/index.html"
+SRC_URI=""
EGIT_REPO_URI="git://github.com/mdp-toolkit/mdp-toolkit.git"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE=""
DEPEND=""
-RDEPEND="|| ( >=dev-python/numpy-1.1 >=sci-libs/scipy-0.5.2 )"
-
-S="${WORKDIR}/${MY_P}"
+RDEPEND="|| (
+ >=dev-python/numpy-1.1[${PYTHON_USEDEP}]
+ >=sci-libs/scipy-0.5.2[${PYTHON_USEDEP}]
+ )"
-src_test() {
- testing() {
- PYTHONPATH="build-${PYTHON_ABI}/src" "$(PYTHON)" -c "import mdp;mdp.test()"
- }
- python_execute_function testing
+python_test() {
+ distutils_install_for_testing
+ cd "${BUILD_DIR}" || die
+ "${PYTHON}" -c "import mdp;mdp.test()" || die
}