aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-biology/ncbi-tools++/ncbi-tools++-12.0.0.ebuild3
-rw-r--r--sci-biology/ncbi-tools++/ncbi-tools++-9.0.0-r1.ebuild4
-rw-r--r--sci-biology/ncbi-tools++/ncbi-tools++-9.0.0.ebuild5
3 files changed, 12 insertions, 0 deletions
diff --git a/sci-biology/ncbi-tools++/ncbi-tools++-12.0.0.ebuild b/sci-biology/ncbi-tools++/ncbi-tools++-12.0.0.ebuild
index d4a50856d..3b19a9391 100644
--- a/sci-biology/ncbi-tools++/ncbi-tools++-12.0.0.ebuild
+++ b/sci-biology/ncbi-tools++/ncbi-tools++-12.0.0.ebuild
@@ -18,6 +18,8 @@ SRC_URI="
ftp://ftp.ncbi.nih.gov/toolbox/ncbi_tools++/ARCHIVE/${MY_PV}/ncbi_cxx--${MY_PV}.tar.gz"
# http://dev.gentoo.org/~jlec/distfiles/${PN}-${PV#0.}-asneeded.patch.xz"
+# should also install ftp://ftp.ncbi.nlm.nih.gov/blast/db/taxdb.tar.gz
+# see http://www.biostars.org/p/76551/ and http://blastedbio.blogspot.cz/2012/05/blast-tabular-missing-descriptions.html
LICENSE="public-domain"
SLOT="0"
IUSE="
@@ -271,6 +273,7 @@ src_configure() {
# --without-static \
# --with-dll \
# --with-mt \
+# --with-openmp \
# --with-lfs \
# --prefix="${ED}"/usr \
# --libdir="${ED}"/usr/$(get_libdir)/"${PN}" \
diff --git a/sci-biology/ncbi-tools++/ncbi-tools++-9.0.0-r1.ebuild b/sci-biology/ncbi-tools++/ncbi-tools++-9.0.0-r1.ebuild
index 7b3ba9e6b..89ae17635 100644
--- a/sci-biology/ncbi-tools++/ncbi-tools++-9.0.0-r1.ebuild
+++ b/sci-biology/ncbi-tools++/ncbi-tools++-9.0.0-r1.ebuild
@@ -18,6 +18,9 @@ SRC_URI="
ftp://ftp.ncbi.nih.gov/toolbox/ncbi_tools++/ARCHIVE/${MY_PV}/ncbi_cxx--${MY_PV}.tar.gz"
# http://dev.gentoo.org/~jlec/distfiles/${PN}-${PV#0.}-asneeded.patch.xz"
+# should also install ftp://ftp.ncbi.nlm.nih.gov/blast/db/taxdb.tar.gz
+# see http://www.biostars.org/p/76551/ and http://blastedbio.blogspot.cz/2012/05/blast-tabular-missing-descriptions.html
+
LICENSE="public-domain"
SLOT="0"
IUSE="
@@ -281,6 +284,7 @@ src_configure() {
# --without-static \
# --with-dll \
# --with-mt \
+# --with-openmp \
# --with-lfs \
# --prefix="${ED}"/usr \
# --libdir="${ED}"/usr/$(get_libdir)/"${PN}" \
diff --git a/sci-biology/ncbi-tools++/ncbi-tools++-9.0.0.ebuild b/sci-biology/ncbi-tools++/ncbi-tools++-9.0.0.ebuild
index 2824e095f..802027609 100644
--- a/sci-biology/ncbi-tools++/ncbi-tools++-9.0.0.ebuild
+++ b/sci-biology/ncbi-tools++/ncbi-tools++-9.0.0.ebuild
@@ -18,6 +18,9 @@ SRC_URI="
ftp://ftp.ncbi.nih.gov/toolbox/ncbi_tools++/ARCHIVE/${MY_PV}/ncbi_cxx--${MY_PV}.tar.gz"
# http://dev.gentoo.org/~jlec/distfiles/${PN}-${PV#0.}-asneeded.patch.xz"
+# should also install ftp://ftp.ncbi.nlm.nih.gov/blast/db/taxdb.tar.gz
+# see http://www.biostars.org/p/76551/ and http://blastedbio.blogspot.cz/2012/05/blast-tabular-missing-descriptions.html
+
LICENSE="public-domain"
SLOT="0"
IUSE="berkdb boost bzip2 cppunit curl expat fastcgi fltk freetype ftds gif glut gnutls hdf5 icu jpeg lzo mesa mysql muparser opengl pcre png python sablotron sqlite sqlite3 ssl tiff xerces xalan xml xpm xslt X"
@@ -283,6 +286,8 @@ src_configure() {
--libdir="${ED}"/usr/$(get_libdir)/"${PN}" \
${myconf} LDFLAGS="-Wl,--no-as-needed" \
|| die
+
+ # --with-openmp
}
src_compile() {