aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/asmjit/asmjit-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/asmjit/asmjit-9999.ebuild b/dev-libs/asmjit/asmjit-9999.ebuild
new file mode 100644
index 000000000..4aa72707c
--- /dev/null
+++ b/dev-libs/asmjit/asmjit-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="complete x86/x64 JIT-Assembler for C++ language"
+HOMEPAGE="http://asmjit.com/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/asmjit/asmjit"
+else
+ COMMIT=b49d685cd9e2e4488f55ce6004306a79bdea056b
+ SRC_URI="https://github.com/asmjit/asmjit/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${COMMIT}
+ KEYWORDS="~amd64"
+fi
+
+SLOT="0"
+LICENSE="BSD"
+IUSE="natvis static-libs test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DASMJIT_EMBED=$(usex static-libs)
+ -DASMJIT_BUILD_X86=ON
+ -DASMJIT_NO_NATVIS=$(usex natvis)
+ -DASMJIT_TEST=$(usex test)
+ )
+ cmake_src_configure
+}