aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-vcs/datalad-fuse/Manifest1
-rw-r--r--dev-vcs/datalad-fuse/datalad-fuse-0.5.1.ebuild43
-rw-r--r--dev-vcs/datalad-fuse/files/datalad-fuse-0.5.1-git_config.patch15
-rw-r--r--dev-vcs/datalad-fuse/metadata.xml16
4 files changed, 75 insertions, 0 deletions
diff --git a/dev-vcs/datalad-fuse/Manifest b/dev-vcs/datalad-fuse/Manifest
new file mode 100644
index 000000000..cebf299ec
--- /dev/null
+++ b/dev-vcs/datalad-fuse/Manifest
@@ -0,0 +1 @@
+DIST datalad-fuse-0.5.1.gh.tar.gz 66846 BLAKE2B 7b6311060bc8434ff48006775199c8bcac30a37feb55a516dd5df754a2c81f062bcd6717f977365d4db08f97e587fc105e7721ff54e08ae90db159b2fb1c81c3 SHA512 9e479008325b6673bb0714dcfc86776361a6764f2218ed70ca229a76ac04e352c76b7c41e1aba13939ccfec186f2ad00b0c1a15eefc42f9b81af4041fcb4fe32
diff --git a/dev-vcs/datalad-fuse/datalad-fuse-0.5.1.ebuild b/dev-vcs/datalad-fuse/datalad-fuse-0.5.1.ebuild
new file mode 100644
index 000000000..1359f4e0d
--- /dev/null
+++ b/dev-vcs/datalad-fuse/datalad-fuse-0.5.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1
+
+DESCRIPTION="Keep code, data, containers under control with git and git-annex"
+HOMEPAGE="https://github.com/datalad/datalad"
+SRC_URI="https://github.com/datalad/datalad-fuse/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/aiohttp-retry[${PYTHON_USEDEP}]
+ dev-python/fsspec[${PYTHON_USEDEP}]
+ dev-python/methodtools[${PYTHON_USEDEP}]
+ dev-python/linesep[${PYTHON_USEDEP}]
+ dev-vcs/datalad[${PYTHON_USEDEP}]
+ sys-fs/fuse
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/${P}-git_config.patch"
+)
+
+python_test() {
+ #git init -q || die
+ #git config --global user.email "placeholder@gentoo.org" || die
+ #git config --global user.name "Place Holder" || die
+ #git add . || die
+ #git commit -m "init" || die
+ ##GIT_AUTHOR_NAME="Place Holder" GIT_AUTHOR_EMAIL="placeholder@gentoo.org" epytest
+ ##export GIT_AUTHOR_NAME="Place Holder"
+ ##export GIT_AUTHOR_EMAIL="placeholder@gentoo.org"
+ epytest
+}
diff --git a/dev-vcs/datalad-fuse/files/datalad-fuse-0.5.1-git_config.patch b/dev-vcs/datalad-fuse/files/datalad-fuse-0.5.1-git_config.patch
new file mode 100644
index 000000000..f62fc412e
--- /dev/null
+++ b/dev-vcs/datalad-fuse/files/datalad-fuse-0.5.1-git_config.patch
@@ -0,0 +1,15 @@
+Upstreamed and perhaps removable for future releases:
+https://github.com/datalad/datalad-fuse/pull/113
+diff --git a/datalad_fuse/tests/test_fsspec_head.py b/datalad_fuse/tests/test_fsspec_head.py
+index 75a6efc..1ffc60f 100644
+--- a/datalad_fuse/tests/test_fsspec_head.py
++++ b/datalad_fuse/tests/test_fsspec_head.py
+@@ -131,6 +131,8 @@ def test_git_repo(tmp_path):
+ TEXT = (Path(__file__).with_name("data") / "text.txt").read_bytes()
+ (tmp_path / "text.txt").write_bytes(TEXT)
+ subprocess.run(["git", "add", "text.txt"], cwd=tmp_path, check=True)
++ subprocess.run(["git", "config", "user.email", "place@holder.org"], cwd=tmp_path, check=True)
++ subprocess.run(["git", "config", "user.name", "Place Holder"], cwd=tmp_path, check=True)
+ subprocess.run(["git", "commit", "-m", "Add a file"], cwd=tmp_path, check=True)
+ ds = Dataset(tmp_path)
+ assert_in_results(
diff --git a/dev-vcs/datalad-fuse/metadata.xml b/dev-vcs/datalad-fuse/metadata.xml
new file mode 100644
index 000000000..97f1a33f3
--- /dev/null
+++ b/dev-vcs/datalad-fuse/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@chymera.eu</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">datalad/datalad-fuse</remote-id>
+ <remote-id type="pypi">datalad-fuse</remote-id>
+ </upstream>
+</pkgmetadata>