aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-chemistry/openbabel-python/ChangeLog4
-rw-r--r--sci-chemistry/openbabel-python/openbabel-python-2.3.2.ebuild8
2 files changed, 11 insertions, 1 deletions
diff --git a/sci-chemistry/openbabel-python/ChangeLog b/sci-chemistry/openbabel-python/ChangeLog
index 51e3bf640..aa49a851b 100644
--- a/sci-chemistry/openbabel-python/ChangeLog
+++ b/sci-chemistry/openbabel-python/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 10 Nov 2012; Reinis Danne <rei4dan@gmail.com> openbabel-python-2.3.2.ebuild:
+ python-r1.eclass doesn't enter BUILD_DIR in python_foreach_impl, do it
+ manually where necessary.
+
*openbabel-python-2.3.2 (19 Oct 2012)
19 Oct 2012; Reinis Danne <rei4dan@gmail.com> +openbabel-python-2.3.2.ebuild,
diff --git a/sci-chemistry/openbabel-python/openbabel-python-2.3.2.ebuild b/sci-chemistry/openbabel-python/openbabel-python-2.3.2.ebuild
index 18b371800..f24e08453 100644
--- a/sci-chemistry/openbabel-python/openbabel-python-2.3.2.ebuild
+++ b/sci-chemistry/openbabel-python/openbabel-python-2.3.2.ebuild
@@ -84,5 +84,11 @@ src_test() {
}
src_install() {
- python_foreach_impl cmake -DCOMPONENT=bindings_python -P cmake_install.cmake
+ my_impl_src_install() {
+ cd "${BUILD_DIR}"
+
+ cmake -DCOMPONENT=bindings_python -P cmake_install.cmake
+ }
+
+ python_foreach_impl my_impl_src_install
}