aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-biology/emboss/ChangeLog17
-rw-r--r--sci-biology/emboss/emboss-6.6.0.ebuild14
-rw-r--r--sci-biology/emboss/files/emboss-6.6.0_plcol.patch112
3 files changed, 138 insertions, 5 deletions
diff --git a/sci-biology/emboss/ChangeLog b/sci-biology/emboss/ChangeLog
index 76a5b350a..1d9c10edb 100644
--- a/sci-biology/emboss/ChangeLog
+++ b/sci-biology/emboss/ChangeLog
@@ -2,6 +2,23 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/ChangeLog,v 1.61 2011/03/09 16:29:05 jlec Exp $
+ 16 Sep 2013; Martin Mokrejs <mmokrejs@fold.natur.cuni.cz>
+ emboss-6.6.0.ebuild, +files/emboss-6.6.0_plcol.patch:
+ emboss-6.6.0.ebuild files/emboss-6.6.0_plcol.patch
+ Added the misisng patch, disabled searches for Gentoo-patches,
+ fixed patch-related variable values in the 6.6.0 ebuild, BUT
+ 1) the ebuild does not work, configure exits after looking for
+ -lhpdf or later -lpng (that can be obeyed by omitting --with-hpdf
+ --with-pngdriver)
+ 2) if one relies on whatever configure detects compilation aborts
+ while compiling embossversion.c or because -lexpat is not in LIBS.
+ Well, expat is not in configure flags at all.
+
+ Maybe something is caused by the --enable-systemlibs configure switch,
+ I think it actually enables inclusion of these from their bundled
+ copies in the EMBOSS tarball (and not use of the system-wide headers
+ and libs).
+
*emboss-6.3.1_p4-r2 (11 Sep 2013)
*emboss-6.5.7 (11 Sep 2013)
*emboss-6.6.0 (11 Sep 2013)
diff --git a/sci-biology/emboss/emboss-6.6.0.ebuild b/sci-biology/emboss/emboss-6.6.0.ebuild
index 4ab735390..1d7b405b5 100644
--- a/sci-biology/emboss/emboss-6.6.0.ebuild
+++ b/sci-biology/emboss/emboss-6.6.0.ebuild
@@ -6,8 +6,11 @@ EAPI="4"
inherit emboss eutils
-EBO_PATCH="4"
-EBOV=${PV/_p*}
+#EBO_PATCH="4"
+#EBOV=${PV/_p*}
+
+EBO_PATCH=""
+EBOV=${PV}
DESCRIPTION="The European Molecular Biology Open Software Suite - A sequence analysis package"
SRC_URI="
@@ -18,7 +21,8 @@ SRC_URI="
##[[ -n ${EBO_PATCH} ]] && SRC_URI+=" ftp://${PN}.open-bio.org/pub/EMBOSS/fixes/patches/patch-1-${EBO_PATCH}.gz -> ${P}-upstream.patch.gz"
#[[ -n ${EBO_PATCH} ]] && SRC_URI+=" http://pkgs.fedoraproject.org/lookaside/pkgs/EMBOSS/patch-1-4.gz/7a42594c5eda4adc6457f33e4ab0d8f2/patch-1-${EBO_PATCH}.gz -> ${P}-upstream.patch.gz"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+#KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+KEYWORDS=""
IUSE+=" minimal"
RDEPEND+=" !sys-devel/cons"
@@ -40,8 +44,8 @@ DOCS+=" FAQ THANKS"
src_prepare() {
[[ -n ${EBO_PATCH} ]] && epatch "${WORKDIR}"/${P}-upstream.patch
- epatch "${WORKDIR}"/${PF}.patch
- epatch "${FILESDIR}/${PF}_plcol.patch"
+ # epatch "${WORKDIR}"/${PF}.patch
+ #epatch "${FILESDIR}/${PF}_plcol.patch"
emboss_src_prepare
}
diff --git a/sci-biology/emboss/files/emboss-6.6.0_plcol.patch b/sci-biology/emboss/files/emboss-6.6.0_plcol.patch
new file mode 100644
index 000000000..0f5e592b7
--- /dev/null
+++ b/sci-biology/emboss/files/emboss-6.6.0_plcol.patch
@@ -0,0 +1,112 @@
+--- EMBOSS-6.3.1/ajax/graphics/ajgraph.c 2012-07-19 23:29:05.000000000 +0200
++++ /tmp/ajgraph.c 2012-07-19 23:25:00.000000000 +0200
+@@ -1645,14 +1645,14 @@
+ ** @return [void]
+ ** @@
+ ******************************************************************************/
+
+ static void GraphSetPen(ajint colour)
+ {
+- ajDebug("=g= plcol(%d '%s') [colour]\n", colour, graphColourName[colour]);
+- plcol((PLINT)colour);
++ ajDebug("=g= plcol0(%d '%s') [colour]\n", colour, graphColourName[colour]);
++ plcol0((PLINT)colour);
+
+ return;
+ }
+
+
+
+--- EMBOSS-6.3.1/plplot/plcore.c 2007-10-24 15:14:43.000000000 +0200
++++ /tmp/plcore.c 2012-07-19 23:25:00.000000000 +0200
+@@ -1709,13 +1709,13 @@
+ if (plsc->zdigmax == 0)
+ plsc->zdigmax = 3;
+
+ /* Switch to graphics mode and set color and arrow style*/
+
+ plgra();
+- plcol(1);
++ plcol0(1);
+
+ plstyl(0, &mk, &sp);
+ plpat(1, &inc, &del);
+
+ plsvect(def_arrow_x, def_arrow_y, 6, 0);
+
+--- EMBOSS-6.3.1/plplot/plstripc.c 2007-05-08 11:09:37.000000000 +0200
++++ /tmp/plstripc.c 2012-07-19 23:25:00.000000000 +0200
+@@ -153,17 +153,17 @@
+
+ plgchr(&sc, &dy);
+ sc = dy = dy/100;
+ plwind(-0.01, 1.01, -0.01, 1.01);
+ for (i=0; i<PEN; i++) {
+ if (mystripc->npts[i] || first) {
+- plcol(mystripc->colline[i]);
++ plcol0(mystripc->colline[i]);
+ pllsty(mystripc->styline[i]);
+ pljoin(mystripc->xlpos, mystripc->ylpos - sc,
+ mystripc->xlpos + 0.1, mystripc->ylpos - sc);
+- plcol(mystripc->collab);
++ plcol0(mystripc->collab);
+ plptex(mystripc->xlpos + 0.11, mystripc->ylpos - sc,
+ 0., 0., 0, mystripc->legline[i]);
+ sc += dy;
+ }
+ }
+ plwind(mystripc->xmin, mystripc->xmax, mystripc->ymin, mystripc->ymax);
+@@ -184,34 +184,34 @@
+ PLFLT x[]={0.,1.,1.,0.}, y[]={0.,0.,1.,1.};
+
+ /* Set up window */
+
+ plvpor(0,1,0,1);
+ plwind(0,1,0,1);
+- plcol(0);plpsty(0);
++ plcol0(0);plpsty(0);
+ plfill(4, &x[0], &y[0]);
+ plvsta();
+
+ /* Draw box and same window dimensions */
+ mystrip->wxmin=mystrip->xmin;
+ mystrip->wxmax=mystrip->xmax;
+ mystrip->wymin=mystrip->ymin;
+ mystrip->wymax=mystrip->ymax; /* FIXME - can exist some redundancy here */
+
+ plwind(mystrip->xmin, mystrip->xmax, mystrip->ymin, mystrip->ymax);
+
+ pllsty(1);
+- plcol(mystrip->colbox);
++ plcol0(mystrip->colbox);
+ plbox(mystrip->xspec, 0.0, 0, mystrip->yspec, 0.0, 0);
+
+- plcol(mystrip->collab);
++ plcol0(mystrip->collab);
+ pllab(mystrip->labx, mystrip->laby, mystrip->labtop);
+
+ for (i=0; i<PEN; i++) {
+ if (mystrip->npts[i] > 0) {
+- plcol(mystrip->colline[i]);pllsty(mystrip->styline[i]);
++ plcol0(mystrip->colline[i]);pllsty(mystrip->styline[i]);
+ plline(mystrip->npts[i], mystrip->x[i], mystrip->y[i]);
+ }
+ }
+
+ plstrip_legend(mystrip,0);
+ }
+@@ -269,13 +269,13 @@
+ if (stripc->xmax - stripc->xmin < stripc->xlen) {
+ if( yasc == 0) {
+
+ /* If user has changed subwindow, make shure we have the correct one */
+ plvsta();
+ plwind(stripc->wxmin, stripc->wxmax, stripc->wymin, stripc->wymax); /* FIXME - can exist some redundancy here */
+- plcol(stripc->colline[p]); pllsty(stripc->styline[p]);
++ plcol0(stripc->colline[p]); pllsty(stripc->styline[p]);
+ if ((stripc->npts[p]-2) < 0)
+ plP_movwor(stripc->x[p][stripc->npts[p]-1], stripc->y[p][stripc->npts[p]-1]);
+ else
+ plP_movwor(stripc->x[p][stripc->npts[p]-2], stripc->y[p][stripc->npts[p]-2]);
+ plP_drawor(stripc->x[p][stripc->npts[p]-1], stripc->y[p][stripc->npts[p]-1]);
+ plflush();