aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-astronomy/mosstack/ChangeLog5
-rw-r--r--sci-astronomy/mosstack/Manifest1
-rw-r--r--sci-astronomy/mosstack/mosstack-0.6.1-r1.ebuild33
3 files changed, 39 insertions, 0 deletions
diff --git a/sci-astronomy/mosstack/ChangeLog b/sci-astronomy/mosstack/ChangeLog
index 91c775507..37042615b 100644
--- a/sci-astronomy/mosstack/ChangeLog
+++ b/sci-astronomy/mosstack/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*mosstack-0.6.1-r1 (25 Dec 2014)
+
+ 25 Dec 2014; Mikko Laine <mikko.laine@gmail.com> +mosstack-0.6.1-r1.ebuild:
+ sci-astronomy/mosstack: New download url for mosstack. Added -r1-ebuild.
+
*mosstack-0.6.1 (13 Dec 2014)
13 Dec 2014; Mikko Laine <mikko.laine@gmail.com> +metadata.xml,
diff --git a/sci-astronomy/mosstack/Manifest b/sci-astronomy/mosstack/Manifest
index 312d31a33..4abada361 100644
--- a/sci-astronomy/mosstack/Manifest
+++ b/sci-astronomy/mosstack/Manifest
@@ -1 +1,2 @@
DIST mosstack-0.6.1.tar.gz 470478 SHA256 c3a0a5021d6f1f717fe5e27caf19ba501fafd66f925662496fd530a38e7b7ccd SHA512 66244086c476ca5743649ef7d4fe5ab6acee8d3a1c163e5008517fe3ad5779e2452cc717482fbad60912934f29b9627cad9851842d87546a33853a87a4ec0568 WHIRLPOOL f475b367e76c3930dc41b0d3114b6447966d7f3d814dd2b1ff5bcbdd464a1fac720737ad0c4f68094363a01eb852c92e1d10720062186f7d031410045a857ee3
+DIST mosstack-0.6.1.tar?attredirects=0&d=1 470478 SHA256 c3a0a5021d6f1f717fe5e27caf19ba501fafd66f925662496fd530a38e7b7ccd SHA512 66244086c476ca5743649ef7d4fe5ab6acee8d3a1c163e5008517fe3ad5779e2452cc717482fbad60912934f29b9627cad9851842d87546a33853a87a4ec0568 WHIRLPOOL f475b367e76c3930dc41b0d3114b6447966d7f3d814dd2b1ff5bcbdd464a1fac720737ad0c4f68094363a01eb852c92e1d10720062186f7d031410045a857ee3
diff --git a/sci-astronomy/mosstack/mosstack-0.6.1-r1.ebuild b/sci-astronomy/mosstack/mosstack-0.6.1-r1.ebuild
new file mode 100644
index 000000000..166de76cb
--- /dev/null
+++ b/sci-astronomy/mosstack/mosstack-0.6.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python{3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Stacking software for astronomical images"
+HOMEPAGE="https://sites.google.com/site/mosstack"
+SRC_URI="https://sites.google.com/site/mosstack/installing/mosstack-0.6.1.tar?attredirects=0&d=1"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="opencl qt4"
+
+DEPEND=">=dev-python/numpy-1.8.0[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]"
+
+RDEPEND=">=dev-python/pillow-2.3.0[${PYTHON_USEDEP}]
+ sci-libs/scikits_image[${PYTHON_USEDEP}]
+ >media-gfx/imagemagick-6.8.0.0
+ sci-astronomy/sextractor
+ media-gfx/dcraw
+ media-libs/exiftool
+ dev-python/astropy[${PYTHON_USEDEP}]
+ opencl? ( >=dev-python/pyopencl-2013.1[${PYTHON_USEDEP}] )
+ qt4? ( dev-python/PyQt4[${PYTHON_USEDEP}] )"
+
+DOCS=( CHANGES.txt README.txt )