aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/nvidia-cuda-gdk/ChangeLog9
-rw-r--r--dev-util/nvidia-cuda-gdk/Manifest2
-rw-r--r--dev-util/nvidia-cuda-gdk/files/nvidia-healthmon9
-rw-r--r--dev-util/nvidia-cuda-gdk/metadata.xml17
-rw-r--r--dev-util/nvidia-cuda-gdk/nvidia-cuda-gdk-340.29.ebuild113
-rw-r--r--licenses/NVIDIA-gdk32
6 files changed, 182 insertions, 0 deletions
diff --git a/dev-util/nvidia-cuda-gdk/ChangeLog b/dev-util/nvidia-cuda-gdk/ChangeLog
new file mode 100644
index 000000000..6e289bbb5
--- /dev/null
+++ b/dev-util/nvidia-cuda-gdk/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-util/nvidia-cuda-gdk
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*nvidia-cuda-gdk-340.29 (18 Nov 2014)
+
+ 18 Nov 2014; Marius Brehler <marbre@linux.sungazer.de>
+ +files/nvidia-healthmon, +metadata.xml, +nvidia-cuda-gdk-340.29.ebuild:
+ Inital commit.
diff --git a/dev-util/nvidia-cuda-gdk/Manifest b/dev-util/nvidia-cuda-gdk/Manifest
new file mode 100644
index 000000000..c2264b195
--- /dev/null
+++ b/dev-util/nvidia-cuda-gdk/Manifest
@@ -0,0 +1,2 @@
+DIST cuda_340_29_gdk_linux_32.run 2736726 SHA256 69dd21a556c04982ad720d8eed5ef90cd7c00d3ff4f1ac7087c9a98433a5795e SHA512 30e659fd337c455fd23a3120650565340d7963c77c6b5f46d5549b8f9b1d080659ae3dd6d12cfc4eaa7f9862fe4b2b511b19b023be5180e5e9937cd5d74938d7 WHIRLPOOL 569972d4281f71d450c88794e1b7efef4c6c24ce5a4717b203e0c961fb42a44e6b89d0be167c145705632de63da3d14c63335ba0eec24c34f99bf67b60a6a011
+DIST cuda_340_29_gdk_linux_64.run 2752832 SHA256 c4dcc5294731bc7f01cd0eafe42a6784f897760e2ed44224db9865db6f7cd6fa SHA512 3310600ccddf0f79087aa48c61cf7c10bde2543f041571f1bf7c9721a5e41a993e6b231f6b01e37b22062e0b978da7135d89382b9a3a996b82b04283676469ff WHIRLPOOL 91b5c104140b9beb28fec6733f7fd71478993497bff7e9814777e3a8f2e4242c26bd383fcd3e3fbed94e221cdbecaecc53e98a4779d9f17ca4ee20362f36463d
diff --git a/dev-util/nvidia-cuda-gdk/files/nvidia-healthmon b/dev-util/nvidia-cuda-gdk/files/nvidia-healthmon
new file mode 100644
index 000000000..007c9dcaf
--- /dev/null
+++ b/dev-util/nvidia-cuda-gdk/files/nvidia-healthmon
@@ -0,0 +1,9 @@
+#!/bin/bash
+
+while getopts "c" opt
+do
+ case $opt in
+ c) exec /opt/cuda/gdk/nvidia-healthmon/nvidia-healthmon "$@";;
+ *) exec /opt/cuda/gdk/nvidia-healthmon/nvidia-healthmon -c /etc/nvidia-healtmon/nvidia-healtmon.conf "$@";;
+ esac
+done \ No newline at end of file
diff --git a/dev-util/nvidia-cuda-gdk/metadata.xml b/dev-util/nvidia-cuda-gdk/metadata.xml
new file mode 100644
index 000000000..d8e7e3dee
--- /dev/null
+++ b/dev-util/nvidia-cuda-gdk/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>marbre@linux.sungazer.de</email>
+ <name>Marius Brehler</name>
+ </maintainer>
+ <use>
+ <flag name="healthmon">
+ Install nvidia-healthmon.
+ </flag>
+ <flag name="nvml">
+ Install the NVIDIA Managment Library.
+ </flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-util/nvidia-cuda-gdk/nvidia-cuda-gdk-340.29.ebuild b/dev-util/nvidia-cuda-gdk/nvidia-cuda-gdk-340.29.ebuild
new file mode 100644
index 000000000..f5f50f8da
--- /dev/null
+++ b/dev-util/nvidia-cuda-gdk/nvidia-cuda-gdk-340.29.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils toolchain-funcs portability unpacker versionator
+
+MYD=$(get_version_component_range 1)_$(get_version_component_range 2)
+
+DESCRIPTION="NVIDIA GPU Deployment Kit"
+HOMEPAGE="https://developer.nvidia.com/gpu-deployment-kit"
+CURI="http://developer.download.nvidia.com/compute/cuda/6_5/rel/installers"
+SRC_URI="
+ amd64? ( ${CURI}/cuda_${MYD}_gdk_linux_64.run )
+ x86? ( ${CURI}/cuda_${MYD}_gdk_linux_32.run )"
+
+LICENSE="NVIDIA-gdk"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+healthmon +nvml +doc examples"
+
+RDEPEND="
+>=dev-util/nvidia-cuda-toolkit-6.5
+examples? ( >=x11-drivers/nvidia-drivers-340.32[uvm] )
+media-libs/freeglut
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/payload"
+
+RESTRICT="binchecks"
+
+src_unpack() {
+ unpacker
+}
+
+src_compile() {
+ use examples || return
+ cd "${S}"/nvml/example
+ emake || die
+}
+
+src_install() {
+ cd "${S}/"
+
+ local i j f t
+
+ if use doc; then
+ if use healthmon ; then
+ ebegin "Installing healthmon docs..."
+ doman nvidia-healthmon/docs/man/man8/nvidia-healthmon.8
+ cd "${S}/nvidia-healthmon/nvidia-healthmon-amd64-${PV}"
+ treecopy $(find -type f \( -name README.txt -name COPYING.txt -o -name "*.pdf" \)) "${ED}"/usr/share/doc/${PF}/nvidia-healthmon/
+ docompress -x $(find "${ED}"/usr/share/doc/${PF}/nvidia-healthmon/ -type f -name readme.txt | sed -e "s:${ED}::")
+ cd "${S}/"
+ eend
+ fi
+
+ if use healthmon ; then
+ ebegin "Installing nvml docs..."
+ doman nvml/doc/man/man3/*.3
+ cd "${S}/nvml/"
+ treecopy $(find -type f \( -name README.txt -name COPYRIGHT.txt -o -name "*.pdf" \)) "${ED}"/usr/share/doc/${PF}/nvml/
+ docompress -x $(find "${ED}"/usr/share/doc/${PF}/nvml/ -type f -name readme.txt | sed -e "s:${ED}::")
+ cd "${S}/"
+ eend
+ fi
+ fi
+
+ ebegin "Cleaning before installation..."
+ find -type f \( -name "*.o" -o -name "*.pdf" -o -name "*.txt" -o -name "*.3" \) -delete || die
+ eend
+
+ if use healthmon; then
+ ebegin "Installing nvidia-healthmon"
+ exeinto "/opt/cuda/gdk/nvidia-healthmon/nvidia-healthmon-tests/"
+ doexe "nvidia-healthmon/nvidia-healthmon-amd64-${PV}/bin"/gpu_rdma_bw
+ doexe "nvidia-healthmon/nvidia-healthmon-amd64-${PV}/bin"/ibv_rdma_bw
+ doexe "nvidia-healthmon/nvidia-healthmon-amd64-${PV}/bin"/rdma_test.sh
+ exeinto "/opt/cuda/gdk/nvidia-healthmon/"
+ doexe "nvidia-healthmon/nvidia-healthmon-amd64-${PV}"/nvidia-healthmon
+ insinto "/etc/nvidia-healthmon/"
+ doins "nvidia-healthmon/nvidia-healthmon-amd64-${PV}"/nvidia-healthmon.conf
+
+ # install launch script
+ exeinto /opt/bin
+ doexe "${FILESDIR}"/nvidia-healthmon
+ fi
+
+ if use nvml; then
+ ebegin "Installing nvml"
+ cd "${S}/nvml"
+ for f in $(find .); do
+ local t="$(dirname ${f})"
+ if [[ "${t/obj\/}" != "${t}" || "${t##*.}" == "a" ]]; then
+ continue
+ fi
+
+ if [[ ! -d "${f}" ]]; then
+ if [[ -x "${f}" ]]; then
+ exeinto "/opt/cuda/gdk/nvml/${t}"
+ doexe "${f}"
+ else
+ insinto "/opt/cuda/gdk/nvml/${t}"
+ doins "${f}"
+ fi
+ fi
+ done
+ cd "${S}/"
+ fi
+
+}
diff --git a/licenses/NVIDIA-gdk b/licenses/NVIDIA-gdk
new file mode 100644
index 000000000..769c505a7
--- /dev/null
+++ b/licenses/NVIDIA-gdk
@@ -0,0 +1,32 @@
+Copyright 1993-2014 NVIDIA Corporation. All rights reserved.
+
+NOTICE TO USER:
+
+This source code is subject to NVIDIA ownership rights under U.S. and
+international Copyright laws. Users and possessors of this source code
+are hereby granted a nonexclusive, royalty-free license to use this code
+in individual and commercial software.
+
+NVIDIA MAKES NO REPRESENTATION ABOUT THE SUITABILITY OF THIS SOURCE
+CODE FOR ANY PURPOSE. IT IS PROVIDED "AS IS" WITHOUT EXPRESS OR
+IMPLIED WARRANTY OF ANY KIND. NVIDIA DISCLAIMS ALL WARRANTIES WITH
+REGARD TO THIS SOURCE CODE, INCLUDING ALL IMPLIED WARRANTIES OF
+MERCHANTABILITY, NONINFRINGEMENT, AND FITNESS FOR A PARTICULAR PURPOSE.
+IN NO EVENT SHALL NVIDIA BE LIABLE FOR ANY SPECIAL, INDIRECT, INCIDENTAL,
+OR CONSEQUENTIAL DAMAGES, OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS
+OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE
+OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE
+OR PERFORMANCE OF THIS SOURCE CODE.
+
+U.S. Government End Users. This source code is a "commercial item" as
+that term is defined at 48 C.F.R. 2.101 (OCT 1995), consisting of
+"commercial computer software" and "commercial computer software
+documentation" as such terms are used in 48 C.F.R. 12.212 (SEPT 1995)
+and is provided to the U.S. Government only as a commercial end item.
+Consistent with 48 C.F.R.12.212 and 48 C.F.R. 227.7202-1 through
+227.7202-4 (JUNE 1995), all U.S. Government End Users acquire the
+source code with only those rights set forth herein.
+
+Any use of this source code in individual and commercial software must
+include, in the user documentation and internal comments to the code,
+the above Disclaimer and U.S. Government End Users Notice.