aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/tensorflow/Manifest5
-rw-r--r--sci-libs/tensorflow/metadata.xml15
-rw-r--r--sci-libs/tensorflow/tensorflow-1.0.1.ebuild28
-rw-r--r--sci-libs/tensorflow/tensorflow-1.5.0.ebuild43
-rw-r--r--sci-libs/tensorflow/tensorflow-1.7.0.ebuild111
-rw-r--r--sci-libs/tensorflow/tensorflow-1.8.0.ebuild200
6 files changed, 0 insertions, 402 deletions
diff --git a/sci-libs/tensorflow/Manifest b/sci-libs/tensorflow/Manifest
deleted file mode 100644
index c11e6952f..000000000
--- a/sci-libs/tensorflow/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-DIST tensorflow-1.0.1.tar.gz 10919903 BLAKE2B 1ce4de131436b2b7fec909251a8b4c03d872920cbe788eb9914c5670803fc0baf8462d1d6498c9ee3ef4e941bd0286bebda44745ac49d8044627a93fac28c746 SHA512 49f22cd6baca8770401aacd870b30b33f4eaa576c9f2d3caae0a00225d40041352d5300cb3dc5ec90ec9f0e8865eb542a7d3d6a0f39ceb6d0f2606cc4725f0a7
-DIST tensorflow-1.5.0.tar.gz 19155285 BLAKE2B 32000e583b85f195fc62acafc22254d8806b26a59f06b024c2be98c0a3b5770cbfc60f73957a3f11cdbf7488b8891978f73a22b6d642fdd763ecd95f18e38d65 SHA512 63240d72b9946db29279800b1081adc4cc08b6cd7dc35155a529cc335bfc1dd16fb525fb6047f6cc0dcec547a54e7e100698a176ee93f5633965cfab2a8ad9eb
-DIST tensorflow-1.7.0.tar.gz 21202162 BLAKE2B 28ce2e002aa6c44681aa4f55af6172b05a3b4f797b5093db23ab67adf06170df9d1a9c64705613e17e6c1ff0f95fe9a1115464c697585ab83fef7baee5ea0985 SHA512 68fffad324be7f6e3726ea539670572729bd72c7dc935edfdb31771f821f1a8fe90c3d7c293969f660a25e5fd76249cc9b74c5f8511c7bd3e2189d3328044f29
-DIST tensorflow-1.8.0-bazel-cache-repos.tar.xz 92733476 BLAKE2B c2ec4fd574031d88bc216f2a64f3867afe27f78a9336fe93f9b64f0156af16c026e2ef56e065b30644f7e2b4f086bcf4dfc0b409ac2e69f1c5811dbe8edc310b SHA512 983123e686cd904dd6e1300819708287bd2dc5077c33e68ad70bb233727e2d9f5c181a9967d1ae8e63b99bb6fe280648f09379fb821dd036d728ffed78a9121b
-DIST tensorflow-1.8.0.tar.gz 22649439 BLAKE2B 7384c2cf742fb5a8b4e266e95080ae2513c1b112ab97f74839fa8e81bd91bd24645be8afb02e4447ad5fba9f47c4d146f59aa12085937cd3a364ec34c99590f3 SHA512 7280e65d26fb3f15d95f7217ee3bc08d1424cd144cf25bf638fa114fa835b2505dfaf457c55700067d24f485b77120973d094ec568e6d1b1054857402f9c352d
diff --git a/sci-libs/tensorflow/metadata.xml b/sci-libs/tensorflow/metadata.xml
deleted file mode 100644
index b94b432fa..000000000
--- a/sci-libs/tensorflow/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>mmokrejs@fold.natur.cuni.cz</email>
- <name>Martin Mokrejs</name>
- </maintainer>
- <maintainer type="project">
- <email>sci-biology@gentoo.org</email>
- <name>Gentoo Biology Project</name>
- </maintainer>
- <use>
- <flag name="cuda">Enable CUDA support</flag>
- </use>
-</pkgmetadata>
diff --git a/sci-libs/tensorflow/tensorflow-1.0.1.ebuild b/sci-libs/tensorflow/tensorflow-1.0.1.ebuild
deleted file mode 100644
index b2e2e596a..000000000
--- a/sci-libs/tensorflow/tensorflow-1.0.1.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{3,4,5,6} )
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="Library for numerical computation using data flow graphs"
-HOMEPAGE="https://www.tensorflow.org
- https://github.com/tensorflow/tensorflow"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS=""
-IUSE="cuda mpi"
-
-DEPEND="dev-util/bazel
- dev-python/wheel
- dev-python/numpy
- dev-libs/protobuf-c
- cuda? ( x11-drivers/nvidia-drivers dev-util/nvidia-cuda-toolkit )
- mpi? ( virtual/mpi )"
-RDEPEND="${DEPEND}"
-
-# TODO: seems it also support some MPI implementation
diff --git a/sci-libs/tensorflow/tensorflow-1.5.0.ebuild b/sci-libs/tensorflow/tensorflow-1.5.0.ebuild
deleted file mode 100644
index 0dae0c1d0..000000000
--- a/sci-libs/tensorflow/tensorflow-1.5.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{3,4,5,6} )
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="Library for numerical computation using data flow graphs"
-HOMEPAGE="https://www.tensorflow.org
- https://github.com/tensorflow/tensorflow"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS=""
-IUSE="cuda mpi"
-
-# TensorFlow 1.7 may be the last time we support Cuda versions below 8.0.
-# Starting with TensorFlow 1.8 release, 8.0 will be the minimum supported
-# version.
-# TensorFlow 1.7 may be the last time we support cuDNN versions below 6.0.
-# Starting with TensorFlow 1.8 release, 6.0 will be the minimum supported
-# version.
-DEPEND="dev-util/bazel
- dev-python/wheel
- dev-python/numpy
- dev-libs/protobuf-c
- cuda? ( >=dev-util/nvidia-cuda-toolkit-7.0[profiler] >=dev-libs/cudnn-3 )
- mpi? ( virtual/mpi )"
-RDEPEND="${DEPEND}"
-
-# TODO: seems it also supports some MPI implementation
-
-src_configure(){
- # there is no setup.py but there is configure
- # https://www.tensorflow.org/install/install_sources
- # https://www.tensorflow.org/install/install_linux#InstallingNativePip
- #
- # usage: configure.py [-h] [--workspace WORKSPACE]
- ./configure || die
-}
diff --git a/sci-libs/tensorflow/tensorflow-1.7.0.ebuild b/sci-libs/tensorflow/tensorflow-1.7.0.ebuild
deleted file mode 100644
index 758872b99..000000000
--- a/sci-libs/tensorflow/tensorflow-1.7.0.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{3,4,5,6} )
-
-inherit python-r1 distutils-r1 eutils
-
-DESCRIPTION="Library for numerical computation using data flow graphs"
-HOMEPAGE="https://www.tensorflow.org
- https://github.com/tensorflow/tensorflow"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS=""
-IUSE="cuda mpi"
-
-# TensorFlow 1.7 may be the last time we support Cuda versions below 8.0.
-# Starting with TensorFlow 1.8 release, 8.0 will be the minimum supported
-# version.
-# TensorFlow 1.7 may be the last time we support cuDNN versions below 6.0.
-# Starting with TensorFlow 1.8 release, 6.0 will be the minimum supported
-# version.
-DEPEND="
- dev-util/bazel
- dev-python/wheel
- dev-python/numpy
- dev-libs/protobuf-c
- dev-python/absl-py
- cuda? ( >=dev-util/nvidia-cuda-toolkit-7.0[profiler] >=dev-libs/cudnn-3 )
- mpi? ( virtual/mpi )"
- #opencl? ( virtual/opencl )"
-RDEPEND="${DEPEND}"
-
-# TODO: seems it also supports some MPI implementations
-src_configure(){
- # there is no setup.py but there is configure
- # https://www.tensorflow.org/install/install_sources
- # https://www.tensorflow.org/install/install_linux#InstallingNativePip
- #
- # usage: configure.py [-h] [--workspace WORKSPACE]
- python_configure() {
- export PYTHON_BIN_PATH=${PYTHON}
- export PYTHON_LIB_PATH=${PYTHON_SITEDIR}
- export TF_NEED_JEMALLOC=1
- export TF_NEED_GCP=0
- export TF_NEED_HDFS=0
- export TF_NEED_S3=0
- export TF_NEED_KAFKA=0
- export TF_ENABLE_XLA=0
- export TF_NEED_GDR=0
- export TF_NEED_VERBS=0
- export TF_NEED_OPENCL=0
- if use cuda; then
- export TF_NEED_CUDA=1
- else
- export TF_NEED_CUDA=0
- fi
- if use mpi; then
- export TF_NEED_MPI=1
- else
- export TF_NEED_MPI=0
- fi
- export TF_NEED_OPENCL_SYCL=0
- export CC_OPT_FLAGS=${CFLAGS}
- export JAVA_HOME=$(java-config -O)
- # TODO: protect by a USE flag test --config=mkl
- ./configure || die
- }
- python_foreach_impl python_configure
-}
-
-src_compile() {
- python_compile() {
- # huh, by default tensorflow links static libs? See BUILD file
- # set framework_shared_object=true somehow
- if use cuda; then
- local opt="--config=cuda"
- else
- local opt=""
- fi
- bazel build --config=opt ${opt} /tensorflow/tools/pip_package:build_pip_package || die
- bazel-bin/tensorflow/tools/pip_package/build_pip_package tensorflow_pkg || die
- unzip -o -d tensorflow_pkg tensorflow_pkg/${P}-cp35-cp35m-linux_x86_64.whl || die
- python_domodule tensorflow_pkg/${P}.data/purelib/tensorflow
- bazel test || die
- bazel shutdown || die
- }
- python_foreach_impl python_compile
-}
-
-src_test() {
- python_foreach_impl python_test
-}
-
-src_install() {
- python_install() {
- # steal site-package path determination from sci-mathematics/z3
- local PYTHON_SITEDIR
- python_export PYTHON_SITEDIR
- cp -av tensorflow_pkg/"${P}".data/purelib/tensorflow/ "$PYTHON_SITEDIR" || die
- cp -av tensorflow_pkg/"${P}".dist-info "$PYTHON_SITEDIR" || die
- # mkdir -p "${D}/usr/$(get_libdir)/python3.6/site-packages" || die
- # cp -av tensorflow_pkg/"${P}".data/purelib/tensorflow/ "${ED}/usr/$(get_libdir)/python3.6/site-packages/" || die
- # cp -av tensorflow_pkg/"${P}".dist-info "${ED}/usr/$(get_libdir)/python3.6/site-packages/" || die
- }
- python_foreach_impl python_install
- einstalldocs
-}
diff --git a/sci-libs/tensorflow/tensorflow-1.8.0.ebuild b/sci-libs/tensorflow/tensorflow-1.8.0.ebuild
deleted file mode 100644
index 557095bc7..000000000
--- a/sci-libs/tensorflow/tensorflow-1.8.0.ebuild
+++ /dev/null
@@ -1,200 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{3,4,5,6} )
-
-inherit python-r1 distutils-r1 eutils versionator
-
-DESCRIPTION="Library for numerical computation using data flow graphs"
-HOMEPAGE="https://www.tensorflow.org
- https://github.com/tensorflow/tensorflow"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://dev.gentoo.org/~gienah/snapshots/${P}-bazel-cache-repos.tar.xz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="cuda cxx mpi"
-
-# To create the cache repo tar file, temporarilly remove the
-# ${P}-bazel-cache-repos.tar.xz from SRC_URI and src_upack. Then build
-# it so that bazel will download the files:
-# FEATURES="noclean -network-sandbox" emerge -av sci-libs/tensorflow
-# cd /var/tmp/portage/sci-libs/${P}
-# tar --owner=portage --group=portage -cJvf \
-# /usr/portage/distfiles/${P}-bazel-cache-repos.tar.xz \
-# homedir/.cache/bazel/_bazel_portage/cache/repos/v1
-
-# TensorFlow 1.7 may be the last time we support Cuda versions below 8.0.
-# Starting with TensorFlow 1.8 release, 8.0 will be the minimum supported
-# version.
-# TensorFlow 1.7 may be the last time we support cuDNN versions below 6.0.
-# Starting with TensorFlow 1.8 release, 6.0 will be the minimum supported
-# version.
-# Possibly missing deps:
-# dev-python/gast
-DEPEND="
- cxx? ( dev-libs/protobuf )
- dev-python/absl-py[${PYTHON_USEDEP}]
- dev-python/astor[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/protobuf-python[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/termcolor[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- dev-libs/jemalloc
- dev-libs/protobuf-c
- dev-util/bazel
- media-libs/giflib
- virtual/jpeg:0
- cuda? ( >=dev-util/nvidia-cuda-toolkit-8.0[profiler] >=dev-libs/cudnn-6 )
- mpi? ( virtual/mpi )"
- #opencl? ( virtual/opencl )"
-RDEPEND="${DEPEND}"
-
-src_unpack() {
- unpack ${P}.tar.gz
- pushd .. || die
- unpack distdir/${P}-bazel-cache-repos.tar.xz
- popd || die
-}
-
-# TODO: seems it also supports some MPI implementations
-src_configure(){
- # there is no setup.py but there is configure
- # https://www.tensorflow.org/install/install_sources
- # https://www.tensorflow.org/install/install_linux#InstallingNativePip
- #
- # usage: configure.py [-h] [--workspace WORKSPACE]
- python_configure() {
- export PYTHON_BIN_PATH=${PYTHON}
- export PYTHON_LIB_PATH=${PYTHON_SITEDIR}
- export TF_NEED_JEMALLOC=1
- export TF_NEED_GCP=0
- export TF_NEED_HDFS=0
- export TF_NEED_S3=0
- export TF_NEED_KAFKA=0
- export TF_ENABLE_XLA=0
- export TF_NEED_GDR=0
- export TF_NEED_VERBS=0
- export TF_NEED_OPENCL=0
- if use cuda; then
- export TF_NEED_CUDA=1
- else
- export TF_NEED_CUDA=0
- fi
- if use mpi; then
- export TF_NEED_MPI=1
- else
- export TF_NEED_MPI=0
- fi
- export TF_NEED_OPENCL_SYCL=0
- export CC_OPT_FLAGS=${CFLAGS}
- export JAVA_HOME=$(java-config -O)
- # TODO: protect by a USE flag test --config=mkl
- ./configure || die
- }
- python_foreach_impl python_configure
-}
-
-bazel-get-flags() {
- local fs=""
- for i in ${CXXFLAGS}; do
- [[ -n "${fs}" ]] && fs+=" "
- fs+="--cxxopt=${i}"
- done
- for i in ${CPPFLAGS}; do
- [[ -n "${fs}" ]] && fs+=" "
- fs+="--copt=${i}"
- fs+="--cxxopt=${i}"
- done
- for i in ${LDFLAGS}; do
- [[ -n "${fs}" ]] && fs+=" "
- fs+="--linkopt=${i}"
- done
- echo "${fs}"
-}
-
-src_compile() {
- # F: fopen_wr
- # S: deny
- # P: /proc/self/setgroups
- # A: /proc/self/setgroups
- # R: /proc/7712/setgroups
- # C: unable to read /proc/1/cmdline
- addpredict /proc
-
- local opt=$(usex cuda "--config=cuda" "")
- einfo ">>> Compiling ${PN} C"$(usex cxx " and C++" "")
- einfo " bazel build \\"
- einfo " --config=opt ${opt} \\"
- einfo " $(bazel-get-flags) \\"
- einfo " //tensorflow:libtensorflow.so \\"
- einfo " //tensorflow:libtensorflow_framework.so \\"
- einfo " "$(usex cxx "//tensorflow:libtensorflow_cc.so" "")
- bazel build \
- --config=opt ${opt} \
- $(bazel-get-flags) \
- //tensorflow:libtensorflow.so \
- //tensorflow:libtensorflow_framework.so \
- $(usex cxx "//tensorflow:libtensorflow_cc.so" "") || die
-
- python_compile() {
- einfo ">>> Compiling ${PN} ${MULTIBUILD_VARIANT}"
- einfo " bazel build \\"
- einfo " --config=opt ${opt} \\"
- einfo " $(bazel-get-flags) \\"
- einfo " //tensorflow/tools/pip_package:build_pip_package"
- bazel build \
- --config=opt ${opt} \
- $(bazel-get-flags) \
- //tensorflow/tools/pip_package:build_pip_package || die
- bazel-bin/tensorflow/tools/pip_package/build_pip_package tensorflow_pkg || die
- unzip -o -d ${PN}_pkg_${MULTIBUILD_VARIANT} ${PN}_pkg/${P}-*.whl || die
- rm -f ${PN}_pkg_${MULTIBUILD_VARIANT}/lib${PN}_framework.so || die
- }
- python_foreach_impl python_compile
- bazel shutdown || die
-}
-
-src_test() {
- python_foreach_impl python_test
-}
-
-src_install() {
- local SO1=$(get_major_version)
- local SOVER=$(version_format_string '$1.$2')
- local tl="${PN} ${PN}_framework"
- dodir /usr/include/${PN}/${PN}/c
- insinto /usr/include/${PN}/${PN}/c
- doins ${PN}/c/c_api.h
- if use cxx; then
- for i in $(find ${PN}/cc ${PN}/core third_party/eigen3 -type f \
- \( -name \*.h -o \
- -wholename third_party/eigen3/Eigen/\* \) -print); do
- dodir $(dirname /usr/include/${PN}/${i})
- insinto $(dirname /usr/include/${PN}/${i})
- doins ${i}
- done
- tl+=" ${PN}_cc"
- fi
- for i in ${tl}; do
- dolib.so bazel-bin/${PN}/lib${i}.so
- dosym "lib${i}.so" \
- "/usr/$(get_libdir)/lib${i}.so.${SO1}" \
- || die "Could not create /usr/$(get_libdir)/lib${i}.so.${SO1} symlink"
- dosym "lib${i}.so" \
- "/usr/$(get_libdir)/lib${i}.so.${SOVER}" \
- || die "Could not create /usr/$(get_libdir)/lib${i}.so.${SOVER} symlink"
- done
- python_install() {
- python_domodule ${PN}_pkg_${MULTIBUILD_VARIANT}/${P}.data/purelib/${PN}
- dosym "../../../lib${PN}_framework.so" \
- "$(python_get_sitedir)/${PN}/lib${PN}_framework.so" \
- || die "Could not create $(python_get_sitedir)/lib${PN}_framework.so symlink for python module"
- }
- python_foreach_impl python_install
- einstalldocs
-}