aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-biology/quicktree/quicktree-1.1-r1.ebuild4
-rw-r--r--sci-libs/libfac/ChangeLog6
-rw-r--r--sci-libs/libfac/libfac-3.1.0.ebuild10
-rw-r--r--sci-libs/libfac/libfac-3.1.1.ebuild10
-rw-r--r--sci-libs/matio/ChangeLog6
-rw-r--r--sci-libs/matio/matio-1.3.4.ebuild32
-rw-r--r--sys-cluster/htcondor/files/Apply-the-user-s-condor_config-last-rather-than-first-8.3.2.patch25
-rw-r--r--sys-cluster/htcondor/files/condor_config.generic-8.3.2.patch43
-rw-r--r--sys-cluster/htcondor/files/condor_shadow_dlopen-8.3.2.patch11
-rw-r--r--sys-cluster/htcondor/files/packaging_directories-8.3.2.patch32
-rw-r--r--sys-cluster/htcondor/htcondor-8.3.2.ebuild6
11 files changed, 146 insertions, 39 deletions
diff --git a/sci-biology/quicktree/quicktree-1.1-r1.ebuild b/sci-biology/quicktree/quicktree-1.1-r1.ebuild
index a0d00fd56..5262e73f7 100644
--- a/sci-biology/quicktree/quicktree-1.1-r1.ebuild
+++ b/sci-biology/quicktree/quicktree-1.1-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=2
+EAPI=5
inherit toolchain-funcs
diff --git a/sci-libs/libfac/ChangeLog b/sci-libs/libfac/ChangeLog
index 5ec780e86..23f9ac3cf 100644
--- a/sci-libs/libfac/ChangeLog
+++ b/sci-libs/libfac/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for sci-libs/libfac
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 10 Jan 2014; Marius Brehler <marbre@linux.sungazer.de>
+ libfac-3.1.1.ebuild, libfac-3.1.0.ebuild:
+ Move to EAPI=5; Clean ebuild
+
25 Jun 2011; Justin Lecher <jlec@gentoo.org> libfac-3.1.0.ebuild,
libfac-3.1.1.ebuild, metadata.xml:
Cleaned ebuild and add USE description to metadata.xml
diff --git a/sci-libs/libfac/libfac-3.1.0.ebuild b/sci-libs/libfac/libfac-3.1.0.ebuild
index 8b82b54e7..81bd94df5 100644
--- a/sci-libs/libfac/libfac-3.1.0.ebuild
+++ b/sci-libs/libfac/libfac-3.1.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=2
+EAPI=5
inherit eutils versionator
@@ -22,10 +22,6 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${PN}"
-RESTRICT="mirror"
-
src_configure() {
- econf --prefix="${D}/usr" \
- $(use_with singular Singular)
-
+ econf $(use_with singular Singular)
}
diff --git a/sci-libs/libfac/libfac-3.1.1.ebuild b/sci-libs/libfac/libfac-3.1.1.ebuild
index 8b82b54e7..81bd94df5 100644
--- a/sci-libs/libfac/libfac-3.1.1.ebuild
+++ b/sci-libs/libfac/libfac-3.1.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=2
+EAPI=5
inherit eutils versionator
@@ -22,10 +22,6 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${PN}"
-RESTRICT="mirror"
-
src_configure() {
- econf --prefix="${D}/usr" \
- $(use_with singular Singular)
-
+ econf $(use_with singular Singular)
}
diff --git a/sci-libs/matio/ChangeLog b/sci-libs/matio/ChangeLog
index 620f108b5..bed9be26c 100644
--- a/sci-libs/matio/ChangeLog
+++ b/sci-libs/matio/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for sci-libs/matio
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 11 Jan 2015; Marius Brehler <marbre@linux.sungazer.de> matio-1.3.4.ebuild:
+ Move to EAPI=5, cleanup the ebuild
+
+
21 Jun 2011; Justin Lecher <jlec@gentoo.org> matio-1.3.4.ebuild:
Added fortran-2.eclass support
diff --git a/sci-libs/matio/matio-1.3.4.ebuild b/sci-libs/matio/matio-1.3.4.ebuild
index 5f948f6bd..8d2b050d5 100644
--- a/sci-libs/matio/matio-1.3.4.ebuild
+++ b/sci-libs/matio/matio-1.3.4.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=3
-inherit autotools eutils fortran-2
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils eutils fortran-2
DESCRIPTION="Library for reading and writing matlab files"
HOMEPAGE="http://sourceforge.net/projects/matio/"
@@ -16,32 +18,26 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
#DEPEND="doc? ( app-doc/doxygen virtual/latex-base )"
RDEPEND=""
-src_prepare() {
- epatch "${FILESDIR}"/${P}-autotools.patch
- eautoreconf
-}
+PATCHES=( "${FILESDIR}/${P}"-autotools.patch )
src_configure() {
- econf \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- --enable-shared \
- --disable-test \
- $(use_enable fortran) \
- $(use_enable doc docs) \
- $(use_enable static-libs static)
+ local myeconfargs=(
+ --disable-test
+ #$(use_enable doc docs)
+ )
+ autotools-utils_src_configure
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc README ChangeLog
+ autotools-utils_src_install
#if use doc; then
# insinto /usr/share/doc/${PF}
# doins -r doxygen/html || die
#fi
if use examples; then
insinto /usr/share/doc/${PF}/examples
- doins test/test* || die
+ doins test/test*
insinto /usr/share/${PN}
- doins share/test* || die
+ doins share/test*
fi
}
diff --git a/sys-cluster/htcondor/files/Apply-the-user-s-condor_config-last-rather-than-first-8.3.2.patch b/sys-cluster/htcondor/files/Apply-the-user-s-condor_config-last-rather-than-first-8.3.2.patch
new file mode 100644
index 000000000..bedd7c595
--- /dev/null
+++ b/sys-cluster/htcondor/files/Apply-the-user-s-condor_config-last-rather-than-first-8.3.2.patch
@@ -0,0 +1,25 @@
+--- src/condor_utils/condor_config.cpp 2014-12-23 18:18:42.000000000 +0100
++++ src/condor_utils/condor_config.cpp 2015-01-11 19:59:17.000000000 +0100
+@@ -1454,18 +1454,14 @@ find_file(const char *env_name, const ch
+ if (!config_source) {
+ // List of condor_config file locations we'll try to open.
+ // As soon as we find one, we'll stop looking.
+- const int locations_length = 4;
++ const int locations_length = 3;
+ MyString locations[locations_length];
+- // 1) $HOME/.condor/condor_config
+- // $HOME/.condor/condor_config was added for BOSCO and never used, We are removing it in 8.3.1, but may put it back if users complain.
+- //find_user_file(locations[0], file_name, false);
+- // 2) /etc/condor/condor_config
+- locations[1].formatstr( "/etc/%s/%s", myDistro->Get(), file_name );
++ locations[0].formatstr( "/etc/%s/%s", myDistro->Get(), file_name );
+ // 3) /usr/local/etc/condor_config (FreeBSD)
+- locations[2].formatstr( "/usr/local/etc/%s", file_name );
++ locations[1].formatstr( "/usr/local/etc/%s", file_name );
+ if (tilde) {
+ // 4) ~condor/condor_config
+- locations[3].formatstr( "%s/%s", tilde, file_name );
++ locations[2].formatstr( "%s/%s", tilde, file_name );
+ }
+
+ int ctr;
diff --git a/sys-cluster/htcondor/files/condor_config.generic-8.3.2.patch b/sys-cluster/htcondor/files/condor_config.generic-8.3.2.patch
new file mode 100644
index 000000000..8e8fac99f
--- /dev/null
+++ b/sys-cluster/htcondor/files/condor_config.generic-8.3.2.patch
@@ -0,0 +1,43 @@
+--- b/src/condor_examples/condor_config.generic 2015-01-11 19:34:36.000000000 +0100
++++ a/src/condor_examples/condor_config.generic 2015-01-11 19:38:18.000000000 +0100
+@@ -19,7 +19,7 @@
+ ######################################################################
+
+ ## Where have you installed the bin, sbin and lib condor directories?
+-RELEASE_DIR = /usr/local/condor
++RELEASE_DIR = /usr
+
+ ## Where is the local condor directory for each host? This is where the local config file(s), logs and
+ ## spool/execute directories are located. this is the default for Linux and Unix systems.
+@@ -27,18 +27,22 @@ RELEASE_DIR = /usr/local/condor
+ ## this is the default on Windows sytems
+ #LOCAL_DIR = $(RELEASE_DIR)
+
+-## Where is the machine-specific local config file for each host?
+-LOCAL_CONFIG_FILE = $(LOCAL_DIR)/condor_config.local
+-## If your configuration is on a shared file system, then this might be a better default
+-#LOCAL_CONFIG_FILE = $(RELEASE_DIR)/etc/$(HOSTNAME).local
++## Looking for LOCAL_CONFIG_FILE? You will not find it here. Instead
++## put a file in the LOCAL_CONFIG_DIR below. It is a more extensible
++## means to manage configuration. The order in which configuration
++## files are read from the LOCAL_CONFIG_DIR is lexicographic. For
++## instance, config in 00MyConfig will be overridden by config in
++## 97MyConfig.
+ ## If the local config file is not present, is it an error? (WARNING: This is a potential security issue.)
+-#REQUIRE_LOCAL_CONFIG_FILE = true
++REQUIRE_LOCAL_CONFIG_FILE = false
+
+-## The normal way to do configuration with RPMs is to read all of the
+-## files in a given directory that don't match a regex as configuration files.
++## Where are optional machine-specific local config files located?
+ ## Config files are read in lexicographic order.
+-LOCAL_CONFIG_DIR = $(LOCAL_DIR)/config
+-#LOCAL_CONFIG_DIR_EXCLUDE_REGEXP = ^((\..*)|(.*~)|(#.*)|(.*\.rpmsave)|(.*\.rpmnew))$
++## No default.
++LOCAL_CONFIG_DIR = $(ETC)/config.d
++
++## Blacklist for file processing in the LOCAL_CONFIG_DIR
++LOCAL_CONFIG_DIR_EXCLUDE_REGEXP = ^((\..*)|(.*~)|(#.*)|(.*\.rpmsave)|(.*\.rpmnew))$
+
+ ## Use a host-based security policy. By default CONDOR_HOST and the local machine will be allowed
+ use SECURITY : HOST_BASED
diff --git a/sys-cluster/htcondor/files/condor_shadow_dlopen-8.3.2.patch b/sys-cluster/htcondor/files/condor_shadow_dlopen-8.3.2.patch
new file mode 100644
index 000000000..5709e70b3
--- /dev/null
+++ b/sys-cluster/htcondor/files/condor_shadow_dlopen-8.3.2.patch
@@ -0,0 +1,11 @@
+--- b/build/cmake/CondorConfigure.cmake 2015-01-11 19:29:57.000000000 +0100
++++ a/build/cmake/CondorConfigure.cmake 2015-01-11 19:30:40.000000000 +0100
+@@ -841,7 +841,7 @@ set (CONDOR_LIBS "condor_utils;${RT_FOUN
+ set (CONDOR_TOOL_LIBS "condor_utils;${RT_FOUND};${CLASSADS_FOUND};${SECURITY_LIBS};${PCRE_FOUND};${COREDUMPER_FOUND}")
+ set (CONDOR_SCRIPT_PERMS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE)
+ if (LINUX OR DARWIN)
+- set (CONDOR_LIBS_FOR_SHADOW "condor_utils_s;classads;${SECURITY_LIBS};${RT_FOUND};${PCRE_FOUND};${OPENSSL_FOUND};${KRB5_FOUND};${POSTGRESQL_FOUND};${COREDUMPER_FOUND};${IOKIT_FOUND};${COREFOUNDATION_FOUND}")
++ set (CONDOR_LIBS_FOR_SHADOW "condor_utils_s;classads;${SECURITY_LIBS};${RT_FOUND};${PCRE_FOUND};${OPENSSL_FOUND};${KRB5_FOUND};${POSTGRESQL_FOUND};${COREDUMPER_FOUND};${IOKIT_FOUND};${COREFOUNDATION_FOUND};dl")
+ if (DARWIN)
+ set (CONDOR_LIBS_FOR_SHADOW "${CONDOR_LIBS_FOR_SHADOW};resolv" )
+ endif (DARWIN)
diff --git a/sys-cluster/htcondor/files/packaging_directories-8.3.2.patch b/sys-cluster/htcondor/files/packaging_directories-8.3.2.patch
new file mode 100644
index 000000000..3faf0a258
--- /dev/null
+++ b/sys-cluster/htcondor/files/packaging_directories-8.3.2.patch
@@ -0,0 +1,32 @@
+--- b/build/cmake/CondorPackageConfig.cmake 2015-01-11 19:46:05.000000000 +0100
++++ a/build/cmake/CondorPackageConfig.cmake 2015-01-11 19:47:05.000000000 +0100
+@@ -406,6 +406,29 @@ elseif( ${OS_NAME} STREQUAL "LINUX" AND
+ set(CMAKE_INSTALL_PREFIX "")
+ set(CPACK_SET_DESTDIR "ON")
+
++ else()
++
++ #Directory overrides
++ set( C_BIN usr/bin )
++ set( C_LIB usr/lib\${LIB_SUFFIX}/condor )
++ set( C_LIB_PUBLIC usr/lib\${LIB_SUFFIX} )
++ set( C_LIB32 usr/lib\${LIB_SUFFIX}/condor )
++ set( C_SBIN usr/sbin )
++ set( C_INCLUDE usr/include/condor )
++ set( C_INCLUDE_PUBLIC usr/include )
++ set( C_MAN usr/share/man )
++ set( C_SRC usr/src)
++ set( C_SQL usr/share/condor/sql)
++ set( C_INIT etc/init.d )
++ set( C_ETC etc/condor )
++ set( C_CONFIGD etc/condor/config.d )
++
++ set( C_ETC_EXAMPLES usr/share/doc/htcondor-${VERSION}/etc/examples )
++ set( C_SHARE_EXAMPLES usr/share/doc/htcondor-${VERSION} )
++ set( C_DOC usr/share/doc/htcondor-${VERSION} )
++ set( C_LIBEXEC usr/lib\${LIB_SUFFIX}/condor/libexec )
++ set( C_SYSCONFIG etc/default )
++
+ endif()
+
+ set( EXTERNALS_LIB "${C_LIB}" )
diff --git a/sys-cluster/htcondor/htcondor-8.3.2.ebuild b/sys-cluster/htcondor/htcondor-8.3.2.ebuild
index 638715b2d..d2c6a552c 100644
--- a/sys-cluster/htcondor/htcondor-8.3.2.ebuild
+++ b/sys-cluster/htcondor/htcondor-8.3.2.ebuild
@@ -50,9 +50,9 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}/condor_shadow_dlopen-${PV}.patch"
- epatch "${FILESDIR}/condor_config.generic.patch"
- epatch "${FILESDIR}/0001-Apply-the-user-s-condor_config-last-rather-than-firs.patch"
- epatch "${FILESDIR}/packaging_directories-8.0.0.patch"
+ epatch "${FILESDIR}/condor_config.generic-${PV}.patch"
+ epatch "${FILESDIR}/Apply-the-user-s-condor_config-last-rather-than-first-${PV}.patch"
+ epatch "${FILESDIR}/packaging_directories-${PV}.patch"
epatch "${FILESDIR}/fix_sandbox_violations-8.0.0.patch"
cmake-utils_src_prepare
}