aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/matplotlib2tikz/ChangeLog6
-rw-r--r--dev-python/matplotlib2tikz/Manifest1
-rw-r--r--dev-python/matplotlib2tikz/matplotlib2tikz-0.5.1.ebuild24
3 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/matplotlib2tikz/ChangeLog b/dev-python/matplotlib2tikz/ChangeLog
index 09acef8ea..b357a96f2 100644
--- a/dev-python/matplotlib2tikz/ChangeLog
+++ b/dev-python/matplotlib2tikz/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Id$
+*matplotlib2tikz-0.5.1 (03 Dec 2015)
+
+ 03 Dec 2015; Marius Brehler <marbre@linux.sungazer.de>
+ +matplotlib2tikz-0.5.1.ebuild:
+ dev-python/matplotlib2tikz: Version bump
+
02 Nov 2015; Marius Brehler <marbre@linux.sungazer.de>
-files/matplotlib2tikz-0.2.0-setup.py.patch, -matplotlib2tikz-0.1.0.ebuild,
-matplotlib2tikz-0.2.0.ebuild:
diff --git a/dev-python/matplotlib2tikz/Manifest b/dev-python/matplotlib2tikz/Manifest
index 602a8b6c0..70c35c921 100644
--- a/dev-python/matplotlib2tikz/Manifest
+++ b/dev-python/matplotlib2tikz/Manifest
@@ -1,2 +1,3 @@
DIST matplotlib2tikz-0.2.4.tar.gz 20681 SHA256 dc0baaf8e854c1557885a22a23a1da4dcfbe43ce4dcd0c0a3253d282cf8a03a9 SHA512 51525fd025ea46f009509f720810bcf0e86d95c7656b13cd6ca5c9a0bf7d8ed82b0f4b4c77aabf17204fe50aded7b2f29f86b48c1ec545dfefb729f15476905f WHIRLPOOL 0cb764e71e3c27863c72205428c76b7590c65c32e09a90538fa8ccb30104b66309f348e4d1118078b7cc60bd3d7d1a6efc3d2838c76c1241044fc4881670742d
DIST matplotlib2tikz-0.4.0.tar.gz 21574 SHA256 d93f9ef7d89b09daa5301da734cc968506a35baff6eb26e53aa32b717532700a SHA512 3bff786418ace22717b5c9bb693a9101e224ad64667bf3c67beeabbbfec581b7fea584ed755ca5d91b2e60286914d0ba69d8e2728001fd45ec41fc9ee6691e42 WHIRLPOOL 7a1715c2ee683c54347048edc8ccd48bd9fe734563ec88834077e862aa2900d18065163523c297cb824871cd134f663bbc9d36571a90c9d5f797298cd2a49678
+DIST matplotlib2tikz-0.5.1.tar.gz 22134 SHA256 30649d1783cf6d7e64085cbd9e1e076e49865f4c6512cc53f5d5e6d75bf487b2 SHA512 cf66c3cff5d93e0f5cc57f7c7204526444f74325b7f876c00e5ac4e8ee485a2306b490144413232e74b5671a03eae6d28ca16a207d1a10879065799e987471ad WHIRLPOOL 67ca46dcf0d1d3b1752df96ddcb7b2d661be82a5dd2d497ebf67df27e67e093689953aa056bab9cd8396ab79fea05c36930ade525d31bec37ca9dd2369abaae7
diff --git a/dev-python/matplotlib2tikz/matplotlib2tikz-0.5.1.ebuild b/dev-python/matplotlib2tikz/matplotlib2tikz-0.5.1.ebuild
new file mode 100644
index 000000000..f8677fb6c
--- /dev/null
+++ b/dev-python/matplotlib2tikz/matplotlib2tikz-0.5.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python script for converting matplotlib figures into native Pgfplots (TikZ) figures"
+HOMEPAGE="https://github.com/nschloe/matplotlib2tikz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-texlive/texlive-pictures"
+DEPEND="${RDEPEND}"
+ #test? ( dev-python/pytest[${PYTHON_USEDEP}] )"