aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/PyVISA/PyVISA-1.8.ebuild13
-rw-r--r--dev-python/PyVISA/PyVISA-9999.ebuild15
-rw-r--r--dev-python/PyVISA/metadata.xml2
3 files changed, 10 insertions, 20 deletions
diff --git a/dev-python/PyVISA/PyVISA-1.8.ebuild b/dev-python/PyVISA/PyVISA-1.8.ebuild
index e16717b37..bc6311678 100644
--- a/dev-python/PyVISA/PyVISA-1.8.ebuild
+++ b/dev-python/PyVISA/PyVISA-1.8.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python2_7 python{3_4,3_5} )
+EAPI=7
+PYTHON_COMPAT=( python3_6 )
inherit distutils-r1
DESCRIPTION="Python VISA bindings for GPIB, RS232, and USB instruments"
-HOMEPAGE="https://github.com/hgrecco/pyvisa"
+HOMEPAGE="https://pyvisa.readthedocs.io"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
@@ -15,11 +15,6 @@ SLOT="0"
KEYWORDS="~amd64"
IUSE="test"
-RDEPEND="
- $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7)
- "
-DEPEND="${RDEPEND}"
-
python_test() {
esetup.py test
}
diff --git a/dev-python/PyVISA/PyVISA-9999.ebuild b/dev-python/PyVISA/PyVISA-9999.ebuild
index a51331354..cc113f649 100644
--- a/dev-python/PyVISA/PyVISA-9999.ebuild
+++ b/dev-python/PyVISA/PyVISA-9999.ebuild
@@ -1,24 +1,19 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python2_7 python{3_4,3_5} )
+EAPI=7
+PYTHON_COMPAT=( python3_6 )
inherit distutils-r1 git-r3
DESCRIPTION="Python VISA bindings for GPIB, RS232, and USB instruments"
-HOMEPAGE="https://github.com/hgrecco/pyvisa-py"
+HOMEPAGE="https://pyvisa.readthedocs.io"
EGIT_REPO_URI="https://github.com/hgrecco/${PN}.git git://github.com/${PN}/${PN}.git"
LICENSE="MIT"
SLOT="0"
IUSE="test"
-RDEPEND="
- $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7)
- "
-DEPEND="${RDEPEND}"
-
python_test() {
esetup.py test
-} \ No newline at end of file
+}
diff --git a/dev-python/PyVISA/metadata.xml b/dev-python/PyVISA/metadata.xml
index 1a5f4a861..332d2e0dc 100644
--- a/dev-python/PyVISA/metadata.xml
+++ b/dev-python/PyVISA/metadata.xml
@@ -15,7 +15,7 @@ Architecture" (VISA), in order to control measurement devices and
test equipment via GPIB, RS232, Ethernet or USB.
</longdescription>
<upstream>
- <remote-id type="github">hgrecco/pyvisa-py</remote-id>
+ <remote-id type="github">pyvisa/pyvisa</remote-id>
<remote-id type="pypi">PyVISA</remote-id>
</upstream>
</pkgmetadata>