aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-chemistry/openbabel-python/metadata.xml18
-rw-r--r--sci-chemistry/openbabel-python/openbabel-python-9999.ebuild83
2 files changed, 0 insertions, 101 deletions
diff --git a/sci-chemistry/openbabel-python/metadata.xml b/sci-chemistry/openbabel-python/metadata.xml
deleted file mode 100644
index 1acf891c7..000000000
--- a/sci-chemistry/openbabel-python/metadata.xml
+++ /dev/null
@@ -1,18 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci-chemistry@gentoo.org</email>
- <name>Gentoo Chemistry Project</name>
- </maintainer>
- <longdescription>
-Open Babel is a chemical toolbox designed to speak the many languages of
-chemical data. It's an open, collaborative project allowing anyone to
-search, convert, analyze, or store data from molecular modeling, chemistry,
-solid-state materials, biochemistry, or related areas. This package enables
-to access Open Babel library from Python programs.
-</longdescription>
- <upstream>
- <remote-id type="sourceforge">openbabel</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/sci-chemistry/openbabel-python/openbabel-python-9999.ebuild b/sci-chemistry/openbabel-python/openbabel-python-9999.ebuild
deleted file mode 100644
index 7d4ab0f8e..000000000
--- a/sci-chemistry/openbabel-python/openbabel-python-9999.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4} )
-
-inherit cmake-utils eutils git-r3 multilib python-r1
-
-DESCRIPTION="Python bindings for OpenBabel (including Pybel)"
-HOMEPAGE="http://openbabel.sourceforge.net/"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/openbabel/openbabel.git"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS=""
-IUSE=""
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- ~sci-chemistry/openbabel-${PV}
- sys-libs/zlib"
-DEPEND="${RDEPEND}
- >=dev-lang/swig-2"
-
-src_prepare() {
- cmake-utils_src_prepare
- sed \
- -e "s:\"\.\.\":\"${EPREFIX}/usr\":g" \
- -i test/testbabel.py || die
- swig -python -c++ -small -O -templatereduce -naturalvar \
- -I"${EPREFIX}/usr/include/openbabel-2.0" \
- -o scripts/python/openbabel-python.cpp \
- -DHAVE_EIGEN \
- -outdir scripts/python \
- scripts/openbabel-python.i \
- || die "Regeneration of openbabel-python.cpp failed"
-}
-
-src_configure() {
- my_impl_src_configure() {
- local mycmakeargs=(
- -DCMAKE_INSTALL_RPATH=
- -DOPTIMIZE_NATIVE=OFF
- -DBINDINGS_ONLY=ON
- -DBABEL_SYSTEM_LIBRARY="${EPREFIX}/usr/$(get_libdir)/libopenbabel.so"
- -DOB_MODULE_PATH="${EPREFIX}/usr/$(get_libdir)/openbabel/${PV}"
- -DPYTHON_BINDINGS=ON
- -DPYTHON_EXECUTABLE=${PYTHON}
- -DCMAKE_INSTALL_PREFIX="${D}/usr"
- -DPYTHON_INCLUDE_DIR="$(python_get_includedir)"
- -DPYTHON_INCLUDE_PATH="$(python_get_includedir)"
- -DPYTHON_LIBRARY="$(python_get_library_path)"
- -DENABLE_TESTS=ON
- )
-
- cmake-utils_src_configure
- }
-
- python_foreach_impl my_impl_src_configure
-}
-
-src_compile() {
- python_foreach_impl cmake-utils_src_make bindings_python
-}
-
-src_test() {
- python_foreach_impl cmake-utils_src_test -R py
-}
-
-src_install() {
- my_impl_src_install() {
- cd "${BUILD_DIR}" || die
-
- cmake -DCOMPONENT=bindings_python -P cmake_install.cmake
-
- python_optimize
- }
-
- python_foreach_impl my_impl_src_install
-}