aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/gdl/ChangeLog (renamed from sci-misc/gdl/ChangeLog)0
-rw-r--r--dev-lang/gdl/Manifest (renamed from sci-misc/gdl/Manifest)4
-rw-r--r--dev-lang/gdl/files/digest-gdl-0.8.11 (renamed from sci-misc/gdl/files/digest-gdl-0.8.11)0
-rw-r--r--dev-lang/gdl/gdl-0.8.11.ebuild (renamed from sci-misc/gdl/gdl-0.8.11.ebuild)35
-rw-r--r--dev-lang/gdl/metadata.xml (renamed from sci-misc/gdl/metadata.xml)0
-rw-r--r--sci-astronomy/swarp/swarp-2.15.6.ebuild1
6 files changed, 16 insertions, 24 deletions
diff --git a/sci-misc/gdl/ChangeLog b/dev-lang/gdl/ChangeLog
index ff61e921a..ff61e921a 100644
--- a/sci-misc/gdl/ChangeLog
+++ b/dev-lang/gdl/ChangeLog
diff --git a/sci-misc/gdl/Manifest b/dev-lang/gdl/Manifest
index 5985cb98d..f930911bb 100644
--- a/sci-misc/gdl/Manifest
+++ b/dev-lang/gdl/Manifest
@@ -1,4 +1,4 @@
-MD5 5e9e6bb9791bd88d0adcefe06e335775 gdl-0.8.11.ebuild 1380
-MD5 a70451096ce00229b8a05e3645d33a11 ChangeLog 298
+MD5 6bd73f70d67b9b0f65c6079809e80029 gdl-0.8.11.ebuild 1290
MD5 dae478fe78d9bee8384be4fbb5111882 metadata.xml 380
+MD5 a70451096ce00229b8a05e3645d33a11 ChangeLog 298
MD5 9e1aea27a6a4b772ac1ba3079109cdc8 files/digest-gdl-0.8.11 62
diff --git a/sci-misc/gdl/files/digest-gdl-0.8.11 b/dev-lang/gdl/files/digest-gdl-0.8.11
index 2a5543b89..2a5543b89 100644
--- a/sci-misc/gdl/files/digest-gdl-0.8.11
+++ b/dev-lang/gdl/files/digest-gdl-0.8.11
diff --git a/sci-misc/gdl/gdl-0.8.11.ebuild b/dev-lang/gdl/gdl-0.8.11.ebuild
index 3ac9cd5b3..873a51c24 100644
--- a/sci-misc/gdl/gdl-0.8.11.ebuild
+++ b/dev-lang/gdl/gdl-0.8.11.ebuild
@@ -2,34 +2,29 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-#inherit eutils libtool
-
-DESCRIPTION="A free IDL (Interactive Data Language) compatible incremental compiler"
+DESCRIPTION="An Interactive Data Language compatible incremental compiler"
HOMEPAGE="http://gnudatalanguage.sourceforge.net/"
SRC_URI="mirror://sourceforge/gnudatalanguage/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL"
SLOT="0"
KEYWORDS="~x86 ~amd64"
-IUSE="python fftw hdf hdf5 imagemagick netcdf fftw"
+IUSE="python fftw hdf hdf5 imagemagick netcdf"
DEPEND=">=sys-libs/readline-4.3
sci-libs/gsl
>=sci-libs/plplot-5.3
imagemagick? ( media-gfx/imagemagick )
- hdf? ( sci-libs/hdf )
+ hdf? ( sci-libs/hdf )
hdf5? ( sci-libs/hdf5 )
netcdf? ( sci-libs/netcdf )
- python? ( >=dev-lang/python-2.3 )
- python? ( >=dev-python/numarray-0.9 )
- python? ( >=dev-python/matplotlib-0.52 )
- fftw? ( sci-libs/fftw )
-"
+ python? ( >=dev-lang/python
+ >=dev-python/numarray
+ >=dev-python/matplotlib )
+ fftw? ( sci-libs/fftw )"
src_compile() {
- local myconf="--without-Magick"
- use imagemagick && myconf=" --with-Magick "
econf \
- ${myconf} \
+ $(use_with imagemagick Magick ) \
$(use_with hdf ) \
$(use_with hdf5 ) \
$(use_with netcdf ) \
@@ -41,14 +36,12 @@ src_compile() {
src_install() {
make DESTDIR=${D} install || die "make install failed"
- dodir /usr/share/${PN}
insinto /usr/share/${PN}
doins -r src/pro
- dodoc README PYTHON.txt AUTHORS ChangeLog NEWS TODO
- echo IDL_PATH=":/usr/share/gdl/pro:" > 99gdl
+ doins -r src/py
+ dodoc README PYTHON.txt AUTHORS ChangeLog NEWS TODO
+ # add GDL provided routines to IDL_PATH
+ #echo "IDL_PATH=:/usr/share/${PN}/pro:" > 99gdl
+ echo "IDL_STARTUP=/usr/share/${PN}/pro" > 99gdl
doenvd 99gdl
}
-
-
-#TODO
-# - test the python modules src/py, install them.
diff --git a/sci-misc/gdl/metadata.xml b/dev-lang/gdl/metadata.xml
index 331a061e1..331a061e1 100644
--- a/sci-misc/gdl/metadata.xml
+++ b/dev-lang/gdl/metadata.xml
diff --git a/sci-astronomy/swarp/swarp-2.15.6.ebuild b/sci-astronomy/swarp/swarp-2.15.6.ebuild
index 359b2803e..852341501 100644
--- a/sci-astronomy/swarp/swarp-2.15.6.ebuild
+++ b/sci-astronomy/swarp/swarp-2.15.6.ebuild
@@ -41,4 +41,3 @@ src_install () {
doins doc/*
fi
}
-