aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/blas-docs/blas-docs-3.2.0.ebuild')
-rw-r--r--app-doc/blas-docs/blas-docs-3.2.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-doc/blas-docs/blas-docs-3.2.0.ebuild b/app-doc/blas-docs/blas-docs-3.2.0.ebuild
new file mode 100644
index 000000000..2a3c727f4
--- /dev/null
+++ b/app-doc/blas-docs/blas-docs-3.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/blas-docs/blas-docs-3.1.1.ebuild,v 1.11 2009/12/17 10:04:04 fauli Exp $
+
+DESCRIPTION="Documentation reference and man pages for blas implementations"
+HOMEPAGE="http://www.netlib.org/blas"
+SRC_URI="mirror://gentoo/lapack-man-${PV}.tar.gz
+ http://www.netlib.org/blas/blasqr.pdf
+ http://www.netlib.org/blas/blast-forum/blas-report.pdf"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+S=${WORKDIR}/lapack-${PV}/manpages
+
+src_install() {
+ # rename because doman do not yet understand manl files
+ # Not all systems have the rename command, like say FreeBSD
+ local f= t=
+ for f in blas/man/manl/*.l; do
+ t="${f%%.l}.n"
+ mv "${f}" "${t}"
+ done
+ doman blas/man/manl/*.n || die "doman failed"
+ dodoc README "${DISTDIR}"/blas{-report,qr}.pdf || die "dodoc failed"
+}