aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/scalapack-docs/scalapack-docs-1.8.ebuild')
-rw-r--r--app-doc/scalapack-docs/scalapack-docs-1.8.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-doc/scalapack-docs/scalapack-docs-1.8.ebuild b/app-doc/scalapack-docs/scalapack-docs-1.8.ebuild
new file mode 100644
index 000000000..833cdca75
--- /dev/null
+++ b/app-doc/scalapack-docs/scalapack-docs-1.8.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="Documentation reference and man pages for ScaLAPACK implementations"
+HOMEPAGE="http://www.netlib.org/scalapack/scalapack_home.html"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"
+
+src_install() {
+ # rename because doman do not yet understand manl files
+ # Not all systems have the rename command, like say FreeBSD
+ local f= t=
+ for f in MANPAGES/man/manl/*.l; do
+ t="${f%%.l}.n"
+ mv "${f}" "${t}"
+ done
+ doman MANPAGES/man/manl/* || die "doman failed"
+ dodoc *.ps || die "dodoc failed"
+}