aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/growler-arch/growler-arch-0.3.7.1.ebuild')
-rw-r--r--dev-cpp/growler-arch/growler-arch-0.3.7.1.ebuild32
1 files changed, 14 insertions, 18 deletions
diff --git a/dev-cpp/growler-arch/growler-arch-0.3.7.1.ebuild b/dev-cpp/growler-arch/growler-arch-0.3.7.1.ebuild
index abd62f28a..2cedc63ff 100644
--- a/dev-cpp/growler-arch/growler-arch-0.3.7.1.ebuild
+++ b/dev-cpp/growler-arch/growler-arch-0.3.7.1.ebuild
@@ -2,34 +2,30 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-SLOT="0"
-LICENSE="NOSA"
+EAPI=5
-KEYWORDS="~amd64 ~x86"
-
-DESCRIPTION="Growler-Arch are growler libraries and utilities."
+DESCRIPTION="Growler libraries and utilities"
HOMEPAGE="http://www.nas.nasa.gov/~bgreen/growler/"
SRC_URI="${HOMEPAGE}/downloads/growler-arch-${PV}.tar.gz"
+SLOT="0"
+LICENSE="NOSA"
+KEYWORDS="~amd64 ~x86"
IUSE="doc static"
-RDEPEND=">=dev-cpp/growler-link-0.3.7
- >=dev-cpp/growler-thread-0.3.4
- >=dev-cpp/growler-core-0.3.7"
+RDEPEND="
+ >=dev-cpp/growler-link-0.3.7
+ >=dev-cpp/growler-thread-0.3.4
+ >=dev-cpp/growler-core-0.3.7"
DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen dev-libs/libxslt )"
+ doc? ( app-doc/doxygen dev-libs/libxslt )"
+
+DOCS=( README NEWS AUTHORS NOSA ChangeLog )
-src_compile() {
+src_configure() {
econf \
$(use_enable doc) \
$(use_enable static) \
- --enable-fast-install \
- || die "could not configure"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
- dodoc README NEWS AUTHORS NOSA ChangeLog
+ --enable-fast-install
}