aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/growler-thread/growler-thread-0.3.4.ebuild')
-rw-r--r--dev-cpp/growler-thread/growler-thread-0.3.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-cpp/growler-thread/growler-thread-0.3.4.ebuild b/dev-cpp/growler-thread/growler-thread-0.3.4.ebuild
new file mode 100644
index 000000000..2d4793be7
--- /dev/null
+++ b/dev-cpp/growler-thread/growler-thread-0.3.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /CVS/groups/vistech/bgreen-overlay/dev-cpp/growler-thread/growler-thread-0.3.1.ebuild,v 1.1.1.1 2007/10/12 20:18:26 bgreen Exp $
+
+SLOT="0"
+LICENSE="NOSA"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Growler-Thread is a pthread wrapper library. It provides support for creating threads, and for common multithreading tasks."
+HOMEPAGE="http://www.nas.nasa.gov/~bgreen/growler/"
+SRC_URI="${HOMEPAGE}/downloads/growler-thread-${PV}.tar.gz"
+
+IUSE="doc static"
+
+RDEPEND=">=dev-cpp/growler-link-0.3.7"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+ econf \
+ $(use_enable doc) \
+ $(use_enable static) \
+ --enable-fast-install \
+ || die "could not configure"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc README NEWS AUTHORS NOSA ChangeLog
+}
+