aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/icnc/ChangeLog3
-rw-r--r--dev-cpp/icnc/icnc-9999.ebuild16
2 files changed, 10 insertions, 9 deletions
diff --git a/dev-cpp/icnc/ChangeLog b/dev-cpp/icnc/ChangeLog
index aaca313f3..d402c65e3 100644
--- a/dev-cpp/icnc/ChangeLog
+++ b/dev-cpp/icnc/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 25 Sep 2014; Christoph Junghans <ottxor@gentoo.org> icnc-9999.ebuild:
+ live ebuild update
+
*icnc-9999 (25 Sep 2014)
25 Sep 2014; Christoph Junghans <ottxor@gentoo.org> +icnc-9999.ebuild,
diff --git a/dev-cpp/icnc/icnc-9999.ebuild b/dev-cpp/icnc/icnc-9999.ebuild
index 8ab3b22d6..aeee540a9 100644
--- a/dev-cpp/icnc/icnc-9999.ebuild
+++ b/dev-cpp/icnc/icnc-9999.ebuild
@@ -12,13 +12,15 @@ HOMEPAGE="https://software.intel.com/en-us/articles/intel-concurrent-collections
if [[ $PV = 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/icnc/icnc.git"
+ KEYWORDS=
else
- SRC_URI="mirror://sourceforge/${PN}/${PV}/l_cnc_b_${PV}.tgz"
+ #SRC_URI="mirror://sourceforge/${PN}/${PV}/l_cnc_b_${PV}.tgz"
+ SRC_URI="https://github.com/martine/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
fi
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64"
IUSE=""
DEPEND="
@@ -29,13 +31,9 @@ RDEPEND="${DEPEND}"
src_configure() {
#TODO has mpi support but broken with virtual/mpi
-# local mycmakeargs=(
# $(cmake-utils_use mpi BUILD_LIBS_FOR_MPI)
-# )
+ local mycmakeargs=(
+ -DLIB=$(get_libdir)
+ )
cmake-utils_src_configure
}
-
-src_install() {
- cmake-utils_src_install
- mv "${ED}"/usr/{lib,$(get_libdir)} || die
-}