aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jlatexmath/Manifest3
-rw-r--r--dev-java/jlatexmath/jlatexmath-1.0.0.ebuild32
-rw-r--r--dev-java/jlatexmath/jlatexmath-1.0.2.ebuild (renamed from dev-java/jlatexmath/jlatexmath-0.9.7.ebuild)22
3 files changed, 12 insertions, 45 deletions
diff --git a/dev-java/jlatexmath/Manifest b/dev-java/jlatexmath/Manifest
index 22218fa56..6e3878792 100644
--- a/dev-java/jlatexmath/Manifest
+++ b/dev-java/jlatexmath/Manifest
@@ -1,2 +1 @@
-DIST jlatexmath-src-0.9.7.zip 1060786 SHA256 d348ab583359e81390627c8fa2d8d08c1d4ff33fb009c47d8314ea0cfebfe1ea SHA512 dc9a244fd8733a3b3c5dcd1f88a3c8e36ee8a46114d03b02508c3fb728878b03a8040c9dcf468a4ce297c792954b99f25db83e4dc7d4ede101ab09cb2af37eab WHIRLPOOL 8370e07d8013f1ab626c081615f0dcce7766fcfe7219403c88152d366ca6e9bb3c4ebc1afb17cc90ce77f1abd773051e9d8fc3a33232adc3b25310f14ded81e8
-DIST jlatexmath-src-1.0.0.zip 1061432 SHA256 bc8630c8506c333d4bb1e55c0724f0811d18d55664dc4dc1952211fd5560feea SHA512 022f8f05b7dc0906091cb2473aecaad70880a4cf8b18f61929b2714f0dafee1064c26186e576fb94eb3db01d8bfa7bcaa0a4dd185fcedb0913da5ee976615c5d WHIRLPOOL 3242d45c41e575996ff6c4208ebfd5f41eb58df21416384adad4e2b817c06a886d5fec182e41b41282616a4bcc4a698582a20c52409680beed7fa8b1c2f059c7
+DIST jlatexmath-src-1.0.2.zip 1074659 SHA256 470345426179197134aa7e61ee0251a1a87c06393482474c53893de2aa595cf4 SHA512 c91af6dd37c5b62058fda35c41b1d34bb8a0f4eea9b5e9a5b76054b8f72c09f049a08de9aa761208fe18a66ee77ff0812d267f7137d015a63e200cac28a32c48 WHIRLPOOL fc3c2b91d96fd707874481d871d020ebf1f65c4cdb1dea368067e3d94e6a49a94e7c1a2a26b1f94bdaea7b8c372e5564357df98310e643c202ea21dd48bcad00
diff --git a/dev-java/jlatexmath/jlatexmath-1.0.0.ebuild b/dev-java/jlatexmath/jlatexmath-1.0.0.ebuild
deleted file mode 100644
index 80245c71b..000000000
--- a/dev-java/jlatexmath/jlatexmath-1.0.0.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="A Java API to render LaTeX"
-SRC_URI="http://forge.scilab.org/index.php/p/${PN}/downloads/get/${PN}-src-${PV}.zip"
-HOMEPAGE="http://forge.scilab.org/index.php/p/jlatexmath"
-
-IUSE="doc examples source"
-DEPEND=">=virtual/jdk-1.5
- app-arch/unzip"
-RDEPEND=">=virtual/jre-1.5"
-
-LICENSE="GPL-2"
-SLOT="1"
-KEYWORDS="~amd64 ~x86"
-
-EANT_BUILD_TARGET="buildJar"
-EANT_DOC_TARGET="doc"
-
-src_install() {
- java-pkg_newjar dist/${P}.jar ${PN}.jar
- use doc && java-pkg_dojavadoc doc
- use source && java-pkg_dosrc src/org
- use examples && java-pkg_doexamples examples
-}
diff --git a/dev-java/jlatexmath/jlatexmath-0.9.7.ebuild b/dev-java/jlatexmath/jlatexmath-1.0.2.ebuild
index ff19bded1..b6b597952 100644
--- a/dev-java/jlatexmath/jlatexmath-0.9.7.ebuild
+++ b/dev-java/jlatexmath/jlatexmath-1.0.2.ebuild
@@ -1,31 +1,31 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=4
+EAPI=5
-JAVA_PKG_IUSE="doc source"
+JAVA_PKG_IUSE="doc examples source"
inherit java-pkg-2 java-ant-2
DESCRIPTION="A Java API to render LaTeX"
-SRC_URI="http://forge.scilab.org/upload/jlatexmath/files/${PN}-src-${PV}.zip"
HOMEPAGE="http://forge.scilab.org/index.php/p/jlatexmath"
-
-IUSE="doc examples source"
-DEPEND=">=virtual/jdk-1.5
- app-arch/unzip"
-RDEPEND=">=virtual/jre-1.5"
+SRC_URI="http://forge.scilab.org/upload/jlatexmath/files/${PN}-src-${PV}.zip"
LICENSE="GPL-2"
-SLOT="0"
+SLOT="1"
KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.5"
EANT_BUILD_TARGET="buildJar"
EANT_DOC_TARGET="doc"
src_install() {
- java-pkg_newjar dist/${P}.jar ${PN}.jar
+ java-pkg_newjar dist/"${P}.jar" "${PN}.jar"
use doc && java-pkg_dojavadoc doc
use source && java-pkg_dosrc src/org
use examples && java-pkg_doexamples examples