aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jlatexmath/ChangeLog6
-rw-r--r--dev-java/jlatexmath/Manifest1
-rw-r--r--dev-java/jlatexmath/jlatexmath-1.0.0.ebuild32
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-java/jlatexmath/ChangeLog b/dev-java/jlatexmath/ChangeLog
index 27e0eac94..f3a9f0a88 100644
--- a/dev-java/jlatexmath/ChangeLog
+++ b/dev-java/jlatexmath/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*jlatexmath-1.0.0 (25 Sep 2012)
+
+ 25 Sep 2012; Guillaume Horel <guillaume.horel@gmail.com>
+ +jlatexmath-1.0.0.ebuild:
+ version bump
+
07 Jul 2012; Sébastien Fabbro <bicatali@gentoo.org> -jlatexmath-0.8.7.ebuild,
-jlatexmath-0.9.4.ebuild, jlatexmath-0.9.7.ebuild:
dev-java/jlatexmath: do not compile examples, bug #421743
diff --git a/dev-java/jlatexmath/Manifest b/dev-java/jlatexmath/Manifest
index f0ffa3db3..22218fa56 100644
--- a/dev-java/jlatexmath/Manifest
+++ b/dev-java/jlatexmath/Manifest
@@ -1 +1,2 @@
DIST jlatexmath-src-0.9.7.zip 1060786 SHA256 d348ab583359e81390627c8fa2d8d08c1d4ff33fb009c47d8314ea0cfebfe1ea SHA512 dc9a244fd8733a3b3c5dcd1f88a3c8e36ee8a46114d03b02508c3fb728878b03a8040c9dcf468a4ce297c792954b99f25db83e4dc7d4ede101ab09cb2af37eab WHIRLPOOL 8370e07d8013f1ab626c081615f0dcce7766fcfe7219403c88152d366ca6e9bb3c4ebc1afb17cc90ce77f1abd773051e9d8fc3a33232adc3b25310f14ded81e8
+DIST jlatexmath-src-1.0.0.zip 1061432 SHA256 bc8630c8506c333d4bb1e55c0724f0811d18d55664dc4dc1952211fd5560feea SHA512 022f8f05b7dc0906091cb2473aecaad70880a4cf8b18f61929b2714f0dafee1064c26186e576fb94eb3db01d8bfa7bcaa0a4dd185fcedb0913da5ee976615c5d WHIRLPOOL 3242d45c41e575996ff6c4208ebfd5f41eb58df21416384adad4e2b817c06a886d5fec182e41b41282616a4bcc4a698582a20c52409680beed7fa8b1c2f059c7
diff --git a/dev-java/jlatexmath/jlatexmath-1.0.0.ebuild b/dev-java/jlatexmath/jlatexmath-1.0.0.ebuild
new file mode 100644
index 000000000..80245c71b
--- /dev/null
+++ b/dev-java/jlatexmath/jlatexmath-1.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A Java API to render LaTeX"
+SRC_URI="http://forge.scilab.org/index.php/p/${PN}/downloads/get/${PN}-src-${PV}.zip"
+HOMEPAGE="http://forge.scilab.org/index.php/p/jlatexmath"
+
+IUSE="doc examples source"
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.5"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+
+EANT_BUILD_TARGET="buildJar"
+EANT_DOC_TARGET="doc"
+
+src_install() {
+ java-pkg_newjar dist/${P}.jar ${PN}.jar
+ use doc && java-pkg_dojavadoc doc
+ use source && java-pkg_dosrc src/org
+ use examples && java-pkg_doexamples examples
+}