aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/cfortran/Manifest2
-rw-r--r--dev-lang/cfortran/cfortran-4.4.ebuild28
2 files changed, 17 insertions, 13 deletions
diff --git a/dev-lang/cfortran/Manifest b/dev-lang/cfortran/Manifest
index bd901c915..add4e5737 100644
--- a/dev-lang/cfortran/Manifest
+++ b/dev-lang/cfortran/Manifest
@@ -1,4 +1,4 @@
MD5 42c63ed48cbdea7757b613104c5daeac ChangeLog 235
-MD5 a720769264232492cd194857d09ac0cf cfortran-4.4.ebuild 1032
+MD5 0985fb4af9f9e4363befa5f7a1cac7a6 cfortran-4.4.ebuild 1100
MD5 1c5f5fb0db8525423a59fab929610dc5 files/digest-cfortran-4.4 135
MD5 4db90a73115deea522f922b48cd036f4 metadata.xml 243
diff --git a/dev-lang/cfortran/cfortran-4.4.ebuild b/dev-lang/cfortran/cfortran-4.4.ebuild
index 45b98ed49..dbfc2cf67 100644
--- a/dev-lang/cfortran/cfortran-4.4.ebuild
+++ b/dev-lang/cfortran/cfortran-4.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -8,30 +8,34 @@ DESCRIPTION="Header file allowing to call Fortran routines from C and C++"
SRC_URI="http://ftp.debian.org/debian/pool/main/c/${PN}/${PN}_${PV}.orig.tar.gz
http://ftp.debian.org/debian/pool/main/c/${PN}/${PN}_${PV}-${DEB_PVER}.diff.gz"
HOMEPAGE="http://www-zeus.desy.de/~burow/cfortran/"
-KEYWORDS="~x86 ~amd64"
+KEYWORDS="~amd64 ~x86"
LICENSE="LGPL"
-IUSE=""
+IUSE="examples"
SLOT="0"
src_unpack() {
unpack ${A}
cd ${S}
epatch ${WORKDIR}/${PN}_${PV}-${DEB_PVER}.diff
- tar -xzf cfortran.examples.tar.gz
- # rename eg to examples and correct bad links
- mv eg examples
- ln -sfn sz1.c examples/sz1/sz1.C
- ln -sfn pz.c examples/pz/pz.C
+ if use examples; then
+ tar -xzf cfortran.examples.tar.gz
+ mv eg examples
+ ln -sfn sz1.c examples/sz1/sz1.C
+ ln -sfn pz.c examples/pz/pz.C
+ fi
}
src_compile() {
- einfo "No compilation neccessary"
+ einfo "No compilation neccessary"
}
src_install() {
insinto /usr/include/cfortran
doins cfortran.h
- dosym /usr/include/cfortran/cfortran.h /usr/include/cfortran.h
- dodoc -r cfortest.c cfortran.doc cfortran.html \
- index.htm cfortex.f debian examples
+ dosym /usr/include/cfortran/cfortran.h /usr/include/cfortran.h
+ dodoc cfortran.doc debian/{NEWS,changelog,copyright}
+ insinto /usr/share/doc/${PF}
+ doins cfortran.html index.htm cfortest.c cfortex.f
+ use examples && doins -r examples
+
}