aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/boost-compute/files')
-rw-r--r--dev-libs/boost-compute/files/boost-compute-0.4-CMakeLists.patch14
-rw-r--r--dev-libs/boost-compute/files/boost-compute-1.74.0-libdir.patch13
2 files changed, 13 insertions, 14 deletions
diff --git a/dev-libs/boost-compute/files/boost-compute-0.4-CMakeLists.patch b/dev-libs/boost-compute/files/boost-compute-0.4-CMakeLists.patch
deleted file mode 100644
index 86d3a9e29..000000000
--- a/dev-libs/boost-compute/files/boost-compute-0.4-CMakeLists.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Install the BoostComputeConfig to /usr/lib/cmake instead of /usr/share/cmake.
-
-Patch by Marius Brehler.
---- CMakeLists.txt
-+++ CMakeLists.txt
-@@ -81,7 +81,7 @@ configure_file(
- # install cmake config file
- install(
- FILES ${BoostCompute_BINARY_DIR}/BoostComputeConfig.cmake
-- DESTINATION share/cmake/BoostCompute
-+ DESTINATION lib/cmake/BoostCompute
- )
-
- # install header files
diff --git a/dev-libs/boost-compute/files/boost-compute-1.74.0-libdir.patch b/dev-libs/boost-compute/files/boost-compute-1.74.0-libdir.patch
new file mode 100644
index 000000000..9b35a5284
--- /dev/null
+++ b/dev-libs/boost-compute/files/boost-compute-1.74.0-libdir.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index d0327ca..e52a62a 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -122,7 +122,7 @@ configure_file(
+ # install cmake config file
+ install(
+ FILES ${BoostCompute_BINARY_DIR}/BoostComputeConfig.cmake
+- DESTINATION lib/cmake/BoostCompute
++ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/BoostCompute
+ )
+
+ # install header files