aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libxml2/files/libxml2-2.9.1-disable_static_modules.patch')
-rw-r--r--dev-libs/libxml2/files/libxml2-2.9.1-disable_static_modules.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-libs/libxml2/files/libxml2-2.9.1-disable_static_modules.patch b/dev-libs/libxml2/files/libxml2-2.9.1-disable_static_modules.patch
new file mode 100644
index 000000000..a13febcbb
--- /dev/null
+++ b/dev-libs/libxml2/files/libxml2-2.9.1-disable_static_modules.patch
@@ -0,0 +1,21 @@
+diff --git a/python/Makefile.am b/python/Makefile.am
+index 4a8b5d5..b976893 100644
+--- a/python/Makefile.am
++++ b/python/Makefile.am
+@@ -19,13 +19,14 @@ if WITH_PYTHON
+ AM_CPPFLAGS = \
+ -I$(top_builddir)/include \
+ -I$(top_srcdir)/include \
+- -I$(PYTHON_INCLUDES)
++ -I$(PYTHON_INCLUDES) \
++ -shared
+
+ python_LTLIBRARIES = libxml2mod.la
+
+ libxml2mod_la_SOURCES = libxml.c libxml_wrap.h libxml2-py.h libxml2-py.c types.c
+ libxml2mod_la_LDFLAGS = $(CYGWIN_EXTRA_LDFLAGS) $(WIN32_EXTRA_LDFLAGS) -module -avoid-version \
+- $(top_builddir)/libxml2.la $(CYGWIN_EXTRA_PYTHON_LIBADD) $(WIN32_EXTRA_PYTHON_LIBADD) $(PYTHON_LIBS)
++ $(top_builddir)/libxml2.la $(CYGWIN_EXTRA_PYTHON_LIBADD) $(WIN32_EXTRA_PYTHON_LIBADD) $(PYTHON_LIBS) -shared
+
+ BUILT_SOURCES = libxml2-export.c libxml2-py.h libxml2-py.c
+