aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/intel-common/Manifest1
-rw-r--r--dev-libs/intel-common/intel-common-15.0.3.187-r1.ebuild59
2 files changed, 0 insertions, 60 deletions
diff --git a/dev-libs/intel-common/Manifest b/dev-libs/intel-common/Manifest
index 363ebfd51..bc7e67674 100644
--- a/dev-libs/intel-common/Manifest
+++ b/dev-libs/intel-common/Manifest
@@ -1,2 +1 @@
-DIST parallel_studio_xe_2015_update3.tgz 4156836825 SHA256 ab7169989c87bbb0fe66221cb7eb3a26b17c8b9ceff38f1926e5607834306896 SHA512 eccc2bfe85ccd039a2ec9e334d370e49d43baa0522d095c087a5982aa08bddb4c97bfc3125bd09f5cd57d3ed252c598012e1f2670b8373a1b3bb455825d18f96 WHIRLPOOL d1fd8d1e46ce35150357a9452f04529d8a1f7e915e50a5d714895184aa37fb61186a5455e89b4750f444f0f6da94563e493d0821c661378551c3739f8d27d7b9
DIST parallel_studio_xe_2016_update1.tgz 4126310292 SHA256 f5a3ab9fb581e19bf1bd966f7d40a11905e002a2bfae1c4a2140544288ca3e48 SHA512 5d6b2a853c6fd142d90d155e6e5997d13d1521c393a78dd1649404e90f2d1f3764a1c5efa0eeb0eedeae7e32bd059852b5b887aa3fafc71880ef3ad1d6774be9 WHIRLPOOL 8a2b84744057785968a1160d60ba9a79beeff323bafb0297bcd8fb36d05f22e9de0214dcc26058e638eb9fd136bf4e0cb04345b49e87a558e7167e651af68c16
diff --git a/dev-libs/intel-common/intel-common-15.0.3.187-r1.ebuild b/dev-libs/intel-common/intel-common-15.0.3.187-r1.ebuild
deleted file mode 100644
index d59e80155..000000000
--- a/dev-libs/intel-common/intel-common-15.0.3.187-r1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-INTEL_DPN=parallel_studio_xe
-INTEL_DID=7538
-INTEL_DPV=2015_update3
-INTEL_SUBDIR=composerxe
-INTEL_SINGLE_ARCH=false
-
-inherit intel-sdp
-
-DESCRIPTION="Common libraries and utilities needed for Intel compilers and libraries"
-HOMEPAGE="http://software.intel.com/en-us/articles/intel-compilers/"
-
-IUSE="+compiler"
-KEYWORDS="-* ~amd64 ~x86 ~amd64-linux ~x86-linux"
-
-CHECKREQS_DISK_BUILD=375M
-
-pkg_setup() {
- einfo ${INTEL_SDP_EDIR}
- INTEL_BIN_RPMS=( openmp openmp-devel )
- INTEL_DAT_RPMS=( compilerpro-common compilerpro-common-pset )
- if use compiler; then
- INTEL_BIN_RPMS+=( compilerpro-devel sourcechecker-devel )
- INTEL_DAT_RPMS+=( compilerpro-vars sourcechecker-common ccompxe compxe fcompxe )
- fi
- intel-sdp_pkg_setup
-}
-
-src_install() {
- intel-sdp_src_install
- local path rootpath ldpath arch fenv=35intelsdp
- cat > ${fenv} <<-EOF
- NLSPATH=${INTEL_SDP_EDIR}/lib/locale/en_US/%N
- INTEL_LICENSE_FILE="${INTEL_SDP_EDIR}"/licenses:"${EPREFIX}/opt/intel/license"
- EOF
- for arch in ${INTEL_ARCH}; do
- path=${path}:${INTEL_SDP_EDIR}/bin/${arch}:${INTEL_SDP_EDIR}/mpirt/bin/${arch}
- rootpath=${rootpath}:${INTEL_SDP_EDIR}/bin/${arch}:${INTEL_SDP_EDIR}/mpirt/bin/${arch}
- ldpath=${ldpath}:${INTEL_SDP_EDIR}/compiler/lib/${arch}:${INTEL_SDP_EDIR}/mpirt/lib/${arch}
- done
- cat >> ${fenv} <<-EOF
- PATH=${path#:}
- ROOTPATH=${rootpath#:}
- LDPATH=${ldpath#:}
- EOF
-
- doenvd ${fenv}
-
- cat >> "${T}"/40-${PN} <<- EOF
- SEARCH_DIRS_MASK="${INTEL_SDP_EDIR}"
- EOF
- insinto /etc/revdep-rebuild/
- doins "${T}"/40-${PN}
-}