aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/lacaml/lacaml-7.0.3.ebuild')
-rw-r--r--dev-ml/lacaml/lacaml-7.0.3.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/dev-ml/lacaml/lacaml-7.0.3.ebuild b/dev-ml/lacaml/lacaml-7.0.3.ebuild
index 1b6d6f541..ad9fbd152 100644
--- a/dev-ml/lacaml/lacaml-7.0.3.ebuild
+++ b/dev-ml/lacaml/lacaml-7.0.3.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=4
OASIS_BUILD_DOCS=1
-
-inherit oasis toolchain-funcs
+inherit oasis
DESCRIPTION="BLAS/LAPACK interface for OCaml"
HOMEPAGE="http://forge.ocamlcore.org/projects/lacaml"
@@ -17,8 +16,7 @@ SLOT="0"
KEYWORDS="~x86"
IUSE=""
-RDEPEND="
- virtual/blas
+RDEPEND="virtual/blas
virtual/lapack"
DEPEND="${DEPEND}
virtual/pkgconfig"
@@ -29,10 +27,10 @@ src_prepare() {
if use doc; then
cp "${FILESDIR}/API.odocl" . || die
fi
- cclib="$($(tc-getPKG_CONFIG) --libs blas lapack)"
+ cclib="$(pkg-config --libs blas lapack)"
cclib="[$(echo $cclib|sed -e 's/\(-[a-z0-9]*\) /\"\1\"\;/g' -e \
's/\(-[a-z0-9]*\)$/\"\1\"/')]"
sed -i "s/cclib = \[\]/cclib = ${cclib}/" setup.conf
#would like to do the below, but doesn't work from ebuild
- #oasis_configure_opts="--override conf_cclib $($(tc-getPKG_CONFIG) --libs blas lapack)"
+ #oasis_configure_opts="--override conf_cclib $(pkg-config --libs blas lapack)"
}