aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/zarith')
-rw-r--r--dev-ml/zarith/ChangeLog6
-rw-r--r--dev-ml/zarith/metadata.xml10
-rw-r--r--dev-ml/zarith/zarith-1.2.1.ebuild27
3 files changed, 25 insertions, 18 deletions
diff --git a/dev-ml/zarith/ChangeLog b/dev-ml/zarith/ChangeLog
index 74f1f9d0b..03336a56a 100644
--- a/dev-ml/zarith/ChangeLog
+++ b/dev-ml/zarith/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for dev-ml/zarith
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 18 Feb 2015; Justin Lecher <jlec@gentoo.org> metadata.xml,
+ zarith-1.2.1.ebuild:
+ dev-ml/zarith: fix SLOT operators; fix usage of die
+
16 Sep 2014; Christoph Junghans <ottxor@gentoo.org> zarith-1.2.1.ebuild:
clean up
diff --git a/dev-ml/zarith/metadata.xml b/dev-ml/zarith/metadata.xml
index 5cabf83c7..0677155e7 100644
--- a/dev-ml/zarith/metadata.xml
+++ b/dev-ml/zarith/metadata.xml
@@ -1,15 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-mathematics</herd>
-<longdescription>
+ <herd>sci-mathematics</herd>
+ <longdescription>
The Zarith library implements arithmetic and logical operations over
arbitrary-precision integers. It uses GMP to efficiently implement
arithmetic over big integers. Small integers are represented as Caml
unboxed integers, for speed and space economy.
</longdescription>
-<use>
- <flag name='mpir'>Use <pkg>sci-libs/mpir</pkg> for arbitrary
+ <use>
+ <flag name="mpir">Use <pkg>sci-libs/mpir</pkg> for arbitrary
precision integer arithmetic</flag>
-</use>
+ </use>
</pkgmetadata>
diff --git a/dev-ml/zarith/zarith-1.2.1.ebuild b/dev-ml/zarith/zarith-1.2.1.ebuild
index 150070425..6c5379bdb 100644
--- a/dev-ml/zarith/zarith-1.2.1.ebuild
+++ b/dev-ml/zarith/zarith-1.2.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -15,9 +15,10 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+ocamlopt doc mpir"
-DEPEND=">=dev-lang/ocaml-3.12.1[ocamlopt?]
- !mpir? ( dev-libs/gmp )
- mpir? ( sci-libs/mpir )"
+DEPEND="
+ >=dev-lang/ocaml-3.12.1[ocamlopt?]
+ !mpir? ( dev-libs/gmp:0 )
+ mpir? ( sci-libs/mpir:0 )"
RDEPEND="${DEPEND}"
pkg_setup() {
@@ -25,8 +26,9 @@ pkg_setup() {
}
src_prepare(){
- sed -e 's:(OCAMLFIND) install:(OCAMLFIND) install -ldconf $(INSTALLDIR)/ld.conf:g' \
- -i "${S}"/project.mak
+ sed \
+ -e 's:(OCAMLFIND) install:(OCAMLFIND) install -ldconf $(INSTALLDIR)/ld.conf:g' \
+ -i "${S}"/project.mak || die
}
src_configure(){
@@ -36,15 +38,16 @@ src_configure(){
}
src_compile(){
- emake
+ default
use doc && emake doc
}
src_install(){
findlib_src_preinst
- cp "${OCAMLDIR}"/ld.conf "${D}/${OCAMLDIR}"/ld.conf
- emake install
- rm -f "${D}/${OCAMLDIR}"/ld.conf
- dodoc Changes README
- use doc && dodoc -r html/
+ cp "${OCAMLDIR}"/ld.conf "${D}/${OCAMLDIR}"/ld.conf || die
+ default
+ rm -f "${D}/${OCAMLDIR}"/ld.conf || die
+ DOCS=( Changes README )
+ use doc && HTML_DOCS=( html/. )
+ einstalldocs
}