aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/zarith')
-rw-r--r--dev-ml/zarith/Manifest3
-rw-r--r--dev-ml/zarith/zarith-1.2.1.ebuild23
2 files changed, 14 insertions, 12 deletions
diff --git a/dev-ml/zarith/Manifest b/dev-ml/zarith/Manifest
index 8dbf2f331..d7156cb11 100644
--- a/dev-ml/zarith/Manifest
+++ b/dev-ml/zarith/Manifest
@@ -1,4 +1 @@
DIST zarith-1.2.1.tgz 68654 SHA256 916801cc39599d3fca07384fbfeec4bfaa5ffcb497d68ef89320af40ba5e4144 SHA512 5c053e259469bf6a2d4aaa3e653da42d18015e815a0b922a4e317db091a54c560e7ed32f5cb1faae7df1e8a6d81ba3913d71e5b500ace1bd45d69e69858467a1 WHIRLPOOL e31770c23e7f77bff8f084eeb3e0a9cab7c1413f2da64926c403720df2351bb84598953ad1bae0436d9b3ba6e66c1543aee0dbd9151a3708d793abe5506f1e00
-EBUILD zarith-1.2.1.ebuild 992 SHA256 247562941f50638da74a08fd033a38a2366f9f896ab4983c0d1c2a19e67fe589 SHA512 4a5bfa400ac5f0804c06b42e488cf8ec54c0674fc4224bc19c8e7d845bbd8c25458cc776790da91b1764df1be0094813603d71ea04c32a0016d442107d134aee WHIRLPOOL b5cbbaa432b53df50051a97fd4679be1d884ad19dbcddc331e827ae6e4cc6bc148deb54394a946dba8cf8550d8aad75d376c51551b412cc3e34e6ff2340b13e6
-MISC ChangeLog 336 SHA256 dd82e831bb0b21ef3c9917dc50b16b10b21e66561794ca0b59eb2ae07cda49aa SHA512 471d19d844981cff8dab5738d5366922de22a658a652956214304f7a47f431c39086ab488cc9c5b79ce22562170cdedd67b58a879ade9e8cfdce47a7d14037e0 WHIRLPOOL 15b849caba4bd8c03a9d1d6f1f8682956cac874c1cf918635c08e8919fa398bc76cf237c4b26b49cb4fa2225355d377c73142af24ee77ee97dda521b903a035e
-MISC metadata.xml 576 SHA256 f2e3b72798b53b5cc8de7f84bb15a4f936b202798dff0924a8dc3153fc02eba3 SHA512 fabad704c895e72ced7561f1e5db01869f3b5b7ecca6d96d3a1474e7febad1170a8ad9087346aa8caf8741a5cd719290567581297ef452cb1eb94f706cb14e6e WHIRLPOOL 15466f22d6b3f39bc2c294a642dccc215a34c84325443b385a9e4aeccef0e8a178b389ce76380769edd55992d6e665b8f440236a132141b85a8885d26d2de108
diff --git a/dev-ml/zarith/zarith-1.2.1.ebuild b/dev-ml/zarith/zarith-1.2.1.ebuild
index 2822592e2..90b518341 100644
--- a/dev-ml/zarith/zarith-1.2.1.ebuild
+++ b/dev-ml/zarith/zarith-1.2.1.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=4
+EAPI=5
+
+inherit eutils findlib multilib
DESCRIPTION="The Zarith library implements arithmetic and logical operations over arbitrary-precision integers"
HOMEPAGE="http://forge.ocamlcore.org/projects/zarith"
@@ -11,12 +13,11 @@ SRC_URI="http://forge.ocamlcore.org/frs/download.php/1199/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+ocamlopt"
-
-OCAMLDIR=`ocamlc -where`
+IUSE="+ocamlopt doc mpir"
DEPEND=">=dev-lang/ocaml-3.12.1[ocamlopt?]
- dev-libs/gmp"
+ !mpir? ( dev-libs/gmp )
+ mpir? ( sci-libs/mpir )"
RDEPEND="${DEPEND}"
src_prepare(){
@@ -24,17 +25,21 @@ src_prepare(){
}
src_configure(){
- ./configure -installdir "${D}${OCAMLDIR}" || die "configure failed"
+ MY_OPTS="-ocamllibdir /usr/$(get_libdir) -installdir ${D}/usr/$(get_libdir)/ocaml"
+ use mpir && MY_OPTS="${MY_OPTS} -mpir"
+ ./configure ${MY_OPTS}|| die || die "configure failed"
}
src_compile(){
emake || die "emake failed"
+ use doc && emake doc || die "emake doc failed"
}
src_install(){
- mkdir -p "${D}${OCAMLDIR}"
- cp "${OCAMLDIR}/ld.conf" "${D}${OCAMLDIR}/ld.conf"
+ findlib_src_preinst
+ cp /usr/$(get_libdir)/ocaml/ld.conf ${D}/usr/$(get_libdir)/ocaml/ld.conf
emake install || die "emake install failed"
- rm "${D}${OCAMLDIR}/ld.conf"
+ rm -f ${D}/usr/$(get_libdir)/ocaml/ld.conf
dodoc Changes README
+ use doc && dodoc -r html/
}