aboutsummaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/mlgmpidl/ChangeLog7
-rw-r--r--dev-ml/mlgmpidl/metadata.xml10
-rw-r--r--dev-ml/mlgmpidl/mlgmpidl-1.1.ebuild50
3 files changed, 34 insertions, 33 deletions
diff --git a/dev-ml/mlgmpidl/ChangeLog b/dev-ml/mlgmpidl/ChangeLog
index 0b8e69c49..541745051 100644
--- a/dev-ml/mlgmpidl/ChangeLog
+++ b/dev-ml/mlgmpidl/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for dev-ml/mlgmpidl
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 18 Feb 2015; Justin Lecher <jlec@gentoo.org> metadata.xml,
+ mlgmpidl-1.1.ebuild:
+ dev-ml/mlgmpidl: fix SLOT operators; fix usage of die; correct deps
+
03 Jul 2010; Jonathan-Christofer Demay <jcdemay@gmail.com>
mlgmpidl-1.1.ebuild, +files/mlgmpidl-1.1-mpfr-3_compat.patch:
dev-libs/mpfr-3.0.0 compatibility
@@ -9,4 +13,3 @@
23 Jun 2010; Andreas K. Huettel (dilfridge) <mail@akhuettel.de>
mlgmpidl-1.1.ebuild, +metadata.xml:
QA fixes
-
diff --git a/dev-ml/mlgmpidl/metadata.xml b/dev-ml/mlgmpidl/metadata.xml
index a3fac8132..2bf2d92bd 100644
--- a/dev-ml/mlgmpidl/metadata.xml
+++ b/dev-ml/mlgmpidl/metadata.xml
@@ -1,14 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-mathematics</herd>
-<longdescription>
+ <herd>sci-mathematics</herd>
+ <longdescription>
MLGMPIDL is a package offering an interface to the GMP and MPFR
libraries for OCaml version 3.07 or higher. The interface offers access
to almost all the functions of the library, and is decomposed into 7
submodules.
</longdescription>
-<use>
- <flag name="mpfr">Add support for <pkg>dev-libs/mpfr</pkg></flag>
-</use>
+ <use>
+ <flag name="mpfr">Add support for <pkg>dev-libs/mpfr</pkg></flag>
+ </use>
</pkgmetadata>
diff --git a/dev-ml/mlgmpidl/mlgmpidl-1.1.ebuild b/dev-ml/mlgmpidl/mlgmpidl-1.1.ebuild
index 10d51bde2..76b8e8d15 100644
--- a/dev-ml/mlgmpidl/mlgmpidl-1.1.ebuild
+++ b/dev-ml/mlgmpidl/mlgmpidl-1.1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="5"
+EAPI=5
inherit eutils toolchain-funcs
-DESCRIPTION="MLGMPIDL is an OCaml interface to the GMP and MPFR libraries"
+DESCRIPTION="OCaml interface to the GMP and MPFR libraries"
HOMEPAGE="http://www.inrialpes.fr/pop-art/people/bjeannet/mlxxxidl-forge/mlgmpidl/"
SRC_URI="https://gforge.inria.fr/frs/download.php/20228/${PN}-${PV}.tgz"
@@ -15,44 +15,42 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc +mpfr"
-DEPEND=">=dev-lang/ocaml-3.09
- dev-ml/camlidl
- dev-libs/gmp
- mpfr? ( dev-libs/mpfr )
- doc? ( app-text/texlive
- app-text/ghostscript-gpl )"
-RDEPEND="${DEPEND}"
+RDEPEND="
+ >=dev-lang/ocaml-3.09
+ dev-ml/camlidl
+ dev-libs/gmp:0
+ mpfr? ( dev-libs/mpfr:0 )"
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/texlive
+ app-text/ghostscript-gpl
+ )"
S="${WORKDIR}/${PN}"
src_prepare() {
- rm -R html mlgmpidl.pdf
- mv Makefile.config.model Makefile.config
- sed -i Makefile.config \
+ rm -R html mlgmpidl.pdf || die
+ mv Makefile.config.model Makefile.config || die
+ sed \
-e "s/FLAGS = \\\/FLAGS += \\\/g" \
-e "s/-O3 -UNDEBUG/-DUDEBUG/g" \
- -e "s/MLGMPIDL_PREFIX = /MLGMPIDL_PREFIX = \$(DESTDIR)\/usr/g"
+ -e "s/MLGMPIDL_PREFIX = /MLGMPIDL_PREFIX = \$(DESTDIR)\/usr/g" \
+ -i Makefile.config || die
if use !mpfr; then
- sed -i -e "s/HAS_MPFR=1/#HAS_MPFR=0/g" Makefile.config
+ sed -i -e "s/HAS_MPFR=1/#HAS_MPFR=0/g" Makefile.config || die
fi
- epatch "${FILESDIR}/${P}-mpfr-3_compat.patch"
+ epatch "${FILESDIR}"/${P}-mpfr-3_compat.patch
}
src_compile() {
- emake all gmprun gmptop -j1 || die "emake failed"
+ emake -j1 all gmprun gmptop
- if use doc; then
- make html mlgmpidl.pdf || die "emake doc failed"
- fi
+ use doc && emake html mlgmpidl.pdf
}
src_install(){
- emake install DESTDIR="${D}" || die "emake install failed"
- dodoc README
-
- if use doc; then
- dodoc mlgmpidl.pdf
- fi
+ use doc && DOCS+=( mlgmpidl.pdf )
+ default
}