aboutsummaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/lacaml/Manifest2
-rw-r--r--dev-ml/lacaml/files/API.odocl1
-rw-r--r--dev-ml/lacaml/lacaml-11.0.8.ebuild26
-rw-r--r--dev-ml/lacaml/lacaml-7.0.3.ebuild37
4 files changed, 27 insertions, 39 deletions
diff --git a/dev-ml/lacaml/Manifest b/dev-ml/lacaml/Manifest
index 0b14f909a..2dade25f2 100644
--- a/dev-ml/lacaml/Manifest
+++ b/dev-ml/lacaml/Manifest
@@ -1 +1 @@
-DIST lacaml-7.0.3.tar.gz 151742 SHA256 3ebd0b35ae0e4fe5cc5483e61a8bf1fb46ef8fed60f5c89a09e589b91b7ec982 SHA512 5f9267e64e5e2a858ba57b34ea41d64ae8724b5a6a9f9d81b6b2f2d4daeb42eb060f2b18d040d559a1baf356518c93c05db0a00af5bbf34084029e27320ad5b7 WHIRLPOOL 7af11d10e246850e2c1f39f3862b9269d783f2599cd7acd86e75662a5bf43bd2487e3ae3de2374070ea799aaef1377792d9d2d14c268742b8bf1a91975b4a2a9
+DIST lacaml-11.0.8.tar.gz 152679 BLAKE2B fd7884f943c8b7259f9f8e027e17b110c7890b27700b403f40ed129dd9664761e33940895ff692a049c02021f10268b4ec248fe5ddbc9319631a9d8856fa0999 SHA512 5fc3ef09a8acb53b1e3efb128af8a8cd6d78c7c009af423c5a02777de0a4c7d14e817f472a06ab95727745cecb1e0630c9bcf03c56d0cce9ec9355ac82e1df72
diff --git a/dev-ml/lacaml/files/API.odocl b/dev-ml/lacaml/files/API.odocl
deleted file mode 100644
index 4e6cc95b8..000000000
--- a/dev-ml/lacaml/files/API.odocl
+++ /dev/null
@@ -1 +0,0 @@
-lib/Lacaml
diff --git a/dev-ml/lacaml/lacaml-11.0.8.ebuild b/dev-ml/lacaml/lacaml-11.0.8.ebuild
new file mode 100644
index 000000000..ea091d80a
--- /dev/null
+++ b/dev-ml/lacaml/lacaml-11.0.8.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="BLAS/LAPACK interface for OCaml"
+HOMEPAGE="https://mmottl.github.io/lacaml/"
+SRC_URI="https://github.com/mmottl/lacaml/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="ocamlopt"
+
+RDEPEND="
+ virtual/blas
+ virtual/lapack
+"
+BDEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+DOCS=( "README.md" "CHANGES.txt" "TODO.md" )
diff --git a/dev-ml/lacaml/lacaml-7.0.3.ebuild b/dev-ml/lacaml/lacaml-7.0.3.ebuild
deleted file mode 100644
index a89c081a6..000000000
--- a/dev-ml/lacaml/lacaml-7.0.3.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-OASIS_BUILD_DOCS=1
-
-inherit oasis toolchain-funcs
-
-DESCRIPTION="BLAS/LAPACK interface for OCaml"
-HOMEPAGE="http://forge.ocamlcore.org/projects/lacaml"
-SRC_URI="https://bitbucket.org/mmottl/lacaml/downloads/${P}.tar.gz"
-
-LICENSE="LGPL-2.1-with-linking-exception"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-
-RDEPEND="
- virtual/blas
- virtual/lapack"
-DEPEND="${DEPEND}
- virtual/pkgconfig"
-
-DOCS=( "README.md" "CHANGES.txt" "TODO.md" )
-
-src_prepare() {
- if use doc; then
- cp "${FILESDIR}/API.odocl" . || die
- fi
- cclib="$($(tc-getPKG_CONFIG) --libs blas lapack)"
- cclib="[$(echo $cclib|sed -e 's/\(-[a-z0-9]*\) /\"\1\"\;/g' -e \
- 's/\(-[a-z0-9]*\)$/\"\1\"/')]"
- sed -i "s/cclib = \[\]/cclib = ${cclib}/" setup.conf
- #would like to do the below, but doesn't work from ebuild
- #oasis_configure_opts="--override conf_cclib $($(tc-getPKG_CONFIG) --libs blas lapack)"
-}