aboutsummaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/zarith/ChangeLog3
-rw-r--r--dev-ml/zarith/zarith-1.2.1.ebuild18
2 files changed, 11 insertions, 10 deletions
diff --git a/dev-ml/zarith/ChangeLog b/dev-ml/zarith/ChangeLog
index 434b2364a..74f1f9d0b 100644
--- a/dev-ml/zarith/ChangeLog
+++ b/dev-ml/zarith/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 16 Sep 2014; Christoph Junghans <ottxor@gentoo.org> zarith-1.2.1.ebuild:
+ clean up
+
22 Jun 2014; Jonathan-Christofer Demay <jcdemay@gmail.com>
zarith-1.2.1.ebuild:
fix regression of pkg_setup
diff --git a/dev-ml/zarith/zarith-1.2.1.ebuild b/dev-ml/zarith/zarith-1.2.1.ebuild
index 5657ff8c4..150070425 100644
--- a/dev-ml/zarith/zarith-1.2.1.ebuild
+++ b/dev-ml/zarith/zarith-1.2.1.ebuild
@@ -21,12 +21,12 @@ DEPEND=">=dev-lang/ocaml-3.12.1[ocamlopt?]
RDEPEND="${DEPEND}"
pkg_setup() {
- OCAMLDIR=$(ocamlc -where)
+ OCAMLDIR=$(ocamlc -where)
}
src_prepare(){
- sed -e "s:(OCAMLFIND) install:(OCAMLFIND) install -ldconf \$(INSTALLDIR)/ld.conf:g" \
- -i ${S}/project.mak
+ sed -e 's:(OCAMLFIND) install:(OCAMLFIND) install -ldconf $(INSTALLDIR)/ld.conf:g' \
+ -i "${S}"/project.mak
}
src_configure(){
@@ -36,17 +36,15 @@ src_configure(){
}
src_compile(){
- emake || die "emake failed"
- if use doc; then
- emake doc || die "emake doc failed"
- fi
+ emake
+ use doc && emake doc
}
src_install(){
findlib_src_preinst
- cp ${OCAMLDIR}/ld.conf ${D}/${OCAMLDIR}/ld.conf
- emake install || die "emake install failed"
- rm -f ${D}/${OCAMLDIR}/ld.conf
+ cp "${OCAMLDIR}"/ld.conf "${D}/${OCAMLDIR}"/ld.conf
+ emake install
+ rm -f "${D}/${OCAMLDIR}"/ld.conf
dodoc Changes README
use doc && dodoc -r html/
}