aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/Forthon/Forthon-0.8.13.ebuild')
-rw-r--r--dev-python/Forthon/Forthon-0.8.13.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/Forthon/Forthon-0.8.13.ebuild b/dev-python/Forthon/Forthon-0.8.13.ebuild
new file mode 100644
index 000000000..013179f79
--- /dev/null
+++ b/dev-python/Forthon/Forthon-0.8.13.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Python interface generator for Fortran based codes"
+HOMEPAGE="http://hifweb.lbl.gov/Forthon"
+SRC_URI="http://hifweb.lbl.gov/${PN}/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+python_prepare_all() {
+ sed -i -e "/data_files/ s/'License.txt',//" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ dohtml docs/index.html
+ if use examples ; then
+ docinto /usr/share/doc/${PF}
+ dodoc -r {example,simpleexample}
+ fi
+ distutils-r1_python_install_all
+}