aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/PyVISA/PyVISA-1.8.ebuild')
-rw-r--r--dev-python/PyVISA/PyVISA-1.8.ebuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/dev-python/PyVISA/PyVISA-1.8.ebuild b/dev-python/PyVISA/PyVISA-1.8.ebuild
index e16717b37..bc6311678 100644
--- a/dev-python/PyVISA/PyVISA-1.8.ebuild
+++ b/dev-python/PyVISA/PyVISA-1.8.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python2_7 python{3_4,3_5} )
+EAPI=7
+PYTHON_COMPAT=( python3_6 )
inherit distutils-r1
DESCRIPTION="Python VISA bindings for GPIB, RS232, and USB instruments"
-HOMEPAGE="https://github.com/hgrecco/pyvisa"
+HOMEPAGE="https://pyvisa.readthedocs.io"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
@@ -15,11 +15,6 @@ SLOT="0"
KEYWORDS="~amd64"
IUSE="test"
-RDEPEND="
- $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7)
- "
-DEPEND="${RDEPEND}"
-
python_test() {
esetup.py test
}