aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dandi-schema/dandi-schema-0.5.1.ebuild')
-rw-r--r--dev-python/dandi-schema/dandi-schema-0.5.1.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/dandi-schema/dandi-schema-0.5.1.ebuild b/dev-python/dandi-schema/dandi-schema-0.5.1.ebuild
deleted file mode 100644
index 19a906634..000000000
--- a/dev-python/dandi-schema/dandi-schema-0.5.1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Schemata for DANDI archive project"
-HOMEPAGE="https://github.com/dandi/dandi-schema"
-SRC_URI="https://github.com/dandi/dandi-schema/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/wheel[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/pydantic[${PYTHON_USEDEP}]
- dev-python/python-email-validator[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.3.4-coverage.patch"
-)
-
-src_configure() {
- echo "__version__ = '${PV}'" >> dandischema/_version.py
-}
-
-distutils_enable_tests pytest
-
-python_test() {
- export DANDI_TESTS_NONETWORK=1
- pushd dandischema || die
- epytest tests
- popd
-}