aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/geopandas/geopandas-0.10.2.ebuild')
-rw-r--r--dev-python/geopandas/geopandas-0.10.2.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-python/geopandas/geopandas-0.10.2.ebuild b/dev-python/geopandas/geopandas-0.10.2.ebuild
deleted file mode 100644
index 6dde1c23f..000000000
--- a/dev-python/geopandas/geopandas-0.10.2.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_PEP517="setuptools"
-inherit distutils-r1
-
-DESCRIPTION="Python tools for geographic data"
-HOMEPAGE="https://github.com/geopandas/geopandas"
-SRC_URI="https://github.com/geopandas/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/pandas[${PYTHON_USEDEP}]
- sci-libs/shapely[${PYTHON_USEDEP}]
- dev-python/fiona[${PYTHON_USEDEP}]
- dev-python/pyproj[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=(
- # disable tests due to networking being blocked
- geopandas/io/tests/test_file.py::test_read_file_remote_zipfile_url
- geopandas/io/tests/test_file.py::test_read_file_remote_geojson_url
- )
-
- epytest ${deselect[@]/#/--deselect }
-}