aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/matplotlib2tikz/matplotlib2tikz-9999.ebuild')
-rw-r--r--dev-python/matplotlib2tikz/matplotlib2tikz-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/matplotlib2tikz/matplotlib2tikz-9999.ebuild b/dev-python/matplotlib2tikz/matplotlib2tikz-9999.ebuild
new file mode 100644
index 000000000..6af9d49d6
--- /dev/null
+++ b/dev-python/matplotlib2tikz/matplotlib2tikz-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python script for converting matplotlib figures into native Pgfplots (TikZ) figures"
+HOMEPAGE="https://github.com/nschloe/matplotlib2tikz"
+
+if [ ${PV} = "9999" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/nschloe/${PN}.git git://github.com/nschloe/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/nschloe/matplotlib2tikz/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-texlive/texlive-pictures"
+DEPEND="${RDEPEND}"
+ #test? ( dev-python/pytest[${PYTHON_USEDEP}] )"