aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/matplotlib2tikz')
-rw-r--r--dev-python/matplotlib2tikz/Manifest1
-rw-r--r--dev-python/matplotlib2tikz/matplotlib2tikz-0.6.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/matplotlib2tikz/Manifest b/dev-python/matplotlib2tikz/Manifest
index d515724dd..976808712 100644
--- a/dev-python/matplotlib2tikz/Manifest
+++ b/dev-python/matplotlib2tikz/Manifest
@@ -1 +1,2 @@
DIST matplotlib2tikz-0.5.16.tar.gz 25296 SHA256 4f640fe0fe67bebc0a63f2061f4c74f13caddb4200c6fc65f006c1ae7d76325d SHA512 6155c92f3014beac1a30bb64e0adb4946a239f805a6236871a863c357afec402bfe6c9431d92867a2088a1406b23d17261a2877a39481b9130f9fe11e157de06 WHIRLPOOL f6ffdfdc147e52b7cdb5ac7a4e01d87ea869c95e4248d8cd2605ff23a503aaab3fb5e80432e48ec6b3d455f5585b2b94885a5168d0a98b773be01433fb1066c3
+DIST matplotlib2tikz-0.6.0.tar.gz 25715 SHA256 f59c67ad4858fe2a6c4a6230bf59a7f7345f5619d979a1384017736c8809eafe SHA512 b487052cd94d3650618f4146b0f84661f760d758787739dc223e064702d1e3f6ac4f369e954ff308fb74a574984ff2c28285dc8bbe9e4e4962278ab817d3e2e6 WHIRLPOOL 516595991bb6542088df607eebb12e990b203c4accb4896756b7aaa51d709bc2b05cdf609e53327f7b6250678dde5965d0bc997585434acc9802ac618cc61047
diff --git a/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.0.ebuild b/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.0.ebuild
new file mode 100644
index 000000000..2c29ff934
--- /dev/null
+++ b/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Convert matplotlib figures into native Pgfplots (TikZ) figures"
+HOMEPAGE="https://github.com/nschloe/matplotlib2tikz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pillow-3.0.0[${PYTHON_USEDEP}]
+ dev-texlive/texlive-pictures"
+DEPEND="${RDEPEND}"
+ #test? ( dev-python/pytest[${PYTHON_USEDEP}] )"