aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/protobuf-python/protobuf-python-3.11.4-r1.ebuild')
-rw-r--r--dev-python/protobuf-python/protobuf-python-3.11.4-r1.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/dev-python/protobuf-python/protobuf-python-3.11.4-r1.ebuild b/dev-python/protobuf-python/protobuf-python-3.11.4-r1.ebuild
deleted file mode 100644
index 1d447ef46..000000000
--- a/dev-python/protobuf-python/protobuf-python-3.11.4-r1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 2008-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-PYTHON_COMPAT=(python{3_7,3_8})
-DISTUTILS_USE_SETUPTOOLS="rdepend"
-
-inherit distutils-r1
-
-DESCRIPTION="Google's Protocol Buffers - Python bindings"
-HOMEPAGE="https://developers.google.com/protocol-buffers/ https://github.com/protocolbuffers/protobuf"
-SRC_URI="https://github.com/protocolbuffers/protobuf/archive/v${PV}.tar.gz -> protobuf-${PV}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/22"
-KEYWORDS="~amd64"
-IUSE=""
-
-BDEPEND="${PYTHON_DEPS}
- ~dev-libs/protobuf-${PV}
- dev-python/namespace-google[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${PYTHON_DEPS}
- ~dev-libs/protobuf-${PV}"
-RDEPEND="${BDEPEND}"
-
-S="${WORKDIR}/protobuf-${PV}/python"
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_CHECKOUT_DIR="${WORKDIR}/protobuf-${PV}"
-fi
-
-python_prepare_all() {
- pushd "${WORKDIR}/protobuf-${PV}" > /dev/null || die
- eapply "${FILESDIR}/${PN}-3.13.0-google.protobuf.pyext._message.PyUnknownFieldRef.patch"
- eapply_user
- popd > /dev/null || die
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- mydistutilsargs=(--cpp_implementation)
-}
-
-python_compile() {
- python_is_python3 || local -x CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- find "${ED}" -name "*.pth" -type f -delete || die
-}