aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/py2bit/py2bit-9999.ebuild')
-rw-r--r--dev-python/py2bit/py2bit-9999.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/dev-python/py2bit/py2bit-9999.ebuild b/dev-python/py2bit/py2bit-9999.ebuild
index 7c6c27ef2..4b1c29658 100644
--- a/dev-python/py2bit/py2bit-9999.ebuild
+++ b/dev-python/py2bit/py2bit-9999.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
@@ -23,3 +24,9 @@ SLOT="0"
DEPEND="sci-libs/lib2bit"
RDEPEND="${DEPEND}"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest "py2bitTest/test.py"
+}