aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyerfa/pyerfa-2.0.0.1-r2.ebuild')
-rw-r--r--dev-python/pyerfa/pyerfa-2.0.0.1-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pyerfa/pyerfa-2.0.0.1-r2.ebuild b/dev-python/pyerfa/pyerfa-2.0.0.1-r2.ebuild
new file mode 100644
index 000000000..11a68c169
--- /dev/null
+++ b/dev-python/pyerfa/pyerfa-2.0.0.1-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings for ERFA"
+HOMEPAGE="https://github.com/liberfa/pyerfa/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# ImportError: cannot import name 'ufunc' from 'erfa'
+RESTRICT="test"
+
+RDEPEND="
+ sci-astronomy/erfa:0=
+ >=dev-python/numpy-1.17[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-doctestplus[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+#distutils_enable_sphinx docs dev-python/sphinx-astropy