aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pysparse/files/pysparse-1.1.1-setup.patch')
-rw-r--r--dev-python/pysparse/files/pysparse-1.1.1-setup.patch56
1 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/pysparse/files/pysparse-1.1.1-setup.patch b/dev-python/pysparse/files/pysparse-1.1.1-setup.patch
deleted file mode 100644
index 3d944a3ec..000000000
--- a/dev-python/pysparse/files/pysparse-1.1.1-setup.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 1b1ee1d..cdb9ddf 100644
---- a/setup.py
-+++ b/setup.py
-@@ -19,40 +19,40 @@ linky=[]
- compily=[]
-
- # Specify whether to link against user's SuperLU library
--use_users_superlu = False #True
-+use_users_superlu = True
- umfpack_defs = [('DINT', 1), ('NBLAS', 1)] # No BLAS. Ok if using your system's BLAS.
- #umfpack_defs = [('DINT', 1), ('CBLAS', 1)] # with atlas c-blas (http://math-atlas.sf.net)
-
- if use_users_superlu:
- # Specify location of include files
-- superlu_include_dirs = ['/Users/dpo/local/linalg/SuperLU/SuperLU_3.1/SRC']
-+ superlu_include_dirs = ['/usr/include/superlu']
- # AND specify ONE of the following:
- # 1) Location of source files (overrides linking with existing library)
-- superlu_src_dir = '/Users/dpo/local/linalg/SuperLU/SuperLU_3.1/SRC'
-+ superlu_src_dir = ''
- # 2) Location of precompiled library
- superlu_lib_dir = ['']
-- superlu_libraries = ['']
-+ superlu_libraries = ['superlu']
-
- # Specify whether to link against user's UMFPACK library
--use_users_umfpack = False #True
-+use_users_umfpack = True
- if use_users_umfpack:
- # Specify location of include files
-- umfpack_include_dirs = ['/Users/dpo/local/linalg/UMFPACK/UMFPACK/Include']
-+ umfpack_include_dirs = ['']
- # AND specify ONE of the following:
- # 1) Location of source files (overrides linking with existing library)
-- umfpack_src_dir = '/Users/dpo/local/linalg/UMFPACK/UMFPACK/Source'
-+ umfpack_src_dir = ''
- # 2) Location of precompiled library
- umfpack_lib_dir = ['']
-- umfpack_libraries = ['']
-+ umfpack_libraries = ['umfpack']
-
- # Do the same for AMD
-- amd_include_dirs = ['/Users/dpo/local/linalg/UMFPACK/AMD/Include']
-+ amd_include_dirs = ['']
- # AND specify ONE of the following:
- # 1) Location of source files (overrides linking with existing library)
-- amd_src_dir = '/Users/dpo/local/linalg/UMFPACK/AMD/Source'
-+ amd_src_dir = ''
- # 2) Location of precompiled library
- amd_lib_dir = ['']
-- amd_libraries = ['']
-+ amd_libraries = ['amd']
-
- else:
- umfpack_libraries = []