aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pywcs/pywcs-1.7.ebuild')
-rw-r--r--dev-python/pywcs/pywcs-1.7.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pywcs/pywcs-1.7.ebuild b/dev-python/pywcs/pywcs-1.7.ebuild
new file mode 100644
index 000000000..b41f30960
--- /dev/null
+++ b/dev-python/pywcs/pywcs-1.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+inherit distutils
+
+WCS_V=4.4.4
+MYP="${P}-${WCS_V}"
+
+DESCRIPTION="Python routines for handling the FITS World Coordinate System"
+HOMEPAGE="https://www.stsci.edu/trac/ssb/astrolib/"
+SRC_URI="http://stsdas.stsci.edu/astrolib/${MYP}.tar.gz"
+
+DEPEND="dev-python/pyfits"
+# FIX: remove shipped wcslib to use system one
+RDEPEND="${DEPEND}"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="AURA"
+
+S="${WORKDIR}/${MYP}"
+
+src_test() {
+ # FIX: does not work, needs fits files
+ PYTHONPATH=$(dir -d build/lib*) "${python}" test/test.py || die
+}