aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/snuggs/snuggs-1.4.7.ebuild')
-rw-r--r--dev-python/snuggs/snuggs-1.4.7.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/snuggs/snuggs-1.4.7.ebuild b/dev-python/snuggs/snuggs-1.4.7.ebuild
new file mode 100644
index 000000000..be3395de7
--- /dev/null
+++ b/dev-python/snuggs/snuggs-1.4.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_10 )
+DISTUTILS_USE_PEP517="setuptools"
+inherit distutils-r1
+
+DESCRIPTION="S-expressions for numpy"
+HOMEPAGE="https://github.com/mapbox/snuggs"
+SRC_URI="https://github.com/mapbox/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( dev-python/hypothesis[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest