aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinxcontrib-napoleon/sphinxcontrib-napoleon-0.7-r1.ebuild')
-rw-r--r--dev-python/sphinxcontrib-napoleon/sphinxcontrib-napoleon-0.7-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-napoleon/sphinxcontrib-napoleon-0.7-r1.ebuild b/dev-python/sphinxcontrib-napoleon/sphinxcontrib-napoleon-0.7-r1.ebuild
new file mode 100644
index 000000000..0a962fd5e
--- /dev/null
+++ b/dev-python/sphinxcontrib-napoleon/sphinxcontrib-napoleon-0.7-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Allow a different format in dosctrings for better clarity"
+HOMEPAGE="https://sphinxcontrib-napoleon.readthedocs.io/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/pockets[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}