aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/vo/files/vo-0.5-expat.patch')
-rw-r--r--dev-python/vo/files/vo-0.5-expat.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/vo/files/vo-0.5-expat.patch b/dev-python/vo/files/vo-0.5-expat.patch
new file mode 100644
index 000000000..7bbd7a84a
--- /dev/null
+++ b/dev-python/vo/files/vo-0.5-expat.patch
@@ -0,0 +1,23 @@
+Using system expat
+
+Patch written by Kacper Kowalik <xarthisius.kk@gmail.com>
+
+--- setup.py
++++ setup.py
+@@ -13,14 +13,9 @@
+
+ iterparse_ext = Extension(
+ "vo.iterparser",
+- ["src/iterparse.c",
+- "src/expat/xmlparse.c",
+- "src/expat/xmlrole.c",
+- "src/expat/xmltok.c",
+- "src/expat/xmltok_impl.c",
+- "src/expat/xmltok_ns.c"],
++ ["src/iterparse.c",],
+ define_macros=defines,
+- include_dirs=["src", "src/expat"])
++ libraries=["expat"])
+
+ setup(name="vo",
+ version="0.5",