aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/annexremote/Manifest3
-rw-r--r--dev-python/annexremote/annexremote-1.6.0.ebuild25
-rw-r--r--dev-python/annexremote/annexremote-1.6.5.ebuild (renamed from dev-python/annexremote/annexremote-1.5.0.ebuild)11
-rw-r--r--dev-python/asciitree/Manifest2
-rw-r--r--dev-python/asciitree/asciitree-0.3.3.ebuild8
-rw-r--r--dev-python/hdmf/Manifest1
-rw-r--r--dev-python/hdmf/hdmf-3.13.0.ebuild2
-rw-r--r--dev-python/hdmf/hdmf-3.14.3.ebuild31
-rw-r--r--dev-python/nwb2bids/Manifest1
-rw-r--r--dev-python/nwb2bids/metadata.xml15
-rw-r--r--dev-python/nwb2bids/nwb2bids-0.0.3.ebuild25
-rw-r--r--dev-python/pybedtools/Manifest1
-rw-r--r--dev-python/pybedtools/metadata.xml15
-rw-r--r--dev-python/pybedtools/pybedtools-0.10.0.ebuild41
-rw-r--r--dev-python/pynwb/Manifest2
-rw-r--r--dev-python/pynwb/pynwb-2.6.0.ebuild4
-rw-r--r--dev-python/pynwb/pynwb-2.8.1.ebuild (renamed from dev-python/pynwb/pynwb-2.5.0.ebuild)12
-rw-r--r--dev-python/wraps/Manifest1
-rw-r--r--dev-python/wraps/wraps-0.13.0.ebuild24
-rw-r--r--dev-python/wraps/wraps-0.2.0.ebuild2
20 files changed, 180 insertions, 46 deletions
diff --git a/dev-python/annexremote/Manifest b/dev-python/annexremote/Manifest
index c5eac671a..24005e3bc 100644
--- a/dev-python/annexremote/Manifest
+++ b/dev-python/annexremote/Manifest
@@ -1,2 +1 @@
-DIST annexremote-1.5.0.tar.gz 73544 BLAKE2B f5b528faf3d390f9bba6fb97768318ab04224cf05941a2606d49edda7bde30d743bf8e492f277986c0eda62f4000e1446e048d932df436cc2075b1f3e536c7d2 SHA512 7307f5ead82d449eda8b27a83f314b112bfe243a50f556397aed0f563452db6b4ba06b68aacaa27ff722ec9ccd2bdc489a3a8f4f3d849354757bd2fff8ae50d0
-DIST annexremote-1.6.0.tar.gz 74199 BLAKE2B 27956c5ea4789a1bd22bfabe6e0da8a5c8700ba50c3c28610b364d6b358f195124667381094c7786a825fae4464a340b36fd61cd09956477101c7bfd54ba8166 SHA512 1320e06fb3bebe65cce872af6adfb702d9d44cad1671ab8fd432137eb44f22cbd35744b889f11900379da2512fb79da0972c0326fcf3e51c6a404fe497e20ea4
+DIST annexremote-1.6.5.gh.tar.gz 49349 BLAKE2B 226c80c41205da14f03b69d94142f5d39abad46aaa8bb84bbb98a83aa0bdc03df908316f3bef0ef6c425d775dc6b63732319bbec8c7ddffbbfcb3b55b84a8f8c SHA512 067d7371ddb0955ad95e208f5bfc22e5c9d3ba48a694794da0eeab6c2fd5523d32ff4bf53b7e33ecefb86629a1395d29d7e30e2b09880ced295745431acd178d
diff --git a/dev-python/annexremote/annexremote-1.6.0.ebuild b/dev-python/annexremote/annexremote-1.6.0.ebuild
deleted file mode 100644
index a6dacd5c9..000000000
--- a/dev-python/annexremote/annexremote-1.6.0.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-inherit distutils-r1 pypi
-
-DESCRIPTION="Helper module to easily develop git-annex remotes"
-HOMEPAGE="https://github.com/Lykos153/AnnexRemote"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples"
-# Tests require nose, reported upstream:
-# https://github.com/Lykos153/AnnexRemote/issues/61
-RESTRICT="test"
-
-python_install_all() {
- distutils-r1_python_install_all
- dodoc README.md
- use examples && dodoc -r examples
-}
diff --git a/dev-python/annexremote/annexremote-1.5.0.ebuild b/dev-python/annexremote/annexremote-1.6.5.ebuild
index a6dacd5c9..39e5f7b09 100644
--- a/dev-python/annexremote/annexremote-1.5.0.ebuild
+++ b/dev-python/annexremote/annexremote-1.6.5.ebuild
@@ -4,22 +4,23 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-inherit distutils-r1 pypi
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1
DESCRIPTION="Helper module to easily develop git-annex remotes"
HOMEPAGE="https://github.com/Lykos153/AnnexRemote"
+SRC_URI="https://github.com/Lykos153/AnnexRemote/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/AnnexRemote-${PV}"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="examples"
-# Tests require nose, reported upstream:
-# https://github.com/Lykos153/AnnexRemote/issues/61
-RESTRICT="test"
python_install_all() {
distutils-r1_python_install_all
dodoc README.md
use examples && dodoc -r examples
}
+
+distutils_enable_tests pytest
diff --git a/dev-python/asciitree/Manifest b/dev-python/asciitree/Manifest
index 5ea004309..4ed32749e 100644
--- a/dev-python/asciitree/Manifest
+++ b/dev-python/asciitree/Manifest
@@ -1 +1 @@
-DIST asciitree-0.3.3.tar.gz 8765 BLAKE2B 85b935d9a0df286cd14bb7828335608a2fa2b7acd83707ab61ba29ca58b452a378758ec3553d2845a2536150fd0c9c2bfeb25e95d6bdf02c3d023156e1065e8e SHA512 82ec368db5c3302640860aadeefc89ef2bc74a4336a46729d2688591454b6c1ab1f1fe9fc5305bc956c9998f27bca9e55aeee3bfb82bdf24a67955953e7e37f0
+DIST asciitree-0.3.3.gh.tar.gz 8765 BLAKE2B 85b935d9a0df286cd14bb7828335608a2fa2b7acd83707ab61ba29ca58b452a378758ec3553d2845a2536150fd0c9c2bfeb25e95d6bdf02c3d023156e1065e8e SHA512 82ec368db5c3302640860aadeefc89ef2bc74a4336a46729d2688591454b6c1ab1f1fe9fc5305bc956c9998f27bca9e55aeee3bfb82bdf24a67955953e7e37f0
diff --git a/dev-python/asciitree/asciitree-0.3.3.ebuild b/dev-python/asciitree/asciitree-0.3.3.ebuild
index 29d5ecf87..77d99c826 100644
--- a/dev-python/asciitree/asciitree-0.3.3.ebuild
+++ b/dev-python/asciitree/asciitree-0.3.3.ebuild
@@ -3,17 +3,17 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
inherit distutils-r1
DESCRIPTION="ASCII trees in python"
HOMEPAGE="https://github.com/mbr/asciitree"
-SRC_URI="https://github.com/mbr/asciitree/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/mbr/asciitree/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
distutils_enable_tests pytest
diff --git a/dev-python/hdmf/Manifest b/dev-python/hdmf/Manifest
index 204753b4e..f6cb13732 100644
--- a/dev-python/hdmf/Manifest
+++ b/dev-python/hdmf/Manifest
@@ -1 +1,2 @@
DIST hdmf-3.13.0.tar.gz 15855926 BLAKE2B 8eb386540768a83954745c02f7142d2a0b466ef670baaf13a1dfee0ce02261f0f89a9b173dfb8d2673d1f538c35e800117f6f0fe2ca77e5ca6a94b01e9908917 SHA512 5d6f97abb28b46136b3a62f915f8c14cc48e49c1ec3d44e3d863b1c3e7aebb1cfea428b77311ca51dbf5ef9a1e529e73cdb477d863e3d0cd6641fbf79a043f20
+DIST hdmf-3.14.3.tar.gz 15844443 BLAKE2B 6789a0df9133dd4920776159f699af7dc22a036e8bf18d0c5914f7598b085b927abdbe2ffb8a6d430b0aa452a6e8686f525faff05707c01210a1a405b4a38511 SHA512 f7df7c3b669dc5ab12e7cd533d01ba324b184ce7b1364a783bfb13993c27a535df394bb58ffaff4d6ab0a5a991a7ae40174cf16274bd30e9cd5e0c27e731ec82
diff --git a/dev-python/hdmf/hdmf-3.13.0.ebuild b/dev-python/hdmf/hdmf-3.13.0.ebuild
index 7068afb01..dd6f0176f 100644
--- a/dev-python/hdmf/hdmf-3.13.0.ebuild
+++ b/dev-python/hdmf/hdmf-3.13.0.ebuild
@@ -11,8 +11,8 @@ DESCRIPTION="The Hierarchical Data Modeling Framework"
HOMEPAGE="https://github.com/hdmf-dev/hdmf"
SRC_URI="$(pypi_sdist_url hdmf)"
-SLOT="0"
LICENSE="BSD"
+SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="
diff --git a/dev-python/hdmf/hdmf-3.14.3.ebuild b/dev-python/hdmf/hdmf-3.14.3.ebuild
new file mode 100644
index 000000000..c6249ef14
--- /dev/null
+++ b/dev-python/hdmf/hdmf-3.14.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="The Hierarchical Data Modeling Framework"
+HOMEPAGE="https://github.com/hdmf-dev/hdmf"
+SRC_URI="$(pypi_sdist_url hdmf)"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ "
+
+#PATCHES=(
+# "${FILESDIR}/${PN}-3.11.0-no_test_coverage.patch"
+# )
+
+distutils_enable_tests pytest
diff --git a/dev-python/nwb2bids/Manifest b/dev-python/nwb2bids/Manifest
new file mode 100644
index 000000000..5e85ba08f
--- /dev/null
+++ b/dev-python/nwb2bids/Manifest
@@ -0,0 +1 @@
+DIST nwb2bids-0.0.3.tar.gz 7054 BLAKE2B 0ebd50a557dea2fb878247d28949e287722cd71a43bd477a404dfbe1d999e94d1aff0421c4e338a354e5f09a3aee8b9258a2191ae6a108c32ed4f56b650b9d39 SHA512 9df9efecb39b55e2712ce825950e472cbe9e076e6901ab44d84f7cbb23c1f7c9b1f0ae71a5684adeae61d42662ee288c5464db0ff616888aadc4fd08549dc85b
diff --git a/dev-python/nwb2bids/metadata.xml b/dev-python/nwb2bids/metadata.xml
new file mode 100644
index 000000000..6dc951583
--- /dev/null
+++ b/dev-python/nwb2bids/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@chymera.eu</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">con/nwb2bids</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/nwb2bids/nwb2bids-0.0.3.ebuild b/dev-python/nwb2bids/nwb2bids-0.0.3.ebuild
new file mode 100644
index 000000000..5f778356e
--- /dev/null
+++ b/dev-python/nwb2bids/nwb2bids-0.0.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Next-generation file format (NGFF) for storing bioimaging data in the cloud"
+HOMEPAGE="https://github.com/con/nwb2bids"
+SRC_URI="https://github.com/con/nwb2bids/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ test? (
+ dev-python/pynwb[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/pybedtools/Manifest b/dev-python/pybedtools/Manifest
new file mode 100644
index 000000000..7db62a4c4
--- /dev/null
+++ b/dev-python/pybedtools/Manifest
@@ -0,0 +1 @@
+DIST pybedtools-0.10.0.tar.gz 12497095 BLAKE2B d9fb44bd3afcb8748e0cadbe0c4d55c7325911331d0719b79bd04eff264bd6299d407dee7f511bc05a7e12dd46e92a9c25ce0607b8926e6542e4dd652cc9d23f SHA512 cec04464fcfaa12bb660f223d6f656a30ac5822ea9053455dbc5717d2afbc998db9fd4b7424d8458445450a6ce5aafb65463fa1274b2691b26bfda7fe84bef56
diff --git a/dev-python/pybedtools/metadata.xml b/dev-python/pybedtools/metadata.xml
new file mode 100644
index 000000000..b80afba97
--- /dev/null
+++ b/dev-python/pybedtools/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mschu.dev@gmail.com</email>
+ <name>Michael Schubert</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-biology@gentoo.org</email>
+ <name>Gentoo Biology Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">daler/pybedtools</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pybedtools/pybedtools-0.10.0.ebuild b/dev-python/pybedtools/pybedtools-0.10.0.ebuild
new file mode 100644
index 000000000..ae51c24ce
--- /dev/null
+++ b/dev-python/pybedtools/pybedtools-0.10.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_EXT=1
+inherit distutils-r1
+
+DESCRIPTION="Use BED and GFF files from python using BEDtools"
+HOMEPAGE="https://daler.github.io/pybedtools"
+SRC_URI="https://github.com/daler/pybedtools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ sci-biology/bedtools
+ sci-biology/pysam[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+"
+
+# TODO: fix docs building
+# ModuleNotFoundError: No module named 'pybedtools.cbedtools'
+# even if pybedtools is installed
+#distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
+python_test() {
+ # Requires network
+ local EPYTEST_DESELECT=(
+ test/test_helpers.py::test_chromsizes
+ )
+ cd "${T}" || die
+ epytest --pyargs pybedtools
+}
diff --git a/dev-python/pynwb/Manifest b/dev-python/pynwb/Manifest
index 0dffbb9ab..8fdf8cf68 100644
--- a/dev-python/pynwb/Manifest
+++ b/dev-python/pynwb/Manifest
@@ -1,2 +1,2 @@
-DIST pynwb-2.5.0.tar.gz 620770 BLAKE2B 470f5127560bf79f112061e9e8af208051d76833e449a66b03e31bb0828ffbfd6aa0b9efc136ecc0b7efba758334c3f15525a41ec4540c6f55d02f8afbd55ab2 SHA512 cad84e3ac6c3c67c3c28e3c3ec44402bfc94c4cf988fbe64ddfa461a67115398b24bb9bcac1bd00933e1b63d73048d9b20ec6cd736a51d9f2c7bf4d294edb261
DIST pynwb-2.6.0.tar.gz 625188 BLAKE2B ac179af7e3c9de6ec4fb841dfd6279a1c3ba191b9d786553af02397a49c511f4a257a0e62f3b57a217ebb08588ad8ca64219fd435b3ec25776775d05e6a9ab9b SHA512 5c830cb37e8c6fe0643bd5bfee947565ddb1d0eff16dadadd3ebec7ec14a6e1ebcf34c3909ad05c3eedd8dd5f9e3669348216d695123f2013de0e969a403ec1c
+DIST pynwb-2.8.1.tar.gz 34769136 BLAKE2B b7fb44380b35edb07da5030c559ce5b7ffb73f7ffa4a00ce838544a124b644eb293232bcd6b9a3d999256eaa102e4ca68aff5302e3cdff342ba42a1fc9ebc403 SHA512 ba2c74b889b725f5abf20b337c9de89357900d5316cd2de0bff5548a1bf3fe80078c05e2652b8cfd76aedcab58457e86cb15e2decd9eb22729b148b3a7b28637
diff --git a/dev-python/pynwb/pynwb-2.6.0.ebuild b/dev-python/pynwb/pynwb-2.6.0.ebuild
index 2f403981c..c19c57fe3 100644
--- a/dev-python/pynwb/pynwb-2.6.0.ebuild
+++ b/dev-python/pynwb/pynwb-2.6.0.ebuild
@@ -4,14 +4,14 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
DESCRIPTION="A Python API for working with Neurodata stored in the NWB Format "
HOMEPAGE="https://github.com/NeurodataWithoutBorders/pynwb"
-SLOT="0"
LICENSE="BSD"
+SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="
diff --git a/dev-python/pynwb/pynwb-2.5.0.ebuild b/dev-python/pynwb/pynwb-2.8.1.ebuild
index ca11c3dbe..1fb2ba26a 100644
--- a/dev-python/pynwb/pynwb-2.5.0.ebuild
+++ b/dev-python/pynwb/pynwb-2.8.1.ebuild
@@ -3,19 +3,22 @@
EAPI=8
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+#DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
DESCRIPTION="A Python API for working with Neurodata stored in the NWB Format "
HOMEPAGE="https://github.com/NeurodataWithoutBorders/pynwb"
-SLOT="0"
LICENSE="BSD"
+SLOT="0"
KEYWORDS="~amd64 ~x86"
+# Segfault error on testing
+RESTRICT="test"
RDEPEND="
- >=dev-python/hdmf-3.3.2[${PYTHON_USEDEP}]
+ >=dev-python/hdmf-3.14.3[${PYTHON_USEDEP}]
>=sci-libs/hdf5-1.12.2
dev-python/h5py[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
@@ -45,6 +48,7 @@ EPYTEST_DESELECT=(
# Not sandboxed, reported upstream:
# https://github.com/NeurodataWithoutBorders/pynwb/issues/1800
tests/read_dandi/test_read_dandi.py::TestReadNWBDandisets::test_read_first_nwb_asset
+ tests/unit/test_base.py::TestTimeSeries::test_repr_html
)
distutils_enable_tests pytest
diff --git a/dev-python/wraps/Manifest b/dev-python/wraps/Manifest
index 44510a1dd..a41862ec8 100644
--- a/dev-python/wraps/Manifest
+++ b/dev-python/wraps/Manifest
@@ -1 +1,2 @@
+DIST wraps-0.13.0.tar.gz 31074 BLAKE2B 96aee060660765de4efb15e0fc55bbbe7745acd8458781330105c448e85da6cc16b2ec94fbadb78a27690226f0b222bf3c476fde6a4e4d8c9a78fd11353d7abf SHA512 4858d8bb2ed0ac410c1d3997fac7c7e576feb888713dd3e1ddb26151c7ab6eea274997fe0df9d5661cc88f3fa553b83e4e01d9784f39f8b85ed5c9e8b9e13749
DIST wraps-0.2.0.tar.gz 25308 BLAKE2B b68359d34995f7bc39535e97458807a5d55e3547124ccb8b34f9cd34fe1d3b38921a3a0c16df031410022f74d414aba97af9e9f60a20fb635428030bc400b130 SHA512 daf72785c3215db06f4bf06704f02c7ecfd1ef5c58dbf5c50b2dee14755d73b519f8a13be9658bf825c296689d9b3effd08aec4254779812583c1024522751f0
diff --git a/dev-python/wraps/wraps-0.13.0.ebuild b/dev-python/wraps/wraps-0.13.0.ebuild
new file mode 100644
index 000000000..bed0a104e
--- /dev/null
+++ b/dev-python/wraps/wraps-0.13.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1 pypi
+
+DESCRIPTION=" Meaningful and safe wrapping types. "
+HOMEPAGE="https://github.com/nekitdev/wraps"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+# package does not have test suite (yet)
+
+RDEPEND="
+ >=dev-python/attrs-21.4.0[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.2.0[${PYTHON_USEDEP}]
+ "
+
+distutils_enable_tests pytest
diff --git a/dev-python/wraps/wraps-0.2.0.ebuild b/dev-python/wraps/wraps-0.2.0.ebuild
index b06b511cd..dd2a9b24f 100644
--- a/dev-python/wraps/wraps-0.2.0.ebuild
+++ b/dev-python/wraps/wraps-0.2.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1 pypi
DESCRIPTION=" Meaningful and safe wrapping types. "