aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/matplotlib/Manifest4
-rw-r--r--dev-python/matplotlib/files/digest-matplotlib-0.87.2-r13
-rw-r--r--dev-python/matplotlib/matplotlib-0.87.2-r1.ebuild75
-rw-r--r--dev-python/matplotlib/matplotlib-0.87.2-r2.ebuild6
-rw-r--r--dev-python/numarray/Manifest4
-rw-r--r--dev-python/numarray/files/digest-numarray-1.5.1-r11
-rw-r--r--dev-python/numarray/numarray-1.5.1-r1.ebuild43
-rw-r--r--dev-python/numarray/numarray-1.5.1-r2.ebuild4
-rw-r--r--dev-python/numpy/Manifest4
-rw-r--r--dev-python/numpy/numpy-0.9.6-r1.ebuild2
-rw-r--r--dev-python/numpy/numpy-0.9.8.ebuild2
-rw-r--r--dev-python/pygsl/Manifest2
-rw-r--r--dev-python/pygsl/pygsl-0.3.2.ebuild2
13 files changed, 13 insertions, 139 deletions
diff --git a/dev-python/matplotlib/Manifest b/dev-python/matplotlib/Manifest
index 67fbf78f7..c59ea019b 100644
--- a/dev-python/matplotlib/Manifest
+++ b/dev-python/matplotlib/Manifest
@@ -1,8 +1,6 @@
MD5 bdabc2e7127281c149ddf332c8d1f4bc ChangeLog 4550
-MD5 164457a27c959174cc2933d826190f3d files/digest-matplotlib-0.87.2-r1 192
MD5 164457a27c959174cc2933d826190f3d files/digest-matplotlib-0.87.2-r2 192
MD5 bf815cadfdb2159e83dffd0862545458 files/matplotlib-0.87.2-no-autodetect.patch 1817
MD5 802d475da9c3232949f87351fd10847b files/matplotlib-mplot3d.patch 918
-MD5 bdf28f13337a15989272fbffc517c0dc matplotlib-0.87.2-r1.ebuild 1782
-MD5 f2f313186d19eeaeb142db835c5eb20b matplotlib-0.87.2-r2.ebuild 1878
+MD5 891d047cce95525816177ea762d2b5cb matplotlib-0.87.2-r2.ebuild 1873
MD5 7d1fbbf5496138b3b2f2f07ec757fecb metadata.xml 428
diff --git a/dev-python/matplotlib/files/digest-matplotlib-0.87.2-r1 b/dev-python/matplotlib/files/digest-matplotlib-0.87.2-r1
deleted file mode 100644
index c293c85ba..000000000
--- a/dev-python/matplotlib/files/digest-matplotlib-0.87.2-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 74dde3c3e33797f56ebd6ca578090f8e matplotlib-0.87.2.tar.gz 2655790
-MD5 41884cf53ede9a635b6ecc08dd2bd6fc mpl3d.zip 179714
-MD5 bcc272707e7db06b8a3aab36c6317e03 users_guide_0.87.1.pdf 4675932
diff --git a/dev-python/matplotlib/matplotlib-0.87.2-r1.ebuild b/dev-python/matplotlib/matplotlib-0.87.2-r1.ebuild
deleted file mode 100644
index 74a957e53..000000000
--- a/dev-python/matplotlib/matplotlib-0.87.2-r1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit distutils python
-
-DESCRIPTION="Python plotting library with Matlab like syntax"
-HOMEPAGE="http://matplotlib.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
- mplot3d? http://matplotlib.sourceforge.net/mpl3d.zip
- doc? http://matplotlib.sourceforge.net/users_guide_0.87.1.pdf"
-
-IUSE="doc gtk tcltk wxpython mplot3d"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-LICENSE="PYTHON"
-
-DEPEND="virtual/python
- || (
- >=dev-python/numeric-22
- dev-python/numarray
- dev-python/numpy
- )
- >=media-libs/freetype-2.1.7
- media-libs/libpng
- sys-libs/zlib
- gtk? ( >=dev-python/pygtk-1.99.16 )
- wxpython? ( dev-python/wxpython )
- dev-python/pytz
- dev-python/python-dateutil"
-
-
-pkg_setup() {
- if use tcltk; then
- python_tkinter_exists
- fi
-}
-
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
-
- # disable autodetection, rely on USE instead
- epatch "${FILESDIR}/${PN}-0.87.2-no-autodetect.patch"
- sed -i \
- -e "/^BUILD_GTK/s/'auto'/$(use gtk && echo 1 || echo 0)/g" \
- -e "/^BUILD_WX/s/'auto'/$(use wxpython && echo 1 || echo 0)/g" \
- -e "/^BUILD_TK/s/'auto'/$(use tcltk && echo 1 || echo 0)/g" \
- setup.py
-
- # patch to apply for mplot3d
- # http://www.scipy.org/Cookbook/Matplotlib/mplot3D
- if use mplot3d; then
- cd ${WORKDIR}/3d
- epatch "${FILESDIR}/${PN}-mplot3d.patch"
- fi
-
-}
-
-src_install() {
- distutils_src_install
-
- use mplot3d && cp -r ${WORKDIR}/3d \
- ${D}/usr/$(get_libdir)/python2.4/site-packages/mpl3d
-
- if use doc ; then
- insinto /usr/share/doc/${PF}/examples
- doins examples/*.py examples/README
- insinto /usr/share/doc/${PF}/examples/data
- doins examples/data/*.dat
- insinto /usr/share/doc/${PF}/
- doins ${DISTDIR}/users_guide_*.pdf
- fi
-}
diff --git a/dev-python/matplotlib/matplotlib-0.87.2-r2.ebuild b/dev-python/matplotlib/matplotlib-0.87.2-r2.ebuild
index f68301670..6b8fa2f8e 100644
--- a/dev-python/matplotlib/matplotlib-0.87.2-r2.ebuild
+++ b/dev-python/matplotlib/matplotlib-0.87.2-r2.ebuild
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
mplot3d? http://matplotlib.sourceforge.net/mpl3d.zip
doc? http://matplotlib.sourceforge.net/users_guide_0.87.1.pdf"
-IUSE="doc gtk tcltk wxpython mplot3d agg"
+IUSE="doc gtk tcltk wxwindows mplot3d agg"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
LICENSE="PYTHON"
@@ -25,10 +25,10 @@ DEPEND="virtual/python
media-libs/libpng
sys-libs/zlib
gtk? ( >=dev-python/pygtk-1.99.16 )
- wxpython? ( dev-python/wxpython )
+ wxwindows? ( dev-python/wxpython )
dev-python/pytz
dev-python/python-dateutil
- agg? ( x11-libs/agg )"
+ agg? ( x11-libs/agg )"
pkg_setup() {
if use tcltk; then
diff --git a/dev-python/numarray/Manifest b/dev-python/numarray/Manifest
index 6ada167ba..691ffa717 100644
--- a/dev-python/numarray/Manifest
+++ b/dev-python/numarray/Manifest
@@ -1,6 +1,4 @@
MD5 3e0700df75a48ebda06597d7613108cd ChangeLog 2650
-MD5 3b253945667c1a85499157ac13dd220c files/digest-numarray-1.5.1-r1 67
MD5 3b253945667c1a85499157ac13dd220c files/digest-numarray-1.5.1-r2 67
MD5 37520cfe4faa14a59f09635d2328cbeb files/numarray-1.5.1-include.patch 2479
-MD5 c0d179b38525d0edd04153b5f207d79d numarray-1.5.1-r1.ebuild 1104
-MD5 2fc20693917253db6902e502f5e96c14 numarray-1.5.1-r2.ebuild 1630
+MD5 da04b59a3fc0c3af5aafae8fab07b318 numarray-1.5.1-r2.ebuild 1616
diff --git a/dev-python/numarray/files/digest-numarray-1.5.1-r1 b/dev-python/numarray/files/digest-numarray-1.5.1-r1
deleted file mode 100644
index 7b08102ba..000000000
--- a/dev-python/numarray/files/digest-numarray-1.5.1-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 e6c282b950f4383f294134424ae58f3b numarray-1.5.1.tar.gz 1196883
diff --git a/dev-python/numarray/numarray-1.5.1-r1.ebuild b/dev-python/numarray/numarray-1.5.1-r1.ebuild
deleted file mode 100644
index b65eff376..000000000
--- a/dev-python/numarray/numarray-1.5.1-r1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit distutils
-
-DESCRIPTION="Large array processing extension module for Python"
-SRC_URI="mirror://sourceforge/numpy/${P}.tar.gz"
-HOMEPAGE="http://www.stsci.edu/resources/software_hardware/numarray"
-# force blas-atlas because we don't have a virtual/cblas
-DEPEND=">=dev-lang/python-2.3
- lapack? ( sci-libs/blas-atlas )
- lapack? ( virtual/lapack )"
-IUSE="lapack"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-LICENSE="BSD"
-
-src_unpack() {
- unpack ${A};
- cd ${S}
- if use lapack; then
- local myblas="/usr/$(get_libdir)/blas/atlas"
- [ -d "/usr/$(get_libdir)/blas/threaded-atlas" ] && \
- myblas=${myblas/threaded-/}
- sed -i cfg_packages.py \
- -e 's:/usr/local/lib/atlas:${myblas}:g' \
- -e 's:/usr/local/include/atlas:/usr/include/atlas:g' \
- -e 's:f77blas:blas:g'
- fi
-}
-
-src_compile() {
- export USE_LAPACK=1
- distutils_src_compile
-}
-
-src_install() {
- distutils_src_install
- dodoc Doc/*.txt LICENSE.txt
- cp -r Doc/*.py Doc/manual Doc/release_notes \
- Examples ${D}/usr/share/doc/${PF}
-}
diff --git a/dev-python/numarray/numarray-1.5.1-r2.ebuild b/dev-python/numarray/numarray-1.5.1-r2.ebuild
index 06ca4901d..542bdaea9 100644
--- a/dev-python/numarray/numarray-1.5.1-r2.ebuild
+++ b/dev-python/numarray/numarray-1.5.1-r2.ebuild
@@ -35,11 +35,11 @@ src_unpack() {
-e 's:f77blas:blas:g' \
cfg_packages.py
# fix gfortran for > gcc-4
- if [[ ${FORTRANC} == gfortran ]]; then
+ if [[ ${FORTRANC} == gfortran ]]; then
sed -i \
-e "s:g2c:gfortran:g" \
cfg_packages.py
- fi
+ fi
fi
}
diff --git a/dev-python/numpy/Manifest b/dev-python/numpy/Manifest
index 7267d3dc6..624ad2b58 100644
--- a/dev-python/numpy/Manifest
+++ b/dev-python/numpy/Manifest
@@ -1,5 +1,5 @@
MD5 678efbebdaf7f7a91c909bcf9ef950b7 ChangeLog 1036
MD5 3d1644c7fef9abd10cb81c674838b436 files/digest-numpy-0.9.6-r1 63
MD5 8f0b986d41688c7bf8b416bc3d1844e9 files/digest-numpy-0.9.8 63
-MD5 b92abce8fdd92dcf11a3bf96958718a3 numpy-0.9.6-r1.ebuild 1283
-MD5 68ca04306f725389d7818eca0a7cc157 numpy-0.9.8.ebuild 1279
+MD5 9185a676f9b9d796c4d7aaf5c91b9895 numpy-0.9.6-r1.ebuild 1281
+MD5 676da0fa8756c208acb6436aae93cfca numpy-0.9.8.ebuild 1277
diff --git a/dev-python/numpy/numpy-0.9.6-r1.ebuild b/dev-python/numpy/numpy-0.9.6-r1.ebuild
index 4f31bf3f5..0a9f98525 100644
--- a/dev-python/numpy/numpy-0.9.6-r1.ebuild
+++ b/dev-python/numpy/numpy-0.9.6-r1.ebuild
@@ -41,7 +41,7 @@ src_unpack() {
echo "/usr/$(get_libdir)/blas/threaded-atlas" >> site.cfg
else
echo "/usr/$(get_libdir)/blas/atlas" >> site.cfg
- fi
+ fi
else
export ATLAS=None
fi
diff --git a/dev-python/numpy/numpy-0.9.8.ebuild b/dev-python/numpy/numpy-0.9.8.ebuild
index 1ffbfda2a..f321a99d1 100644
--- a/dev-python/numpy/numpy-0.9.8.ebuild
+++ b/dev-python/numpy/numpy-0.9.8.ebuild
@@ -41,7 +41,7 @@ src_unpack() {
echo "/usr/$(get_libdir)/blas/threaded-atlas" >> site.cfg
else
echo "/usr/$(get_libdir)/blas/atlas" >> site.cfg
- fi
+ fi
else
export ATLAS=None
fi
diff --git a/dev-python/pygsl/Manifest b/dev-python/pygsl/Manifest
index 470682cca..2c954ef26 100644
--- a/dev-python/pygsl/Manifest
+++ b/dev-python/pygsl/Manifest
@@ -1,4 +1,4 @@
MD5 558ce1827738174d750ef5a399e3313b ChangeLog 322
MD5 a1e9632a05c6f3f684cddbdedf9e199d files/digest-pygsl-0.3.2 63
MD5 ccbe84622d692bf05d6894f19b432239 metadata.xml 388
-MD5 299e1832318aabd9b9ee355de0533547 pygsl-0.3.2.ebuild 529
+MD5 1add887179dfee46aac975cdcedff768 pygsl-0.3.2.ebuild 528
diff --git a/dev-python/pygsl/pygsl-0.3.2.ebuild b/dev-python/pygsl/pygsl-0.3.2.ebuild
index e6549afc0..cee57acf8 100644
--- a/dev-python/pygsl/pygsl-0.3.2.ebuild
+++ b/dev-python/pygsl/pygsl-0.3.2.ebuild
@@ -12,7 +12,7 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=">=dev-lang/python-2.2
+DEPEND=">=dev-lang/python-2.2
>=sci-libs/gsl-1.4
dev-python/numeric"