aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/smartgit/smartgit-0_alpha4.ebuild')
-rw-r--r--dev-util/smartgit/smartgit-0_alpha4.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/smartgit/smartgit-0_alpha4.ebuild b/dev-util/smartgit/smartgit-0_alpha4.ebuild
new file mode 100644
index 000000000..7ed07cbfa
--- /dev/null
+++ b/dev-util/smartgit/smartgit-0_alpha4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit java-utils-2
+
+DESCRIPTION="SmartGIT"
+HOMEPAGE="http://www.syntevo.com/smartgit"
+SRC_URI="${PN}-generic-1-M4.tar.gz"
+
+SLOT="0"
+LICENSE="smartgit"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT="fetch"
+
+RDEPEND=">=virtual/jre-1.4.1"
+
+S="${WORKDIR}"/smartgit-1-M4/
+
+pkg_nofetch(){
+ einfo "Please download ${MY_P}.tar.gz from:"
+ einfo "http://www.syntevo.com/smartgit/early-access.html"
+ einfo "and move/copy to ${DISTDIR}"
+}
+
+src_install() {
+ local rdir="/opt/${PN}"
+ insinto ${rdir}
+ doins -r * || die "cannot install needed files"
+
+ java-pkg_regjar "${D}"/${rdir}/lib/*.jar
+
+ java-pkg_dolauncher ${PN} --java_args "-Xmx256M -Dsmartgit.vm-xmx=256m" --jar ${PN}.jar
+
+ for X in 32 64 128
+ do
+ insinto /usr/share/icons/hicolor/${X}x${X}/apps
+ newins "${S}/bin/icon-${X}.png" "${PN}.png" || die "cannot install needed files"
+ done
+
+ make_desktop_entry "${PN}" "SmartGIT" ${PN}.png "Development;RevisionControl"
+}